]> git.pld-linux.org Git - packages/gg.git/blob - gg.spec
- massive change ( validate errors warrings from desktop-file-validate)
[packages/gg.git] / gg.spec
1 # Conditional build:
2 #
3 %bcond_without  gnome           # don't build with GNOME
4 %bcond_without  gnome_applet    # don't build GNOME applet
5 %bcond_without  kde             # don't build KDE applet
6 %bcond_without  wm_applet       # don't build WM applet
7 %bcond_without  sound           # disable sound support
8 #
9 # This looks like overkill but some day we might have *everything* bconded :)
10 %{?with_gnome:%define           need_gnome      1}
11 %{?with_gnome:%define           need_esd        1}
12 %{?with_gnome_applet:%define    need_gnome      1}
13 %{?with_gnome_applet:%define    nees_esd        1}
14 %{?with_kde:%define             need_arts       1}
15 %{?with_wm_applet:%define       need_esd        1}
16 #
17 Summary:        GNU Gadu - free talking
18 Summary(pl.UTF-8):      GNU Gadu - wolne gadanie
19 Name:           gg
20 Version:        1.0.0
21 Release:        3
22 Epoch:          5
23 License:        GPL
24 Group:          Applications/Communications
25 Source0:        http://dl.sourceforge.net/ggadu/%{name}-%{version}.tar.gz
26 # Source0-md5:  7b32d4c866ef59dfe22373a83b1a9a2a
27 Source1:        %{name}.png
28 Source2:        %{name}_gnome.desktop
29 Source3:        %{name}_WM_applet.desktop
30 Source4:        %{name}_KDE.desktop
31 Patch0:         http://piorun.ds.pg.gda.pl/~blues/patches/gg-debian_fixes.patch
32 URL:            http://gadu.gnu.pl/
33 %{?need_arts:BuildRequires:     arts-devel}
34 %if %{with sound}
35 %{?need_esd:BuildRequires:      esound-devel > 0.2.7}
36 %endif
37 %{?need_gnome:BuildRequires:    gnome-libs-devel}
38 %{?need_gnome:BuildRequires:    gnome-core-devel}
39 BuildRequires:  gtk+-devel > 1.2.8
40 BuildRequires:  xmms-devel
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _sysconfdir     /etc/X11/GNOME
44 %define         _prefix                 /usr/X11R6
45
46 %description
47 Gadu-Gadu client released on GNU/GPL.
48
49 %description -l pl.UTF-8
50 Klient Gadu-Gadu na licencji GNU/GPL.
51
52 %package common
53 Summary:        GNU Gadu - free talking - common files
54 Summary(pl.UTF-8):      GNU Gadu - wolne gadanie - wspólne pliki
55 Group:          Applications/Communications
56 Obsoletes:      gg =< 0.2.0
57
58 %description common
59 Gadu-Gadu client released on GNU/GPL.
60
61 %description common -l pl.UTF-8
62 Klient Gadu-Gadu na licencji GNU/GPL.
63
64 %package X11
65 Summary:        GNU Gadu - free talking
66 Summary(pl.UTF-8):      GNU Gadu - wolne gadanie
67 Group:          Applications/Communications
68 PreReq:         %{name}-common = %{epoch}:%{version}
69 Provides:       gg = %{epoch}:%{version}-%{release}
70
71 %description X11
72 Gadu-Gadu client released on GNU/GPL.
73
74 %description X11 -l pl.UTF-8
75 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla X11.
76
77 %package gnome
78 Summary:        GNU Gadu - free talking - GNOME version
79 Summary(pl.UTF-8):      GNU Gadu - wolne gadanie - wersja dla GNOME
80 Group:          Applications/Communications
81 PreReq:         %{name}-common = %{epoch}:%{version}
82 Provides:       gg = %{epoch}:%{version}-%{release}
83
84 %description gnome
85 Gadu-Gadu client released on GNU/GPL. GNOME version
86
87 %description gnome -l pl.UTF-8
88 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla GNOME.
89
90 %package gnome-applet
91 Summary:        GNU Gadu - free talking - GNOME dockable version
92 Summary(pl.UTF-8):      GNU Gadu - wolne gadanie - wersja dokowalna dla GNOME
93 Group:          Applications/Communications
94 PreReq:         %{name}-common = %{epoch}:%{version}
95 Provides:       gg = %{epoch}:%{version}-%{release}
96
97 %description gnome-applet
98 Gadu-Gadu client released on GNU/GPL. GNOME dockable version
99
100 %description gnome-applet -l pl.UTF-8
101 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dokowalna dla GNOME.
102
103 %package wm-applet
104 Summary:        GNU Gadu - free talking - WindowMaker dockable version
105 Summary(pl.UTF-8):      GNU Gadu - wolne gadanie - wersja dokowalna dla WindowMaker'a
106 Group:          Applications/Communications
107 PreReq:         %{name}-common = %{epoch}:%{version}
108 Provides:       gg = %{epoch}:%{version}-%{release}
109
110 %description wm-applet
111 Gadu-Gadu client released on GNU/GPL. WindowMaker dockable version
112
113 %description wm-applet -l pl.UTF-8
114 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dokowalna dla
115 WindowMaker'a.
116
117 %package kde
118 Summary:        GNU Gadu - free talking - KDE version
119 Summary(pl.UTF-8):      GNU Gadu - wolne gadanie - wersja dla KDE
120 Group:          Applications/Communications
121 PreReq:         %{name}-common = %{epoch}:%{version}
122 Provides:       gg = %{epoch}:%{version}-%{release}
123
124 %description kde
125 Gadu-Gadu client released on GNU/GPL. KDE version
126
127 %description kde -l pl.UTF-8
128 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla KDE.
129
130 %prep
131 %setup -q
132 %patch0 -p1
133
134 %build
135 LDFLAGS=" -L%{_libdir} %{rpmldflags}"
136
137 %if %{with gnome_applet}
138 %configure \
139         %{!?with_sound:--disable-esd} \
140         --enable-gnome \
141         --enable-panel \
142         --enable-xmms
143 %{__make}
144 mv -f src/gg src/gg_applet
145 %{__make} clean
146 %endif
147
148 %if %{with gnome}
149 %configure \
150         %{!?with_sound:--disable-esd} \
151         --enable-gnome \
152         --enable-xmms
153 %{__make}
154 mv -f src/gg src/gg_gnome
155 %{__make} clean
156 %endif
157
158 %if %{with wm_applet}
159 %configure \
160         %{!?with_sound:--disable-esd} \
161         --enable-dockapp \
162         --enable-xmms
163 %{__make}
164 mv -f src/gg src/gg_wm
165 %{__make} clean
166 %endif
167
168 %if %{with kde}
169 %configure \
170         --enable-docklet \
171         %{?with_sound:--enable-arts} \
172         --disable-esd \
173         --enable-xmms
174 %{__make}
175 mv -f src/gg src/gg_kde
176 %{__make} clean
177 %endif
178
179 %configure %{!?with_sound:--disable-esd} --enable-xmms
180 %{__make}
181
182 %install
183 rm -rf $RPM_BUILD_ROOT
184 install -d $RPM_BUILD_ROOT{%{_applnkdir}/Network/Communications,%{_datadir}/applets/Network} \
185         $RPM_BUILD_ROOT{%{_sysconfdir}/CORBA/servers,%{_pixmapsdir}}
186
187 %{__make} install \
188         DESTDIR=$RPM_BUILD_ROOT
189
190 %{?with_gnome_applet:install src/gg_applet $RPM_BUILD_ROOT%{_bindir}}
191 %{?with_gnome:install src/gg_gnome $RPM_BUILD_ROOT%{_bindir}}
192 %{?with_wm_applet:install src/gg_wm $RPM_BUILD_ROOT%{_bindir}}
193 %{?with_kde:install src/gg_kde $RPM_BUILD_ROOT%{_bindir}}
194
195 sed -e 's/xpm$/png/' src/GnuGadu.desktop \
196         > $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu.desktop
197 sed -e 's/xpm$/png/' -e 's/Exec=gg/Exec=gg_applet\ --activate-goad-server=gg/' \
198         src/GnuGadu.desktop > $RPM_BUILD_ROOT%{_datadir}/applets/Network/GnuGadu.desktop
199
200 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
201 install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu_gnome.desktop
202 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/applets/Network/GnuGadu_WM_applet.desktop
203 install %{SOURCE4} $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu_KDE.desktop
204 install src/GnuGadu.gnorba $RPM_BUILD_ROOT%{_sysconfdir}/CORBA/servers/
205
206 %clean
207 rm -rf $RPM_BUILD_ROOT
208
209 %files common
210 %defattr(644,root,root,755)
211 %doc README ChangeLog TODO
212 %{_datadir}/gg
213 %{_pixmapsdir}/*
214
215 %files X11
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_bindir}/gg
218 %{_applnkdir}/Network/Communications/GnuGadu.desktop
219
220 %if %{with gnome}
221 %files gnome
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{_bindir}/gg_gnome
224 %{_applnkdir}/Network/Communications/GnuGadu_gnome.desktop
225 %endif
226
227 %if %{with gnome_applet}
228 %files gnome-applet
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_bindir}/gg_applet
231 %{_datadir}/applets/Network/GnuGadu.desktop
232 %{_sysconfdir}/CORBA/servers/GnuGadu.gnorba
233 %endif
234
235 %if %{with wm_applet}
236 %files wm-applet
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_bindir}/gg_wm
239 %{_datadir}/applets/Network/GnuGadu_WM_applet.desktop
240 %endif
241
242 %if %{with kde}
243 %files kde
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_bindir}/gg_kde
246 %{_applnkdir}/Network/Communications/GnuGadu_KDE.desktop
247 %endif
This page took 0.072217 seconds and 3 git commands to generate.