]> git.pld-linux.org Git - packages/gfs2.git/commitdiff
- removed outdated install patch
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 28 May 2011 04:40:39 +0000 (04:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added llh patch to use userspace linux-libc-headers
- added blkid patch to use libblkid instead of obsolete libvolume_id
- added quota-nolist patch to drop quota list support (withdrawn)
- some cleanups; build only gfs2 from this spec; other parts of 2nd generation
  cluster are present in separate specs

Changed files:
    gfs2-blkid.patch -> 1.1
    gfs2-install.patch -> 1.2
    gfs2-llh.patch -> 1.1
    gfs2-quota-nolist.patch -> 1.1
    gfs2.spec -> 1.9

gfs2-blkid.patch [new file with mode: 0644]
gfs2-install.patch [deleted file]
gfs2-llh.patch [new file with mode: 0644]
gfs2-quota-nolist.patch [new file with mode: 0644]
gfs2.spec

diff --git a/gfs2-blkid.patch b/gfs2-blkid.patch
new file mode 100644 (file)
index 0000000..a950e9c
--- /dev/null
@@ -0,0 +1,72 @@
+--- cluster-2.03.10/gfs2/mkfs/main_mkfs.c.orig 2008-12-09 09:36:04.000000000 +0100
++++ cluster-2.03.10/gfs2/mkfs/main_mkfs.c      2011-05-23 19:32:57.164084076 +0200
+@@ -12,10 +12,10 @@
+ #include <stdarg.h>
+ #include <mntent.h>
++#include <blkid/blkid.h>
+ #include <linux/types.h>
+ #include "libgfs2.h"
+ #include "gfs2_mkfs.h"
+-#include "libvolume_id.h"
+ char *prog_name;
+@@ -258,33 +258,35 @@
+ static void are_you_sure(struct gfs2_sbd *sdp)
+ {
+       char input[32];
+-      struct volume_id *vid = NULL;
++      blkid_probe pr;
+       int fd;
+       fd = open(sdp->device_name, O_RDONLY);
+       if (fd < 0)
+               die("Error: device %s not found.\n", sdp->device_name);
+-      vid = volume_id_open_fd(fd);
+-      if (vid == NULL) {
++      pr = blkid_new_probe();
++      if (pr == NULL) {
+               close(fd);
+               die("error identifying the contents of %s: %s\n",
+                   sdp->device_name, strerror(errno));
+       }
+       printf("This will destroy any data on %s.\n", sdp->device_name);
+-      if (volume_id_probe_all(vid, 0, sdp->device_size) == 0) {
++      blkid_probe_set_request(pr, BLKID_PROBREQ_TYPE | BLKID_PROBREQ_USAGE);
++      if ((blkid_probe_set_device(pr, fd, 0, sdp->device_size) == 0) &&
++          (blkid_do_safeprobe(pr) == 0)) {
+               const char *fstype, *fsusage;
+               int rc;
+-              rc = volume_id_get_type(vid, &fstype);
++              rc = blkid_probe_lookup_value(pr, "TYPE", &fstype, NULL);
+               if (rc) {
+-                      rc = volume_id_get_usage(vid, &fsusage);
++                      rc = blkid_probe_lookup_value(pr, "USAGE", &fsusage, NULL);
+                       if (!rc || strncmp(fsusage, "other", 5) == 0)
+                               fsusage = "partition";
+                       printf("  It appears to contain a %s %s.\n", fstype,
+                              fsusage);
+               }
+       }
+-      volume_id_close(vid);
++      blkid_free_probe(pr);
+       close(fd);
+       printf("\nAre you sure you want to proceed? [y/n] ");
+       fgets(input, 32, stdin);
+--- cluster-2.03.10/gfs2/mkfs/Makefile.orig    2011-05-23 18:20:05.000000000 +0200
++++ cluster-2.03.10/gfs2/mkfs/Makefile 2011-05-23 18:21:26.757273752 +0200
+@@ -20,11 +20,10 @@
+       main_jadd.o
+ CFLAGS += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_GNU_SOURCE
+-CFLAGS += -I${volidincdir}
+ CFLAGS += -I$(S)/../include -I$(S)/../libgfs2
+ CFLAGS += -I${incdir}
+-LDFLAGS += -L${volidlibdir} -lvolume_id
++LDFLAGS += -lblkid
+ LDFLAGS += -L../libgfs2 -lgfs2
diff --git a/gfs2-install.patch b/gfs2-install.patch
deleted file mode 100644 (file)
index b545148..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur cluster-2.00.00/gfs2/mkfs/Makefile cluster-2.00.00-o/gfs2/mkfs/Makefile
---- cluster-2.00.00/gfs2/mkfs/Makefile 2007-04-05 14:34:25.000000000 -0600
-+++ cluster-2.00.00-o/gfs2/mkfs/Makefile       2006-08-22 13:16:39.000000000 -0600
-@@ -35,7 +35,7 @@
- install: all
-       ${INSTALL} -m 0755 ${MKFS} ${sbindir}
--      ln -f ${MKFS} ${sbindir}/${JADD}
-+      ln -s ${MKFS} ${sbindir}/${JADD}
- clean:
-       rm -f *.o ${MKFS} ${JADD}
diff --git a/gfs2-llh.patch b/gfs2-llh.patch
new file mode 100644 (file)
index 0000000..1b5c4ec
--- /dev/null
@@ -0,0 +1,30 @@
+--- cluster-2.03.10/gfs2/libgfs2/Makefile.orig 2008-12-09 09:36:04.000000000 +0100
++++ cluster-2.03.10/gfs2/libgfs2/Makefile      2011-05-23 18:01:19.803900005 +0200
+@@ -9,7 +9,6 @@ include $(OBJDIR)/make/install.mk
+ include $(OBJDIR)/make/uninstall.mk
+ CFLAGS += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_GNU_SOURCE
+-CFLAGS += -I${KERNEL_SRC}/fs/gfs2/ -I${KERNEL_SRC}/include/
+ CFLAGS += -I$(S)/../include
+ CFLAGS += -I${incdir}
+ CFLAGS += -fPIC
+--- cluster-2.03.10/gfs2/mkfs/Makefile.orig    2008-12-09 09:36:04.000000000 +0100
++++ cluster-2.03.10/gfs2/mkfs/Makefile 2011-05-23 18:16:57.367264732 +0200
+@@ -20,7 +20,6 @@
+       main_jadd.o
+ CFLAGS += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_GNU_SOURCE
+-CFLAGS += -I${KERNEL_SRC}/include/
+ CFLAGS += -I${volidincdir}
+ CFLAGS += -I$(S)/../include -I$(S)/../libgfs2
+ CFLAGS += -I${incdir}
+--- cluster-2.03.10/gfs2/quota/Makefile.orig   2008-12-09 09:36:04.000000000 +0100
++++ cluster-2.03.10/gfs2/quota/Makefile        2011-05-23 19:35:46.334089741 +0200
+@@ -15,7 +15,6 @@
+       check.o
+ CFLAGS += -DHELPER_PROGRAM -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
+-CFLAGS += -I${KERNEL_SRC}/fs/gfs2/ -I${KERNEL_SRC}/include/
+ CFLAGS += -I$(S)/../include -I$(S)/../libgfs2
+ CFLAGS += -I${incdir}
diff --git a/gfs2-quota-nolist.patch b/gfs2-quota-nolist.patch
new file mode 100644 (file)
index 0000000..0fea2dc
--- /dev/null
@@ -0,0 +1,255 @@
+--- cluster-2.03.10/gfs2/libgfs2/ondisk.c.orig 2008-12-09 09:36:04.000000000 +0100
++++ cluster-2.03.10/gfs2/libgfs2/ondisk.c      2011-05-23 18:13:36.813924684 +0200
+@@ -217,8 +217,7 @@ void gfs2_quota_in(struct gfs2_quota *qu
+       CPIN_64(qu, str, qu_limit);
+       CPIN_64(qu, str, qu_warn);
+       CPIN_64(qu, str, qu_value);
+-      CPIN_32(qu, str, qu_ll_next);
+-      CPIN_08(qu, str, qu_reserved, 60);
++      CPIN_08(qu, str, qu_reserved, 64);
+ }
+ void gfs2_quota_out(struct gfs2_quota *qu, char *buf)
+@@ -228,8 +227,7 @@ void gfs2_quota_out(struct gfs2_quota *q
+       CPOUT_64(qu, str, qu_limit);
+       CPOUT_64(qu, str, qu_warn);
+       CPOUT_64(qu, str, qu_value);
+-      CPOUT_32(qu, str, qu_ll_next);
+-      CPOUT_08(qu, str, qu_reserved, 60);
++      CPOUT_08(qu, str, qu_reserved, 64);
+ }
+ void gfs2_quota_print(struct gfs2_quota *qu)
+--- cluster-2.03.10/gfs2/quota/main.c.orig     2008-12-09 09:36:04.000000000 +0100
++++ cluster-2.03.10/gfs2/quota/main.c  2011-05-27 23:17:21.726106878 +0200
+@@ -374,106 +374,6 @@
+ }
+ /**
+- * is_valid_quota_list - Check if we have a valid quota list
+- * @fd: an open file descriptor of the quota file
+- * Returns 0 or 1.
+- */
+-int 
+-is_valid_quota_list(int fd)
+-{
+-      /* This is a slow test to determine if the quotas are in a 
+-       * linked list. We should come up with something better
+-       * Quota linked list format is identified by the following.
+-       * step1: Get the maximum groupid and userid having valid
+-       *        quotas in the quota file.
+-       * step2: Obtain the size of the quota file. The size of the 
+-       *        quota file (position of the last valid quota) 
+-       *        determines the last user/group id.
+-       * step3: If we can obtain the last valid quota through the 
+-       *        lists, then our lists are good. Else, the lists are 
+-       *        either corrupt or an older quota file format is in use
+-       */
+-      int id_type = GQ_ID_GROUP;
+-      uint32_t id = 0, prev, ulast = 0, glast = 0, max;
+-      struct gfs2_quota q;
+-
+-      get_last_quota_id(fd, &max);
+-again:
+-      do {
+-              read_quota_internal(fd, id, id_type, &q);
+-              prev = id;
+-              id = q.qu_ll_next;
+-              if (id > max)
+-                      return 0;
+-      } while (id && id > prev);
+-
+-      if (id && id <= prev)
+-              return 0;
+-
+-      if (id_type == GQ_ID_GROUP)
+-              glast = prev;
+-      else
+-              ulast = prev;
+-
+-      if (id_type == GQ_ID_GROUP) {
+-              id_type = GQ_ID_USER;
+-              id = 0;
+-              goto again;
+-      }
+-
+-      if (glast != max && ulast != max)
+-              return 0;
+-      
+-      return 1;
+-}
+-
+-void 
+-print_quota_list_warning()
+-{
+-      printf("\nWarning: This filesystem doesn't seem to have the new quota "
+-             "list format or the quota list is corrupt. list, check and init "
+-             "operation performance will suffer due to this. It is recommended "
+-             "that you run the 'gfs2_quota reset' operation to reset the quota "
+-             "file. All current quota information will be lost and you will "
+-             "have to reassign all quota limits and warnings\n\n"); 
+-}
+-
+-/**
+- * adjust_quota_list - Adjust the quota linked list
+- * @fd: The quota file descriptor
+- * @comline: the struct containing the parsed command line arguments
+- */
+-static void
+-adjust_quota_list(int fd, commandline_t *comline)
+-{
+-      uint32_t prev = 0, next = 0, id = comline->id;
+-      struct gfs2_quota tmpq, q;
+-      int id_type = comline->id_type;
+-      
+-      if (id == 0) /* root quota, don't do anything */
+-              goto out;
+-      /* We just wrote the quota for id in do_set(). Get it */
+-      next = 0;
+-      do {
+-              read_quota_internal(fd, next, id_type, &q);
+-              prev = next;
+-              next = q.qu_ll_next;
+-              if (prev == id) /* no duplicates, bail */
+-                      goto out;
+-              if (prev < id && id < next) /* gotcha! */
+-                      break;
+-      } while(next && next > prev);
+-      read_quota_internal(fd, id, id_type, &tmpq);
+-      tmpq.qu_ll_next = next;
+-      q.qu_ll_next = id;
+-      write_quota_internal(fd, id, id_type, &tmpq);
+-      write_quota_internal(fd, prev, id_type, &q);
+-
+-out:
+-      return;
+-}
+-
+-/**
+  * do_reset - Reset all the quota data for a filesystem
+  * @comline: the struct containing the parsed command line arguments
+  */
+@@ -512,11 +412,9 @@
+       }
+       read_quota_internal(fd, 0, GQ_ID_USER, &q);
+-      q.qu_ll_next = 0;
+       write_quota_internal(fd, 0, GQ_ID_USER, &q);
+       read_quota_internal(fd, 0, GQ_ID_GROUP, &q);
+-      q.qu_ll_next = 0;
+       write_quota_internal(fd, 0, GQ_ID_GROUP, &q);
+       /* truncate the quota file such that only the first
+@@ -568,29 +466,6 @@
+                   strerror(errno));
+       }
+       
+-      if (!is_valid_quota_list(fd)) {
+-              print_quota_list_warning();
+-              goto do_old_school;
+-      }
+-      get_last_quota_id(fd, &maxid);
+-      
+-      for (pass=0; pass<2; pass++) {
+-              id = 0;
+-              id_type = pass ? GQ_ID_GROUP : GQ_ID_USER;
+-              
+-              do {
+-                      read_quota_internal(fd, id, id_type, &q);
+-                      prev = id;
+-                      if (q.qu_limit || q.qu_warn || q.qu_value)
+-                              print_quota(comline, 
+-                                          id_type == GQ_ID_USER ? TRUE : FALSE, 
+-                                          id, &q, &sdp->sd_sb);
+-                      id = q.qu_ll_next;
+-              } while(id && id > prev && id <= maxid);
+-      }
+-      goto out;
+-
+-do_old_school:
+       for (pass=0; pass<2; pass++) {
+               if (!pass)
+                       offset = 0;
+@@ -615,7 +490,6 @@
+                       offset += 2 * sizeof(struct gfs2_quota);
+               } while (error == sizeof(struct gfs2_quota));
+       }
+-out:
+       close(fd);
+       close(sdp->metafs_fd);
+       cleanup_metafs(sdp);
+@@ -789,7 +663,7 @@
+       int fd;
+       uint64_t offset;
+       uint64_t new_value;
+-      int error, adj_flag = 0;;
++      int error;
+       char quota_file[BUF_SIZE];
+       char id_str[16];
+       struct stat stat_buf;
+@@ -816,11 +690,6 @@
+                   strerror(errno));
+       }
+       
+-      if (is_valid_quota_list(fd))
+-              adj_flag = 1;
+-      else
+-              print_quota_list_warning();
+-
+       switch (comline->id_type) {
+       case GQ_ID_USER:
+               offset = (2 * (uint64_t)comline->id) * sizeof(struct gfs2_quota);
+@@ -938,8 +807,6 @@
+       set_sysfs(fs, comline->id_type == GQ_ID_USER ?
+                 "quota_refresh_user" : "quota_refresh_group", id_str);
+       
+-      if (adj_flag)
+-              adjust_quota_list(fd, comline);
+ out:
+       close(fd);
+       close(sdp->metafs_fd);
+--- cluster-2.03.10/gfs2/quota/check.c.orig    2008-12-09 09:36:04.000000000 +0100
++++ cluster-2.03.10/gfs2/quota/check.c 2011-05-27 23:16:22.309438221 +0200
+@@ -194,33 +194,6 @@
+                   strerror(errno));
+       }
+-      if (!is_valid_quota_list(fd)) {
+-              print_quota_list_warning();
+-              goto do_old_school;
+-      }
+-      get_last_quota_id(fd, &maxid);
+-      
+-      for (pass=0; pass<2; pass++) {
+-              id = 0;
+-              id_type = pass ? GQ_ID_GROUP : GQ_ID_USER;
+-              
+-              do {
+-                      read_quota_internal(fd, id, id_type, &q);
+-                      prev = id;
+-                      q.qu_value <<= sdp->sd_sb.sb_bsize_shift - 9;
+-                      
+-                      if (q.qu_value) {
+-                              if (pass)
+-                                      add_value(gid, id, q.qu_value);
+-                              else
+-                                      add_value(uid, id, q.qu_value);
+-                      }
+-                      id = q.qu_ll_next;
+-              } while(id && id > prev && id <= maxid);
+-      }
+-      goto out;
+-      
+-do_old_school:
+       do {
+               
+               memset(buf, 0, sizeof(struct gfs2_quota));
+@@ -249,7 +222,6 @@
+               offset += sizeof(struct gfs2_quota);
+       } while (error == sizeof(struct gfs2_quota));
+-out:
+       close(fd);
+       close(sdp->metafs_fd);
+       cleanup_metafs(sdp);
index 74f0488ff88a7a3e70a9f11088913e15da466b67..9686b76a9c3ab9b3997c1bbf1cc4150ae5c2fa6c 100644 (file)
--- a/gfs2.spec
+++ b/gfs2.spec
@@ -1,25 +1,17 @@
+# NOTE:
+# - for 3rd generation cluster see cluster.spec
+# - gfs2 and dlm kernel modules are in the kernel package
+#   (2.6.28.9-3 for example); gfs is the old GFS.
 #
 # TODO:
-#      - update patch0
-#      - cleanup files section
-#      - change from gfs2 to cluster
-#      - move to cluster-3 (for kernels 2.6.29+)
-#      - split cluster pkg to gfs2, gfs, fence, dlm, rmanager,
-#        ccs, cman, group
-#      - more kernel stuff (gnbd, ...), but gnbd looks dead,
-#        use iscsi, fc, aoe, nbd or sth instead
-#      - optflags
-#   - fixup -n cluster package mess, subpackages, duplicate files, external libs and so on
-#   - is this pkg obsolete by gfs.spec with 2.03?
-# INFO:
-#      - gfs2 and dlm kernel modules are in the kernel package
-#        (2.6.28.9-3 for example); gfs is the old GFS.
+# - more kernel stuff (gnbd, ...), but gnbd looks dead,
+#   use iscsi, fc, aoe, nbd or sth instead
 #
 # Conditional build:
 %bcond_without dist_kernel     # without distribution kernel
-%bcond_with    kernel          # don't build kernel module
+%bcond_with    kernel          # build kernel module
 %bcond_without userspace       # don't build userspace package
-%bcond_with    verbose
+%bcond_with    verbose         # verbose kernel module build
 
 %if %{without kernel}
 %undefine      with_dist_kernel
@@ -43,18 +35,20 @@ License:    GPL v2
 Group:         Applications/System
 Source0:       ftp://sources.redhat.com/pub/cluster/releases/cluster-%{version}.tar.gz
 # Source0-md5: 379b560096e315d4b52e238a5c72ba4a
-Patch0:                %{name}-install.patch
-Patch1:                %{name}-kernel-2.6.28.patch
+Patch0:                %{name}-kernel-2.6.28.patch
+Patch1:                %{name}-llh.patch
+Patch2:                %{name}-blkid.patch
+Patch3:                %{name}-quota-nolist.patch
 URL:           http://sources.redhat.com/cluster/gfs/
-BuildRequires: libvolume_id-devel
-BuildRequires: linux-libc-headers >= 7:2.6.20
+BuildRequires: libblkid-devel >= 2.16
+# which exactly version merged qq_ll_next into reserved in gfs2_quota struct?
+BuildRequires: linux-libc-headers >= 7:2.6.38
 BuildRequires: ncurses-devel
 BuildRequires: openais-devel
 BuildRequires: perl-base
 %if %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.27
 %endif
-
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sbindir        /sbin
@@ -66,8 +60,8 @@ between them (with FC, iSCSI, NBD, etc...). GFS reads and writes to
 the block device like a local filesystem, but also uses a lock module
 to allow the computers coordinate their I/O so filesystem consistency
 is maintained. One of the nifty features of GFS is perfect consistency
--- changes made to the filesystem on one machine show up immediately on all
-other machines in the cluster.
+- changes made to the filesystem on one machine show up immediately on
+all other machines in the cluster.
 
 %description -l pl.UTF-8
 GFS (Global File System) to klastrowy system plików. Pozwala klastrowi
@@ -80,15 +74,9 @@ szykownych możliwości GFS-a jest idealna spójność - zmiany wykonane w
 systemie plików na jednej maszynie natychmiast pokazują się na
 wszystkich innych maszynach w klastrze.
 
-%package -n cluster
-Summary:       Cluster stuff
-Group:         Applications/System
-
-%description -n cluster
-The rest of the cluster stuff.
-
 %package -n kernel%{_alt_kernel}-misc-gfs
 Summary:       gfs kernel module
+Summary(pl.UTF-8):     Moduł jądra gfs
 Release:       %{rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 Requires(post,postun): /sbin/depmod
@@ -101,8 +89,12 @@ Provides:   kernel(gfs) = %{version}-%{rel}
 %description -n kernel%{_alt_kernel}-misc-gfs
 gfs kernel module.
 
+%description -n kernel%{_alt_kernel}-misc-gfs -l pl.UTF-8
+Moduł jądra gfs.
+
 %package -n kernel%{_alt_kernel}-misc-gnbd
 Summary:       gnbd kernel module
+Summary(pl.UTF-8):     Moduł jądra gnbd
 Release:       %{rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 Requires(post,postun): /sbin/depmod
@@ -115,14 +107,18 @@ Provides: kernel(gnbd) = %{version}-%{rel}
 %description -n kernel%{_alt_kernel}-misc-gnbd
 gnbd kernel module.
 
+%description -n kernel%{_alt_kernel}-misc-gnbd -l pl.UTF-8
+Moduł jądra gnbd.
+
 %prep
 %setup -q -n cluster-%{version}
-#patch0 -p1
+%patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+
+%{__perl} -pi -e 's/-lncurses/-lncurses -ltinfo/' gfs2/edit/Makefile
 
-sed -i -e 's,-Wall,%{rpmcflags} -I/usr/include/ncurses -Wall,' make/defines.mk.input
-sed -i -e 's/ -ggdb / %{rpmcflags} /' gfs2/libgfs2/Makefile
-sed -i -e 's/ -O2 -ggdb / %{rpmcflags} /' gfs2/mkfs/Makefile
 %if %{with kernel}
 # gfs
 sed -i -e "s,\.\./\.\./\.\.,$PWD," gfs-kernel/src/gfs/Makefile
@@ -134,15 +130,22 @@ sed -i -e "s,\$(OBJDIR),$PWD," gnbd-kernel/src/Makefile
 
 %build
 ./configure \
+       --cc="%{__cc}" \
+       --cflags="%{rpmcflags} -Wall" \
+       --ldflags="%{rpmldflags}" \
+       --incdir=%{_includedir} \
+       --ncursesincdir=%{_includedir}/ncurses \
        --libdir=%{_libdir} \
+       --libexecdir=%{_libdir} \
        --mandir=%{_mandir} \
        --prefix=%{_prefix} \
        --sbindir=%{_sbindir} \
-       --ncursesincdir=/usr/include/ncurses \
+       --without_gfs \
+       --without_gnbd \
        --without_kernel_modules
 
 %if %{with userspace}
-%{__make}
+%{__make} -C %{name}
 %endif
 
 %if %{with kernel}
@@ -155,7 +158,7 @@ export KBUILD_NOPEDANTIC=1
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with userspace}
-%{__make} install \
+%{__make} -C %{name} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
@@ -173,247 +176,15 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_sbindir}/*gfs2*
+%attr(755,root,root) %{_sbindir}/fsck.gfs2
+%attr(755,root,root) %{_sbindir}/gfs2_*
+%attr(755,root,root) %{_sbindir}/mkfs.gfs2
+%attr(755,root,root) %{_sbindir}/mount.gfs2
+%attr(755,root,root) %{_sbindir}/umount.gfs2
 %attr(754,root,root) /etc/rc.d/init.d/gfs2
-%{_mandir}/man?/*gfs2*
-%{_docdir}/cluster/gfs2.txt
-
-%files -n cluster
-%defattr(644,root,root,755)
-%attr(754,root,root) /etc/rc.d/init.d/cman
-%attr(754,root,root) /etc/rc.d/init.d/gfs
-%attr(754,root,root) /etc/rc.d/init.d/qdiskd
-%attr(754,root,root) /etc/rc.d/init.d/rgmanager
-%attr(754,root,root) /etc/rc.d/init.d/scsi_reserve
-%attr(755,root,root) %{_libdir}/libcman.so
-%attr(755,root,root) %{_libdir}/libcman.so.2
-%attr(755,root,root) %{_libdir}/libcman.so.2.3
-%attr(755,root,root) %{_libdir}/libdlm_lt.so
-%attr(755,root,root) %{_libdir}/libdlm_lt.so.2
-%attr(755,root,root) %{_libdir}/libdlm_lt.so.2.3
-%attr(755,root,root) %{_libdir}/libdlm.so
-%attr(755,root,root) %{_libdir}/libdlm.so.2
-%attr(755,root,root) %{_libdir}/libdlm.so.2.3
-%attr(755,root,root) %{_sbindir}/ccsd
-%attr(755,root,root) %{_sbindir}/ccs_test
-%attr(755,root,root) %{_sbindir}/ccs_tool
-%attr(755,root,root) %{_sbindir}/clubufflush
-%attr(755,root,root) %{_sbindir}/clufindhostname
-%attr(755,root,root) %{_sbindir}/clulog
-%attr(755,root,root) %{_sbindir}/clunfslock
-%attr(755,root,root) %{_sbindir}/clurgmgrd
-%attr(755,root,root) %{_sbindir}/clurmtabd
-%attr(755,root,root) %{_sbindir}/clustat
-%attr(755,root,root) %{_sbindir}/clusvcadm
-%attr(755,root,root) %{_sbindir}/cman_tool
-%attr(755,root,root) %{_sbindir}/dlm_controld
-%attr(755,root,root) %{_sbindir}/dlm_tool
-%attr(755,root,root) %{_sbindir}/fence_ack_manual
-%attr(755,root,root) %{_sbindir}/fence_alom
-%attr(755,root,root) %{_sbindir}/fence_apc
-%attr(755,root,root) %{_sbindir}/fence_apc_snmp
-%attr(755,root,root) %{_sbindir}/fence_baytech
-%attr(755,root,root) %{_sbindir}/fence_bladecenter
-%attr(755,root,root) %{_sbindir}/fence_brocade
-%attr(755,root,root) %{_sbindir}/fence_bullpap
-%attr(755,root,root) %{_sbindir}/fence_cpint
-%attr(755,root,root) %{_sbindir}/fenced
-%attr(755,root,root) %{_sbindir}/fence_drac
-%attr(755,root,root) %{_sbindir}/fence_drac5
-%attr(755,root,root) %{_sbindir}/fence_egenera
-%attr(755,root,root) %{_sbindir}/fence_eps
-%attr(755,root,root) %{_sbindir}/fence_gnbd
-%attr(755,root,root) %{_sbindir}/fence_ibmblade
-%attr(755,root,root) %{_sbindir}/fence_ifmib
-%attr(755,root,root) %{_sbindir}/fence_ilo
-%attr(755,root,root) %{_sbindir}/fence_ipmilan
-%attr(755,root,root) %{_sbindir}/fence_ldom
-%attr(755,root,root) %{_sbindir}/fence_lpar
-%attr(755,root,root) %{_sbindir}/fence_mcdata
-%attr(755,root,root) %{_sbindir}/fence_node
-%attr(755,root,root) %{_sbindir}/fence_rackswitch
-%attr(755,root,root) %{_sbindir}/fence_rps10
-%attr(755,root,root) %{_sbindir}/fence_rsa
-%attr(755,root,root) %{_sbindir}/fence_rsb
-%attr(755,root,root) %{_sbindir}/fence_sanbox2
-%attr(755,root,root) %{_sbindir}/fence_scsi
-%attr(755,root,root) %{_sbindir}/fence_scsi_test
-%attr(755,root,root) %{_sbindir}/fence_tool
-%attr(755,root,root) %{_sbindir}/fence_virsh
-%attr(755,root,root) %{_sbindir}/fence_vixel
-%attr(755,root,root) %{_sbindir}/fence_vmware
-%attr(755,root,root) %{_sbindir}/fence_wti
-%attr(755,root,root) %{_sbindir}/fence_xcat
-%attr(755,root,root) %{_sbindir}/fence_zvm
-%attr(755,root,root) %{_sbindir}/fsck.gfs
-%attr(755,root,root) %{_sbindir}/gfs_controld
-%attr(755,root,root) %{_sbindir}/gfs_debug
-%attr(755,root,root) %{_sbindir}/gfs_edit
-%attr(755,root,root) %{_sbindir}/gfs_fsck
-%attr(755,root,root) %{_sbindir}/gfs_grow
-%attr(755,root,root) %{_sbindir}/gfs_jadd
-%attr(755,root,root) %{_sbindir}/gfs_mkfs
-%attr(755,root,root) %{_sbindir}/gfs_quota
-%attr(755,root,root) %{_sbindir}/gfs_tool
-%attr(755,root,root) %{_sbindir}/gnbd_clusterd
-%attr(755,root,root) %{_sbindir}/gnbd_export
-%attr(755,root,root) %{_sbindir}/gnbd_get_uid
-%attr(755,root,root) %{_sbindir}/gnbd_import
-%attr(755,root,root) %{_sbindir}/gnbd_monitor
-%attr(755,root,root) %{_sbindir}/gnbd_recvd
-%attr(755,root,root) %{_sbindir}/gnbd_serv
-%attr(755,root,root) %{_sbindir}/groupd
-%attr(755,root,root) %{_sbindir}/group_tool
-%attr(755,root,root) %{_sbindir}/mkfs.gfs
-%attr(755,root,root) %{_sbindir}/mkqdisk
-%attr(755,root,root) %{_sbindir}/mount.gfs
-%attr(755,root,root) %{_sbindir}/qdiskd
-%attr(755,root,root) %{_sbindir}/rg_test
-%attr(755,root,root) %{_sbindir}/umount.gfs
-%{_datadir}/cluster/apache.metadata
-%{_datadir}/cluster/apache.sh
-%{_datadir}/cluster/ASEHAagent.sh
-%{_datadir}/cluster/clusterfs.sh
-%{_datadir}/cluster/default_event_script.sl
-%{_datadir}/cluster/fs.sh
-%{_datadir}/cluster/ip.sh
-%{_datadir}/cluster/lvm_by_lv.sh
-%{_datadir}/cluster/lvm_by_vg.sh
-%{_datadir}/cluster/lvm.metadata
-%{_datadir}/cluster/lvm.sh
-%{_datadir}/cluster/mysql.metadata
-%{_datadir}/cluster/mysql.sh
-%{_datadir}/cluster/named.metadata
-%{_datadir}/cluster/named.sh
-%{_datadir}/cluster/netfs.sh
-%{_datadir}/cluster/nfsclient.sh
-%{_datadir}/cluster/nfsexport.sh
-%{_datadir}/cluster/ocf-shellfuncs
-%{_datadir}/cluster/openldap.metadata
-%{_datadir}/cluster/openldap.sh
-%{_datadir}/cluster/oracledb.sh
-%{_datadir}/cluster/postgres-8.metadata
-%{_datadir}/cluster/postgres-8.sh
-%{_datadir}/cluster/samba.metadata
-%{_datadir}/cluster/samba.sh
-%{_datadir}/cluster/SAPDatabase
-%{_datadir}/cluster/SAPInstance
-%{_datadir}/cluster/script.sh
-%{_datadir}/cluster/service.sh
-%{_datadir}/cluster/smb.sh
-%{_datadir}/cluster/svclib_nfslock
-%{_datadir}/cluster/tomcat-5.metadata
-%{_datadir}/cluster/tomcat-5.sh
-%{_datadir}/cluster/utils/config-utils.sh
-%{_datadir}/cluster/utils/httpd-parse-config.pl
-%{_datadir}/cluster/utils/member_util.sh
-%{_datadir}/cluster/utils/messages.sh
-%{_datadir}/cluster/utils/ra-skelet.sh
-%{_datadir}/cluster/utils/tomcat-parse-config.pl
-%{_datadir}/cluster/vm.sh
-%{_datadir}/fence/fencing.py
-%{_datadir}/fence/telnet_ssl
-%{_datadir}/snmp/mibs/powernet369.mib
-%{_docdir}/cluster/COPYING.applications
-%{_docdir}/cluster/COPYING.libraries
-%{_docdir}/cluster/COPYRIGHT
-%{_docdir}/cluster/journaling.txt
-%{_docdir}/cluster/min-gfs.txt
-%{_docdir}/cluster/README.licence
-%{_docdir}/cluster/usage.txt
-/etc/udev/rules.d/51-dlm.rules
-%{_includedir}/ccs.h
-%{_includedir}/libcman.h
-%{_includedir}/libdlm.h
-%{_libdir}/libccs.a
-%{_libdir}/libcman.a
-%{_libdir}/libdlm.a
-%{_libdir}/libdlm_lt.a
-%{_mandir}/man3/dlm_cleanup.3
-%{_mandir}/man3/dlm_close_lockspace.3
-%{_mandir}/man3/dlm_create_lockspace.3*
-%{_mandir}/man3/dlm_dispatch.3
-%{_mandir}/man3/dlm_get_fd.3
-%{_mandir}/man3/dlm_lock.3*
-%{_mandir}/man3/dlm_lock_wait.3
-%{_mandir}/man3/dlm_ls_lock.3
-%{_mandir}/man3/dlm_ls_lock_wait.3
-%{_mandir}/man3/dlm_ls_lockx.3
-%{_mandir}/man3/dlm_ls_pthread_init.3
-%{_mandir}/man3/dlm_ls_unlock.3
-%{_mandir}/man3/dlm_ls_unlock_wait.3
-%{_mandir}/man3/dlm_new_lockspace.3
-%{_mandir}/man3/dlm_open_lockspace.3
-%{_mandir}/man3/dlm_pthread_init.3
-%{_mandir}/man3/dlm_release_lockspace.3
-%{_mandir}/man3/dlm_unlock.3*
-%{_mandir}/man3/dlm_unlock_wait.3
-%{_mandir}/man3/libdlm.3*
-%{_mandir}/man5/cluster.conf.5*
-%{_mandir}/man5/cman.5*
-%{_mandir}/man5/qdisk.5*
-%{_mandir}/man7/ccs.7*
-%{_mandir}/man8/ccsd.8*
-%{_mandir}/man8/ccs_test.8*
-%{_mandir}/man8/ccs_tool.8*
-%{_mandir}/man8/clubufflush.8*
-%{_mandir}/man8/clufindhostname.8*
-%{_mandir}/man8/clulog.8*
-%{_mandir}/man8/clurgmgrd.8*
-%{_mandir}/man8/clurmtabd.8*
-%{_mandir}/man8/clustat.8*
-%{_mandir}/man8/clusvcadm.8*
-%{_mandir}/man8/cman_tool.8*
-%{_mandir}/man8/dlm_controld.8*
-%{_mandir}/man8/dlm_tool.8*
-%{_mandir}/man8/fence.8*
-%{_mandir}/man8/fence_ack_manual.8*
-%{_mandir}/man8/fence_alom.8*
-%{_mandir}/man8/fence_apc.8*
-%{_mandir}/man8/fence_bladecenter.8*
-%{_mandir}/man8/fence_brocade.8*
-%{_mandir}/man8/fence_bullpap.8*
-%{_mandir}/man8/fenced.8*
-%{_mandir}/man8/fence_drac.8*
-%{_mandir}/man8/fence_egenera.8*
-%{_mandir}/man8/fence_eps.8*
-%{_mandir}/man8/fence_gnbd.8*
-%{_mandir}/man8/fence_ifmib.8*
-%{_mandir}/man8/fence_ilo.8*
-%{_mandir}/man8/fence_ipmilan.8*
-%{_mandir}/man8/fence_ldom.8*
-%{_mandir}/man8/fence_manual.8*
-%{_mandir}/man8/fence_mcdata.8*
-%{_mandir}/man8/fence_node.8*
-%{_mandir}/man8/fence_rib.8*
-%{_mandir}/man8/fence_rsa.8*
-%{_mandir}/man8/fence_sanbox2.8*
-%{_mandir}/man8/fence_tool.8*
-%{_mandir}/man8/fence_virsh.8*
-%{_mandir}/man8/fence_vixel.8*
-%{_mandir}/man8/fence_vmware.8*
-%{_mandir}/man8/fence_wti.8*
-%{_mandir}/man8/fence_xvm.8*
-%{_mandir}/man8/fence_xvmd.8*
-%{_mandir}/man8/gfs.8*
-%{_mandir}/man8/gfs_controld.8*
-%{_mandir}/man8/gfs_edit.8
-%{_mandir}/man8/gfs_fsck.8*
-%{_mandir}/man8/gfs_grow.8*
-%{_mandir}/man8/gfs_jadd.8*
-%{_mandir}/man8/gfs_mkfs.8*
-%{_mandir}/man8/gfs_mount.8*
-%{_mandir}/man8/gfs_quota.8*
-%{_mandir}/man8/gfs_tool.8*
-%{_mandir}/man8/gnbd.8*
-%{_mandir}/man8/gnbd_export.8*
-%{_mandir}/man8/gnbd_import.8*
-%{_mandir}/man8/gnbd_serv.8*
-%{_mandir}/man8/groupd.8*
-%{_mandir}/man8/group_tool.8*
-%{_mandir}/man8/mkqdisk.8*
-%{_mandir}/man8/qdiskd.8*
-%{_prefix}/libexec/lcrso/service_cman.lcrso
+%{_mandir}/man8/gfs2.8*
+%{_mandir}/man8/gfs2_*.8*
+%{_mandir}/man8/mkfs.gfs2.8*
 %endif
 
 %if %{with kernel}
This page took 0.145335 seconds and 4 git commands to generate.