]> git.pld-linux.org Git - packages/gflags.git/blob - gflags.spec
- TODO already fixed
[packages/gflags.git] / gflags.spec
1 Summary:        A commandline flags library that allows for distributed flags
2 Summary(pl.UTF-8):      Biblioteka flag linii poleceń pozwalająca na rozproszone flagi
3 Name:           gflags
4 Version:        2.2.0
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 #Source0Download: https://github.com/gflags/gflags/releases
9 Source0:        https://github.com/schuhschuh/gflags/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  b99048d9ab82d8c56e876fb1456c285e
11 Patch0:         %{name}-pc-nothreads.patch
12 URL:            http://gflags.github.io/gflags/
13 BuildRequires:  cmake >= 2.8.12
14 BuildRequires:  libstdc++-devel
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 gflags is Google's commandline flags library. It differs from other
19 libraries, such as getopt(), in that flag definitions can be scattered
20 around the source code, and not just listed in one place such as
21 main().
22
23 %description -l pl.UTF-8
24 gflags to biblioteka flag linii poleceń stworzona przez Google. Różni
25 się od innych bibliotek, takich jak getopt(), tym, że definicje flag
26 mogą być rozproszone po kodzie źródłowym, a nie wypisane tylko w
27 jednym miejscu, takim jak main().
28
29 %package devel
30 Summary:        Header files for gflags library
31 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gflags
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34 Requires:       libstdc++-devel
35
36 %description devel
37 Header files for gflags library.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe biblioteki gflags.
41
42 %package static
43 Summary:        Static gflags library
44 Summary(pl.UTF-8):      Statyczna biblioteka gflags
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 Static gflags library.
50
51 %description static -l pl.UTF-8
52 Statyczna biblioteka gflags.
53
54 %prep
55 %setup -q
56 %patch0 -p1
57
58 %build
59 install -d build
60 cd build
61 %cmake .. \
62         -DBUILD_STATIC_LIBS=ON
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} -C build install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files
78 %defattr(644,root,root,755)
79 %doc AUTHORS.txt COPYING.txt ChangeLog.txt README.md
80 %attr(755,root,root) %{_bindir}/gflags_completions.sh
81 %attr(755,root,root) %{_libdir}/libgflags.so.*.*.*
82 %attr(755,root,root) %ghost %{_libdir}/libgflags.so.2.2
83 %attr(755,root,root) %{_libdir}/libgflags_nothreads.so.*.*.*
84 %attr(755,root,root) %ghost %{_libdir}/libgflags_nothreads.so.2.2
85
86 %files devel
87 %defattr(644,root,root,755)
88 # not present in 2.2.0
89 #%doc doc/{index.html,designstyle.css}
90 %attr(755,root,root) %{_libdir}/libgflags.so
91 %attr(755,root,root) %{_libdir}/libgflags_nothreads.so
92 %{_includedir}/gflags
93 %{_pkgconfigdir}/gflags.pc
94 %{_pkgconfigdir}/gflags_nothreads.pc
95 %{_libdir}/cmake/gflags
96
97 %files static
98 %defattr(644,root,root,755)
99 %{_libdir}/libgflags.a
100 %{_libdir}/libgflags_nothreads.a
This page took 0.078926 seconds and 3 git commands to generate.