]> git.pld-linux.org Git - packages/gexiv2.git/commitdiff
- updated to 0.10.0 auto/th/gexiv2-0.10.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 6 Apr 2014 19:25:33 +0000 (21:25 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 6 Apr 2014 19:25:33 +0000 (21:25 +0200)
gexiv2.spec

index 0fadbdd6983c8a77faf6797f27f100ae1a0b6119..bea602d14315d000e549ab0a68f4e46d4caadb96 100644 (file)
@@ -1,21 +1,31 @@
+#
+# Conditional build:
+%bcond_without static_libs     # static library
+#
 Summary:       GObject-based wrapper around the Exiv2 library
 Summary(pl.UTF-8):     Oparte na GObject obudowanie biblioteki Exiv2
 Name:          gexiv2
-Version:       0.7.0
+Version:       0.10.0
 Release:       1
 License:       GPL v2
 Group:         Libraries
-Source0:       http://yorba.org/download/gexiv2/0.7/lib%{name}-%{version}.tar.xz
-# Source0-md5: 15f5adab32022c6ab3f66d82eed7c1e8
-URL:           http://trac.yorba.org/wiki/gexiv2
+Source0:       https://download.gnome.org/sources/gexiv2/0.10/%{name}-%{version}.tar.xz
+# Source0-md5: d5e33e2e6d034df900879a167513325f
+URL:           https://wiki.gnome.org/Projects/gexiv2
 BuildRequires: exiv2-devel >= 0.21
-BuildRequires: glib2-devel >= 1:2.0
+BuildRequires: glib2-devel >= 1:2.26.1
+BuildRequires: gobject-introspection-devel >= 0.10
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 2:1.5
 BuildRequires: m4
-BuildRequires: pkgconfig
-BuildRequires: sed >= 4.0
+BuildRequires: pkgconfig >= 1:0.26
+BuildRequires: python >= 2
+BuildRequires: python-pygobject3-devel >= 3
+BuildRequires: python3 >= 3.2
+BuildRequires: python3-pygobject3-devel >= 3
+BuildRequires: rpmbuild(macros) >= 1.219
 Requires:      exiv2-libs >= 0.21
+Requires:      glib2 >= 1:2.26.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -32,7 +42,7 @@ Summary(pl.UTF-8):    Pliki nagłówkowe biblioteki gexiv2
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      exiv2-devel >= 0.21
-Requires:      glib2-devel >= 1:2.0
+Requires:      glib2-devel >= 1:2.26.1
 Requires:      libstdc++-devel
 
 %description devel
@@ -53,6 +63,32 @@ Static gexiv2 library.
 %description static -l pl.UTF-8
 Statyczna biblioteka gexiv2.
 
+%package -n python-gexiv2
+Summary:       Python 2 binding for gexiv2 library
+Summary(pl.UTF-8):     Wiązanie Pythona 2 do biblioteki gexiv2
+Group:         Development/Languages/Python
+Requires:      %{name} = %{version}-%{release}
+Requires:      python-gobject3 >= 3
+
+%description -n python-gexiv2
+Python 2 binding for gexiv2 library.
+
+%description -n python-gexiv2 -l pl.UTF-8
+Wiązanie Pythona 2 do biblioteki gexiv2.
+
+%package -n python3-gexiv2
+Summary:       Python 3 binding for gexiv2 library
+Summary(pl.UTF-8):     Wiązanie Pythona 3 do biblioteki gexiv2
+Group:         Development/Languages/Python
+Requires:      %{name} = %{version}-%{release}
+Requires:      python3-gobject3 >= 3
+
+%description -n python3-gexiv2
+Python 3 binding for gexiv2 library.
+
+%description -n python3-gexiv2 -l pl.UTF-8
+Wiązanie Pythona 3 do biblioteki gexiv2.
+
 %package -n vala-gexiv2
 Summary:       Vala binding for gexiv2 library
 Summary(pl.UTF-8):     Wiązanie języka vala do biblioteki gexiv2
@@ -66,28 +102,24 @@ Vala binding for gexiv2 library.
 Wiązanie języka vala do biblioteki gexiv2.
 
 %prep
-%setup -q -n lib%{name}-%{version}
+%setup -q
 
 %build
-# not autoconf-generated
-./configure \
-       --prefix=%{_prefix}
-
-%{__make} \
-       CFLAGS="%{rpmcflags}" \
-       CXX="%{__cxx}" \
-       LIB="%{_lib}" \
-       LDFLAGS="-lm"
+%configure \
+       --enable-introspection \
+       %{?with_static_libs:--enable-static}
 
-# fix hardcoded ${exec_prefix}/lib
-sed -i -e 's,^libdir=.*,libdir=%{_libdir},' gexiv2.pc
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       LIB="%{_lib}"
+       DESTDIR=$RPM_BUILD_ROOT
+
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}/gi/overrides
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/gi/overrides
+%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -97,20 +129,32 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS MAINTAINERS NEWS README THANKS
+%doc AUTHORS NEWS README THANKS
 %attr(755,root,root) %{_libdir}/libgexiv2.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libgexiv2.so.2
+%{_libdir}/girepository-1.0/GExiv2-0.10.typelib
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libgexiv2.so
 %{_libdir}/libgexiv2.la
+%{_datadir}/gir-1.0/GExiv2-0.10.gir
 %{_includedir}/gexiv2
 %{_pkgconfigdir}/gexiv2.pc
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libgexiv2.a
+%endif
+
+%files -n python-gexiv2
+%defattr(644,root,root,755)
+%{py_sitedir}/gi/overrides/GExiv2.py[co]
+
+%files -n python3-gexiv2
+%defattr(644,root,root,755)
+%{py3_sitedir}/gi/overrides/GExiv2.py
 
 %files -n vala-gexiv2
 %defattr(644,root,root,755)
This page took 0.077237 seconds and 4 git commands to generate.