]> git.pld-linux.org Git - packages/gexiv2.git/commitdiff
- Initial add
authorCaleb Maclennan <caleb@alerque.com>
Mon, 2 Aug 2010 18:00:58 +0000 (18:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gexiv2-libtool.patch -> 1.1
    gexiv2.spec -> 1.1

gexiv2-libtool.patch [new file with mode: 0644]
gexiv2.spec [new file with mode: 0644]

diff --git a/gexiv2-libtool.patch b/gexiv2-libtool.patch
new file mode 100644 (file)
index 0000000..c3af6e2
--- /dev/null
@@ -0,0 +1,31 @@
+--- Makefile~  2010-06-28 13:00:02.000000000 -0600
++++ Makefile   2010-08-02 13:12:28.000000000 -0600
+@@ -134,7 +134,7 @@
+ .PHONY: install
+ install:
+       @mkdir -p $(DESTDIR)$(PREFIX)/$(LIB)
+-      libtool --mode=install $(INSTALL_PROGRAM) $(LIBRARY).la $(DESTDIR)$(PREFIX)/$(LIB)
++      libtool --tag=CC --mode=install $(INSTALL_PROGRAM) $(LIBRARY).la $(DESTDIR)$(PREFIX)/$(LIB)
+       @mkdir -p $(DESTDIR)$(PREFIX)/include/$(PKGNAME)
+       $(INSTALL_DATA) $(EXPANDED_INSTALLED_HEADER_FILES) $(DESTDIR)$(PREFIX)/include/$(PKGNAME)
+       @mkdir -p $(DESTDIR)$(PREFIX)/$(LIB)/pkgconfig
+@@ -147,7 +147,7 @@
+       $(INSTALL_DATA) $(VAPI_FILE) $(DESTDIR)$(PREFIX)/share/vala/vapi
+ uninstall:
+-      libtool --mode=uninstall rm -f $(DESTDIR)$(PREFIX)/$(LIB)/$(LIBRARY).la
++      libtool --tag=CC --mode=uninstall rm -f $(DESTDIR)$(PREFIX)/$(LIB)/$(LIBRARY).la
+       rm -rf $(DESTDIR)$(PREFIX)/include/$(PKGNAME)
+       rm -f $(DESTDIR)$(PREFIX)/$(LIB)/pkgconfig/$(PKGNAME).pc
+       rm -f $(DESTDIR)$(PREFIX)/share/vala/vapi/$(PKGNAME).vapi
+@@ -163,8 +163,8 @@
+ $(EXPANDED_OBJ_FILES): $(BUILD_DIR)/%.o: gexiv2/%.cpp $(EXPANDED_HEADER_FILES) $(CONFIG_IN) Makefile
+       @pkg-config --print-errors --exists '$(EXT_PKG_VERSIONS)'
+       @mkdir -p $(BUILD_DIR)
+-      libtool --mode=compile $(CXX) -c $(EXT_PKGS_CFLAGS) $(CFLAGS) -I. -o $@ $<
++      libtool --tag=CC --mode=compile $(CXX) -c $(EXT_PKGS_CFLAGS) $(CFLAGS) -I. -o $@ $<
+ $(LIBRARY_BIN): $(EXPANDED_OBJ_FILES)
+-      libtool --mode=link $(CXX) -rpath $(PREFIX)/$(LIB) $(EXPANDED_LO_FILES) $(EXT_PKGS_LDFLAGS) $(CFLAGS) $(LDFLAGS) -o $(LIBRARY_BIN)
++      libtool --tag=CC --mode=link $(CXX) -rpath $(PREFIX)/$(LIB) $(EXPANDED_LO_FILES) $(EXT_PKGS_LDFLAGS) $(CFLAGS) $(LDFLAGS) -o $(LIBRARY_BIN)
diff --git a/gexiv2.spec b/gexiv2.spec
new file mode 100644 (file)
index 0000000..823f40d
--- /dev/null
@@ -0,0 +1,72 @@
+# TODO:
+# - Add bcond for vapi support and subpackage
+
+Summary:       GObject-based wrapper around the  Exiv2 library
+Name:          gexiv2
+Version:       0.1.0
+Release:       1
+License:       GPL
+Group:         Applications/Graphics
+Source0:       http://yorba.org/download/%{name}/0.1/lib%{name}-%{version}.tar.bz2
+# Source0-md5: efae406dac86aa6db4cfb75569cbb3f9
+URL:           http://libexif.sourceforge.net/
+Patch0:                gexiv2-libtool.patch
+BuildRequires: exiv2-devel
+BuildRequires: pkgconfig
+Requires:      exiv2-libs
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+gexiv2 is a GObject-based wrapper around the  Exiv2 library. It makes
+the basic features of Exiv2 available to GNOME applications.
+
+%package devel
+Summary: GObject-based wrapper around the  Exiv2 library
+Requires:      exiv2-devel
+Group: Development/Libraries
+
+%description devel
+gexiv2 development files
+
+%package static
+Summary: GObject-based wrapper around the  Exiv2 library
+Requires:      exiv2-static
+Group: Development/Libraries
+
+%description static
+gexiv2 static library
+
+%prep
+%setup -q -n lib%{name}-%{version}
+%patch0 -p0
+
+%build
+%{__libtoolize}
+./configure --prefix=%{_prefix}
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/lib%{name}.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/lib%{name}.so.0
+%attr(755,root,root) %{_libdir}/lib%{name}.so
+
+%files devel
+%defattr(644,root,root,755)
+%{_libdir}/lib%{name}.la
+%{_includedir}/%{name}
+%{_pkgconfigdir}/%{name}.pc
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/lib%{name}.a
This page took 0.102297 seconds and 4 git commands to generate.