]> git.pld-linux.org Git - packages/gexiv2.git/blob - gexiv2.spec
- updated to 0.14.2 (ready for exiv2 0.28)
[packages/gexiv2.git] / gexiv2.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # static library
5
6 Summary:        GObject-based wrapper around the Exiv2 library
7 Summary(pl.UTF-8):      Oparte na GObject obudowanie biblioteki Exiv2
8 Name:           gexiv2
9 Version:        0.10.7
10 Release:        1
11 License:        GPL v2
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gexiv2/0.10/%{name}-%{version}.tar.xz
14 # Source0-md5:  01e1b860ffe35f5946020c3d5c4c50c9
15 URL:            https://wiki.gnome.org/Projects/gexiv2
16 BuildRequires:  exiv2-devel >= 0.21
17 BuildRequires:  glib2-devel >= 1:2.26.1
18 BuildRequires:  gobject-introspection-devel >= 0.10
19 BuildRequires:  gtk-doc >= 1.14
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  m4
22 BuildRequires:  pkgconfig >= 1:0.26
23 BuildRequires:  python >= 2
24 BuildRequires:  python-pygobject3-devel >= 3
25 BuildRequires:  python3 >= 1:3.2
26 BuildRequires:  python3-pygobject3-devel >= 3
27 BuildRequires:  rpmbuild(macros) >= 1.219
28 Requires:       exiv2-libs >= 0.21
29 Requires:       glib2 >= 1:2.26.1
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 gexiv2 is a GObject-based wrapper around the Exiv2 library. It makes
34 the basic features of Exiv2 available to GNOME applications.
35
36 %description -l pl.UTF-8
37 gexiv2 to oparte na GObject obudowanie biblioteki Exiv2. Udostępnia
38 podstawowe możliwości Exiv2 aplikacjom GNOME.
39
40 %package devel
41 Summary:        Header files for gexiv2 library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gexiv2
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       exiv2-devel >= 0.21
46 Requires:       glib2-devel >= 1:2.26.1
47 Requires:       libstdc++-devel
48
49 %description devel
50 Header files for gexiv2 library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki gexiv2.
54
55 %package static
56 Summary:        Static gexiv2 library
57 Summary(pl.UTF-8):      Statyczna biblioteka gexiv2
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static gexiv2 library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka gexiv2.
66
67 %package apidocs
68 Summary:        gexiv2 API documentation
69 Summary(pl.UTF-8):      Dokumentacja API gexiv2
70 Group:          Documentation
71 Requires:       gtk-doc-common
72 %if "%{_rpmversion}" >= "5"
73 BuildArch:      noarch
74 %endif
75
76 %description apidocs
77 gexiv2 API documentation.
78
79 %description apidocs -l pl.UTF-8
80 Dokumentacja API gexiv2.
81
82 %package -n python-gexiv2
83 Summary:        Python 2 binding for gexiv2 library
84 Summary(pl.UTF-8):      Wiązanie Pythona 2 do biblioteki gexiv2
85 Group:          Development/Languages/Python
86 Requires:       %{name} = %{version}-%{release}
87 Requires:       python-pygobject3 >= 3
88
89 %description -n python-gexiv2
90 Python 2 binding for gexiv2 library.
91
92 %description -n python-gexiv2 -l pl.UTF-8
93 Wiązanie Pythona 2 do biblioteki gexiv2.
94
95 %package -n python3-gexiv2
96 Summary:        Python 3 binding for gexiv2 library
97 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki gexiv2
98 Group:          Development/Languages/Python
99 Requires:       %{name} = %{version}-%{release}
100 Requires:       python3-pygobject3 >= 3
101
102 %description -n python3-gexiv2
103 Python 3 binding for gexiv2 library.
104
105 %description -n python3-gexiv2 -l pl.UTF-8
106 Wiązanie Pythona 3 do biblioteki gexiv2.
107
108 %package -n vala-gexiv2
109 Summary:        Vala binding for gexiv2 library
110 Summary(pl.UTF-8):      Wiązanie języka vala do biblioteki gexiv2
111 Group:          Development/Languages
112 Requires:       %{name}-devel = %{version}-%{release}
113 %if "%{_rpmversion}" >= "5"
114 BuildArch:      noarch
115 %endif
116
117 %description -n vala-gexiv2
118 Vala binding for gexiv2 library.
119
120 %description -n vala-gexiv2 -l pl.UTF-8
121 Wiązanie języka vala do biblioteki gexiv2.
122
123 %prep
124 %setup -q
125
126 %build
127 %configure \
128         %{__enable_disable apidocs gtk-doc} \
129         --enable-introspection \
130         %{?with_static_libs:--enable-static} \
131         --disable-silent-rules \
132         --with-html-dir=%{_gtkdocdir}
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT \
141         typelibdir=%{_libdir}/girepository-1.0
142
143 # obsoleted by pkg-config
144 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgexiv2.la
145
146 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/gi/overrides
147 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/gi/overrides
148 %py_postclean
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %files
157 %defattr(644,root,root,755)
158 %doc AUTHORS NEWS README THANKS
159 %attr(755,root,root) %{_libdir}/libgexiv2.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libgexiv2.so.2
161 %{_libdir}/girepository-1.0/GExiv2-0.10.typelib
162
163 %files devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/libgexiv2.so
166 %{_datadir}/gir-1.0/GExiv2-0.10.gir
167 %{_includedir}/gexiv2
168 %{_pkgconfigdir}/gexiv2.pc
169
170 %if %{with static_libs}
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/libgexiv2.a
174 %endif
175
176 %files apidocs
177 %defattr(644,root,root,755)
178 %{_gtkdocdir}/gexiv2
179
180 %files -n python-gexiv2
181 %defattr(644,root,root,755)
182 %{py_sitedir}/gi/overrides/GExiv2.py[co]
183
184 %files -n python3-gexiv2
185 %defattr(644,root,root,755)
186 %{py3_sitedir}/gi/overrides/GExiv2.py
187
188 %files -n vala-gexiv2
189 %defattr(644,root,root,755)
190 %{_datadir}/vala/vapi/gexiv2.vapi
This page took 0.08496 seconds and 3 git commands to generate.