]> git.pld-linux.org Git - packages/geos.git/blob - geos.spec
- updated to 3.8.3 (last version with swig bindings)
[packages/geos.git] / geos.spec
1 #
2 # Conditional build:
3 %bcond_without  ruby    # ruby binding
4
5 Summary:        Geometry Engine - Open Source
6 Summary(pl.UTF-8):      GEOS - silnik geometryczny z otwartymi źródłami
7 Name:           geos
8 Version:        3.8.3
9 Release:        1
10 License:        LGPL v2.1
11 Group:          Libraries
12 Source0:        http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
13 # Source0-md5:  57e4bde34a4f8aabed096e06a2002c4d
14 Patch0:         rubydir.patch
15 Patch1:         %{name}-x32.patch
16 URL:            https://trac.osgeo.org/geos/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake
19 BuildRequires:  libstdc++-devel >= 6:4.7
20 BuildRequires:  python
21 BuildRequires:  python-devel
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.519
24 %{?with_ruby:BuildRequires:     ruby-devel}
25 BuildRequires:  swig-python >= 1.3.29
26 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.40-3}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 GEOS (Geometry Engine - Open Source) is a C++ port of the Java
31 Topology Suite (JTS). As such, it aims to contain the complete
32 functionality of JTS in C++. This includes all the OpenGIS "Simple
33 Features for SQL" spatial predicate functions and spatial operators,
34 as well as specific JTS topology functions such as IsValid().
35
36 %description -l pl.UTF-8
37 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
38 otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
39 Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
40 JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych wg
41 "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a także
42 specyficzne dla JTS funkcje topologiczne takie jak IsValid().
43
44 %package devel
45 Summary:        Header files for GEOS library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GEOS
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       libstdc++-devel >= 6:4.7
50
51 %description devel
52 Header files for GEOS library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki GEOS.
56
57 %package static
58 Summary:        Static GEOS library
59 Summary(pl.UTF-8):      Statyczna biblioteka GEOS
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static GEOS library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka GEOS.
68
69 %package -n python-geos
70 Summary:        Python bindings for Geometry Engine - Open Source
71 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GEOS
72 Group:          Development/Languages/Python
73 Requires:       %{name} = %{version}-%{release}
74
75 %description -n python-geos
76 Python bindings for Geometry Engine - Open Source.
77
78 %description -n python-geos -l pl.UTF-8
79 Wiązania Pythona do biblioteki GEOS.
80
81 %package -n ruby-geos
82 Summary:        Ruby bindings for Geometry Engine - Open Source
83 Summary(pl.UTF-8):      Wiązania języka Ruby do biblioteki GEOS
84 Group:          Development/Languages/Python
85 Requires:       %{name} = %{version}-%{release}
86
87 %description -n ruby-geos
88 Ruby bindings for Geometry Engine - Open Source.
89
90 %description -n ruby-geos -l pl.UTF-8
91 Wiązania języka Ruby do biblioteki GEOS.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96 %patch1 -p1
97
98 %build
99 %{__aclocal} -I macros
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         --enable-python \
105         %{?with_ruby:--enable-ruby}
106
107 %{__make} \
108         pkglibdir=%{_libdir}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT \
115         pythondir=%{py_sitescriptdir}
116
117 %{?with_ruby:%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/*.{la,a}}
118 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
119
120 %py_postclean
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS NEWS README.md
131 %attr(755,root,root) %{_libdir}/libgeos-%{version}.so
132 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/geos-config
138 %attr(755,root,root) %{_libdir}/libgeos.so
139 %attr(755,root,root) %{_libdir}/libgeos_c.so
140 %{_libdir}/libgeos.la
141 %{_libdir}/libgeos_c.la
142 %{_includedir}/geos
143 %{_includedir}/geos.h
144 %{_includedir}/geos_c.h
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libgeos.a
149 %{_libdir}/libgeos_c.a
150
151 %files -n python-geos
152 %defattr(644,root,root,755)
153 %dir %{py_sitedir}/geos
154 %attr(755,root,root) %{py_sitedir}/geos/_geos.so
155 %{py_sitescriptdir}/geos
156 %{py_sitescriptdir}/geos.pth
157
158 %if %{with ruby}
159 %files -n ruby-geos
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{ruby_vendorarchdir}/geos.so
162 %endif
This page took 0.077832 seconds and 4 git commands to generate.