]> git.pld-linux.org Git - packages/geos.git/blob - geos.spec
db36700938f9196f1401cf9b6dba155d00b1b828
[packages/geos.git] / geos.spec
1 #
2 # Conditional build:
3 %bcond_without  php     # PHP binding
4 %bcond_without  ruby    # ruby binding
5 #
6 Summary:        Geometry Engine - Open Source
7 Summary(pl.UTF-8):      GEOS - silnik geometryczny z otwartymi źródłami
8 Name:           geos
9 Version:        3.3.8
10 Release:        2
11 License:        LGPL v2.1
12 Group:          Libraries
13 Source0:        http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
14 # Source0-md5:  75be476d0831a2d14958fed76ca266de
15 Patch0:         %{name}-ruby1.9.patch
16 Patch1:         %{name}-am.patch
17 URL:            http://trac.osgeo.org/geos/
18 BuildRequires:  autoconf >= 2.52
19 BuildRequires:  automake
20 BuildRequires:  libstdc++-devel
21 %{?with_php:BuildRequires:      php-devel}
22 BuildRequires:  python
23 BuildRequires:  python-devel
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.519
26 %{?with_ruby:BuildRequires:     ruby-devel}
27 BuildRequires:  swig-python >= 1.3.29
28 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.40-3}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 GEOS (Geometry Engine - Open Source) is a C++ port of the Java
33 Topology Suite (JTS). As such, it aims to contain the complete
34 functionality of JTS in C++. This includes all the OpenGIS "Simple
35 Features for SQL" spatial predicate functions and spatial operators,
36 as well as specific JTS topology functions such as IsValid().
37
38 %description -l pl.UTF-8
39 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
40 otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
41 Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
42 JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
43 wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
44 także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
45
46 %package devel
47 Summary:        Header files for GEOS library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GEOS
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       libstdc++-devel
52
53 %description devel
54 Header files for GEOS library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki GEOS.
58
59 %package static
60 Summary:        Static GEOS library
61 Summary(pl.UTF-8):      Statyczna biblioteka GEOS
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static GEOS library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka GEOS.
70
71 %package -n php-geos
72 Summary:        PHP bindings for Geometry Engine - Open Source
73 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GEOS
74 Group:          Development/Languages/PHP
75 Requires:       %{name} = %{version}-%{release}
76 %{?requires_php_extension}
77
78 %description -n php-geos
79 PHP bindings for Geometry Engine - Open Source.
80
81 %description -n php-geos -l pl.UTF-8
82 Wiązania PHP do biblioteki GEOS.
83
84 %package -n python-geos
85 Summary:        Python bindings for Geometry Engine - Open Source
86 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GEOS
87 Group:          Development/Languages/Python
88 Requires:       %{name} = %{version}-%{release}
89
90 %description -n python-geos
91 Python bindings for Geometry Engine - Open Source.
92
93 %description -n python-geos -l pl.UTF-8
94 Wiązania Pythona do biblioteki GEOS.
95
96 %package -n ruby-geos
97 Summary:        Ruby bindings for Geometry Engine - Open Source
98 Summary(pl.UTF-8):      Wiązania języka Ruby do biblioteki GEOS
99 Group:          Development/Languages/Python
100 Requires:       %{name} = %{version}-%{release}
101
102 %description -n ruby-geos
103 Ruby bindings for Geometry Engine - Open Source.
104
105 %description -n ruby-geos -l pl.UTF-8
106 Wiązania języka Ruby do biblioteki GEOS.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111 %patch1 -p1
112
113 %build
114 %{__aclocal} -I macros
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         %{?with_php:--enable-php} \
120         --enable-python \
121 %if %{with ruby}
122         RUBY_EXTENSION_DIR=%{ruby_vendorarchdir} \
123         --enable-ruby \
124 %endif
125
126
127 %{__make} \
128         pkglibdir=%{_libdir}
129
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %if %{with php}
138 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
139 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/geos.ini
140 ; Enable geos extension module
141 extension=geos.so
142 EOF
143 %endif
144
145 %{?with_ruby:%{__rm} $RPM_BUILD_ROOT%{ruby_sitearchdir}/*.{la,a}}
146 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
147
148 %py_postclean
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %files
157 %defattr(644,root,root,755)
158 %doc AUTHORS ChangeLog NEWS README TODO
159 %attr(755,root,root) %{_libdir}/libgeos-*.so
160 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
162
163 %files devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_bindir}/geos-config
166 %attr(755,root,root) %{_libdir}/libgeos.so
167 %attr(755,root,root) %{_libdir}/libgeos_c.so
168 %{_libdir}/libgeos.la
169 %{_libdir}/libgeos_c.la
170 %{_includedir}/geos
171 %{_includedir}/geos.h
172 %{_includedir}/geos_c.h
173
174 %files static
175 %defattr(644,root,root,755)
176 %{_libdir}/libgeos.a
177 %{_libdir}/libgeos_c.a
178
179 %if %{with php}
180 %files -n php-geos
181 %defattr(644,root,root,755)
182 %doc php/{README,TODO}
183 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/geos.ini
184 %attr(755,root,root) %{php_extensiondir}/geos.so
185 %endif
186
187 %files -n python-geos
188 %defattr(644,root,root,755)
189 %dir %{py_sitedir}/geos
190 %attr(755,root,root) %{py_sitedir}/geos/_geos.so
191 %{py_sitescriptdir}/geos
192 %{py_sitescriptdir}/geos.pth
193
194 %if %{with ruby}
195 %files -n ruby-geos
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{ruby_vendorarchdir}/geos.so
198 %endif
This page took 0.038261 seconds and 2 git commands to generate.