]> git.pld-linux.org Git - packages/geos.git/blob - geos.spec
- updated to 3.7.1; requires C++11 now
[packages/geos.git] / geos.spec
1 #
2 # Conditional build:
3 %bcond_without  ruby    # ruby binding
4
5 Summary:        Geometry Engine - Open Source
6 Summary(pl.UTF-8):      GEOS - silnik geometryczny z otwartymi źródłami
7 Name:           geos
8 Version:        3.7.1
9 Release:        1
10 License:        LGPL v2.1
11 Group:          Libraries
12 Source0:        http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
13 # Source0-md5:  62149456d21dabee44999f644c986ab0
14 Patch0:         rubydir.patch
15 URL:            http://trac.osgeo.org/geos/
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake
18 BuildRequires:  libstdc++-devel >= 6:4.7
19 BuildRequires:  python
20 BuildRequires:  python-devel
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.519
23 %{?with_ruby:BuildRequires:     ruby-devel}
24 BuildRequires:  swig-python >= 1.3.29
25 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.40-3}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 GEOS (Geometry Engine - Open Source) is a C++ port of the Java
30 Topology Suite (JTS). As such, it aims to contain the complete
31 functionality of JTS in C++. This includes all the OpenGIS "Simple
32 Features for SQL" spatial predicate functions and spatial operators,
33 as well as specific JTS topology functions such as IsValid().
34
35 %description -l pl.UTF-8
36 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
37 otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
38 Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
39 JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych wg
40 "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a także
41 specyficzne dla JTS funkcje topologiczne takie jak IsValid().
42
43 %package devel
44 Summary:        Header files for GEOS library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GEOS
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       libstdc++-devel >= 6:4.7
49
50 %description devel
51 Header files for GEOS library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki GEOS.
55
56 %package static
57 Summary:        Static GEOS library
58 Summary(pl.UTF-8):      Statyczna biblioteka GEOS
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static GEOS library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka GEOS.
67
68 %package -n python-geos
69 Summary:        Python bindings for Geometry Engine - Open Source
70 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GEOS
71 Group:          Development/Languages/Python
72 Requires:       %{name} = %{version}-%{release}
73
74 %description -n python-geos
75 Python bindings for Geometry Engine - Open Source.
76
77 %description -n python-geos -l pl.UTF-8
78 Wiązania Pythona do biblioteki GEOS.
79
80 %package -n ruby-geos
81 Summary:        Ruby bindings for Geometry Engine - Open Source
82 Summary(pl.UTF-8):      Wiązania języka Ruby do biblioteki GEOS
83 Group:          Development/Languages/Python
84 Requires:       %{name} = %{version}-%{release}
85
86 %description -n ruby-geos
87 Ruby bindings for Geometry Engine - Open Source.
88
89 %description -n ruby-geos -l pl.UTF-8
90 Wiązania języka Ruby do biblioteki GEOS.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95
96 %build
97 %{__aclocal} -I macros
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         --enable-python \
103         %{?with_ruby:--enable-ruby}
104
105 %{__make} \
106         pkglibdir=%{_libdir}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT \
113         pythondir=%{py_sitescriptdir}
114
115 %{?with_ruby:%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/*.{la,a}}
116 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
117
118 %py_postclean
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog NEWS README.md TODO
129 %attr(755,root,root) %{_libdir}/libgeos-%{version}.so
130 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/geos-config
136 %attr(755,root,root) %{_libdir}/libgeos.so
137 %attr(755,root,root) %{_libdir}/libgeos_c.so
138 %{_libdir}/libgeos.la
139 %{_libdir}/libgeos_c.la
140 %{_includedir}/geos
141 %{_includedir}/geos.h
142 %{_includedir}/geos_c.h
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libgeos.a
147 %{_libdir}/libgeos_c.a
148
149 %files -n python-geos
150 %defattr(644,root,root,755)
151 %dir %{py_sitedir}/geos
152 %attr(755,root,root) %{py_sitedir}/geos/_geos.so
153 %{py_sitescriptdir}/geos
154 %{py_sitescriptdir}/geos.pth
155
156 %if %{with ruby}
157 %files -n ruby-geos
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{ruby_vendorarchdir}/geos.so
160 %endif
This page took 0.0716599999999999 seconds and 3 git commands to generate.