]> git.pld-linux.org Git - packages/geos.git/blob - geos.spec
consistent php name
[packages/geos.git] / geos.spec
1 #
2 # Conditional build:
3 %bcond_without  php     # PHP binding
4 %bcond_without  ruby    # ruby binding
5
6 %define         php_name        php55
7 Summary:        Geometry Engine - Open Source
8 Summary(pl.UTF-8):      GEOS - silnik geometryczny z otwartymi źródłami
9 Name:           geos
10 Version:        3.5.0
11 Release:        3
12 License:        LGPL v2.1
13 Group:          Libraries
14 Source0:        http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
15 # Source0-md5:  136842690be7f504fba46b3c539438dd
16 Patch0:         %{name}-php7.patch
17 Patch1:         rubydir.patch
18 URL:            http://trac.osgeo.org/geos/
19 %{?with_php:BuildRequires:      %{php_name}-devel}
20 BuildRequires:  autoconf >= 2.52
21 BuildRequires:  automake
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  python
24 BuildRequires:  python-devel
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.519
27 %{?with_ruby:BuildRequires:     ruby-devel}
28 BuildRequires:  swig-python >= 1.3.29
29 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.40-3}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 GEOS (Geometry Engine - Open Source) is a C++ port of the Java
34 Topology Suite (JTS). As such, it aims to contain the complete
35 functionality of JTS in C++. This includes all the OpenGIS "Simple
36 Features for SQL" spatial predicate functions and spatial operators,
37 as well as specific JTS topology functions such as IsValid().
38
39 %description -l pl.UTF-8
40 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
41 otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
42 Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
43 JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych wg
44 "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a także
45 specyficzne dla JTS funkcje topologiczne takie jak IsValid().
46
47 %package devel
48 Summary:        Header files for GEOS library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GEOS
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       libstdc++-devel
53
54 %description devel
55 Header files for GEOS library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki GEOS.
59
60 %package static
61 Summary:        Static GEOS library
62 Summary(pl.UTF-8):      Statyczna biblioteka GEOS
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static GEOS library.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka GEOS.
71
72 %package -n %{php_name}-geos
73 Summary:        PHP bindings for Geometry Engine - Open Source
74 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GEOS
75 Group:          Development/Languages/PHP
76 Requires:       %{name} = %{version}-%{release}
77 %{?requires_php_extension}
78
79 %description -n %{php_name}-geos
80 PHP bindings for Geometry Engine - Open Source.
81
82 %description -n %{php_name}-geos -l pl.UTF-8
83 Wiązania PHP do biblioteki GEOS.
84
85 %package -n python-geos
86 Summary:        Python bindings for Geometry Engine - Open Source
87 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GEOS
88 Group:          Development/Languages/Python
89 Requires:       %{name} = %{version}-%{release}
90
91 %description -n python-geos
92 Python bindings for Geometry Engine - Open Source.
93
94 %description -n python-geos -l pl.UTF-8
95 Wiązania Pythona do biblioteki GEOS.
96
97 %package -n ruby-geos
98 Summary:        Ruby bindings for Geometry Engine - Open Source
99 Summary(pl.UTF-8):      Wiązania języka Ruby do biblioteki GEOS
100 Group:          Development/Languages/Python
101 Requires:       %{name} = %{version}-%{release}
102
103 %description -n ruby-geos
104 Ruby bindings for Geometry Engine - Open Source.
105
106 %description -n ruby-geos -l pl.UTF-8
107 Wiązania języka Ruby do biblioteki GEOS.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %patch1 -p1
113
114 %build
115 %{__aclocal} -I macros
116 %{__autoconf}
117 %{__autoheader}
118 %{__automake}
119 %configure \
120         %{?with_php:--enable-php} \
121         --enable-python \
122         %{?with_ruby:--enable-ruby}
123
124 %{__make} \
125         pkglibdir=%{_libdir}
126
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT \
133         pythondir=%{py_sitescriptdir}
134
135 %if %{with php}
136 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
137 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/geos.ini
138 ; Enable geos extension module
139 extension=geos.so
140 EOF
141 %endif
142
143 %{?with_ruby:%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/*.{la,a}}
144 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
145
146 %py_postclean
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 %doc AUTHORS ChangeLog NEWS README TODO
157 %attr(755,root,root) %{_libdir}/libgeos-%{version}.so
158 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
160
161 %files devel
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_bindir}/geos-config
164 %attr(755,root,root) %{_libdir}/libgeos.so
165 %attr(755,root,root) %{_libdir}/libgeos_c.so
166 %{_libdir}/libgeos.la
167 %{_libdir}/libgeos_c.la
168 %{_includedir}/geos
169 %{_includedir}/geos.h
170 %{_includedir}/geos_c.h
171
172 %files static
173 %defattr(644,root,root,755)
174 %{_libdir}/libgeos.a
175 %{_libdir}/libgeos_c.a
176
177 %if %{with php}
178 %files -n %{php_name}-geos
179 %defattr(644,root,root,755)
180 %doc php/{README,TODO}
181 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/geos.ini
182 %attr(755,root,root) %{php_extensiondir}/geos.so
183 %endif
184
185 %files -n python-geos
186 %defattr(644,root,root,755)
187 %dir %{py_sitedir}/geos
188 %attr(755,root,root) %{py_sitedir}/geos/_geos.so
189 %{py_sitescriptdir}/geos
190 %{py_sitescriptdir}/geos.pth
191
192 %if %{with ruby}
193 %files -n ruby-geos
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{ruby_vendorarchdir}/geos.so
196 %endif
This page took 0.074959 seconds and 3 git commands to generate.