]> git.pld-linux.org Git - packages/geos.git/blob - geos.spec
95593eb870ee5914bf65be9ce6f1ba31d8ce5f4f
[packages/geos.git] / geos.spec
1 #
2 # Conditional build:
3 %bcond_without  php     # PHP binding
4 %bcond_without  ruby    # ruby binding
5 #
6 Summary:        Geometry Engine - Open Source
7 Summary(pl.UTF-8):      GEOS - silnik geometryczny z otwartymi źródłami
8 Name:           geos
9 Version:        3.3.0
10 Release:        1
11 License:        LGPL v2.1
12 Group:          Libraries
13 Source0:        http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
14 # Source0-md5:  3301f3d1d747b95749384b8a356b022a
15 Patch0:         %{name}-ruby1.9.patch
16 URL:            http://trac.osgeo.org/geos/
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  automake
19 BuildRequires:  libstdc++-devel
20 %{?with_php:BuildRequires:      php-devel}
21 BuildRequires:  python
22 BuildRequires:  python-devel
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.519
25 %{?with_ruby:BuildRequires:     ruby-devel}
26 BuildRequires:  swig-python >= 1.3.29
27 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.40-3}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 GEOS (Geometry Engine - Open Source) is a C++ port of the Java
32 Topology Suite (JTS). As such, it aims to contain the complete
33 functionality of JTS in C++. This includes all the OpenGIS "Simple
34 Features for SQL" spatial predicate functions and spatial operators,
35 as well as specific JTS topology functions such as IsValid().
36
37 %description -l pl.UTF-8
38 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
39 otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
40 Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
41 JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
42 wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
43 także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
44
45 %package devel
46 Summary:        Header files for GEOS library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GEOS
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       libstdc++-devel
51
52 %description devel
53 Header files for GEOS library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki GEOS.
57
58 %package static
59 Summary:        Static GEOS library
60 Summary(pl.UTF-8):      Statyczna biblioteka GEOS
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static GEOS library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka GEOS.
69
70 %package -n php-geos
71 Summary:        PHP bindings for Geometry Engine - Open Source
72 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GEOS
73 Group:          Development/Languages/PHP
74 Requires:       %{name} = %{version}-%{release}
75 %{?requires_php_extension}
76
77 %description -n php-geos
78 PHP bindings for Geometry Engine - Open Source.
79
80 %description -n php-geos -l pl.UTF-8
81 Wiązania PHP do biblioteki GEOS.
82
83 %package -n python-geos
84 Summary:        Python bindings for Geometry Engine - Open Source
85 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GEOS
86 Group:          Development/Languages/Python
87 Requires:       %{name} = %{version}-%{release}
88
89 %description -n python-geos
90 Python bindings for Geometry Engine - Open Source.
91
92 %description -n python-geos -l pl.UTF-8
93 Wiązania Pythona do biblioteki GEOS.
94
95 %package -n ruby-geos
96 Summary:        Ruby bindings for Geometry Engine - Open Source
97 Summary(pl.UTF-8):      Wiązania języka Ruby do biblioteki GEOS
98 Group:          Development/Languages/Python
99 Requires:       %{name} = %{version}-%{release}
100
101 %description -n ruby-geos
102 Ruby bindings for Geometry Engine - Open Source.
103
104 %description -n ruby-geos -l pl.UTF-8
105 Wiązania języka Ruby do biblioteki GEOS.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110
111 %build
112 %{__aclocal} -I macros
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 %configure \
117         %{?with_php:--enable-php} \
118         --enable-python \
119         %{?with_ruby:--enable-ruby}
120
121 %{__make} \
122         pkglibdir=%{_libdir}
123
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %if %{with php}
132 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
133 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/geos.ini
134 ; Enable geos extension module
135 extension=geos.so
136 EOF
137 %endif
138
139 %{?with_ruby:%{__rm} $RPM_BUILD_ROOT%{ruby_sitearchdir}/*.{la,a}}
140 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
141
142 %py_postclean
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog NEWS README TODO
153 %attr(755,root,root) %{_libdir}/libgeos-*.so
154 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
156
157 %files devel
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_bindir}/geos-config
160 %attr(755,root,root) %{_libdir}/libgeos.so
161 %attr(755,root,root) %{_libdir}/libgeos_c.so
162 %{_libdir}/libgeos.la
163 %{_libdir}/libgeos_c.la
164 %{_includedir}/geos
165 %{_includedir}/geos.h
166 %{_includedir}/geos_c.h
167
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libgeos.a
171 %{_libdir}/libgeos_c.a
172
173 %if %{with php}
174 %files -n php-geos
175 %defattr(644,root,root,755)
176 %doc php/{README,TODO}
177 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/geos.ini
178 %attr(755,root,root) %{php_extensiondir}/geos.so
179 %endif
180
181 %files -n python-geos
182 %defattr(644,root,root,755)
183 %dir %{py_sitedir}/geos
184 %attr(755,root,root) %{py_sitedir}/geos/_geos.so
185 %{py_sitescriptdir}/geos
186 %{py_sitescriptdir}/geos.pth
187
188 %if %{with ruby}
189 %files -n ruby-geos
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{ruby_sitearchdir}/geos.so
192 %endif
This page took 0.093179 seconds and 2 git commands to generate.