]> git.pld-linux.org Git - packages/geos.git/blob - geos.spec
- added -gcc43.patch
[packages/geos.git] / geos.spec
1 # TODO
2 # - unpackaged:    /usr/bin/XMLTester
3 #
4 # Conditional build:
5 %bcond_without  ruby    # ruby binding
6 #
7 Summary:        Geometry Engine - Open Source
8 Summary(pl.UTF-8):      GEOS - silnik geometryczny z otwartymi źródłami
9 Name:           geos
10 Version:        3.0.0
11 Release:        2
12 License:        LGPL v2.1
13 Group:          Libraries
14 Source0:        http://geos.refractions.net/downloads/%{name}-%{version}.tar.bz2
15 # Source0-md5:  3f7940abee9fec69a9787878cd3ae771
16 Patch0:         %{name}-gcc43.patch
17 URL:            http://geos.refractions.net/
18 BuildRequires:  automake
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  python
21 BuildRequires:  python-devel
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.219
24 %{?with_ruby:BuildRequires:     ruby-devel}
25 BuildRequires:  swig-python >= 1.3.29
26 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.29}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 GEOS (Geometry Engine - Open Source) is a C++ port of the Java
31 Topology Suite (JTS). As such, it aims to contain the complete
32 functionality of JTS in C++. This includes all the OpenGIS "Simple
33 Features for SQL" spatial predicate functions and spatial operators,
34 as well as specific JTS topology functions such as IsValid().
35
36 %description -l pl.UTF-8
37 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
38 otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
39 Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
40 JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
41 wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
42 także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
43
44 %package devel
45 Summary:        Header files for GEOS library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GEOS
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       libstdc++-devel
50
51 %description devel
52 Header files for GEOS library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki GEOS.
56
57 %package static
58 Summary:        Static GEOS library
59 Summary(pl.UTF-8):      Statyczna biblioteka GEOS
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static GEOS library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka GEOS.
68
69 %package -n python-geos
70 Summary:        Python bindings for Geometry Engine - Open Source
71 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GEOS
72 Group:          Development/Languages/Python
73 Requires:       %{name} = %{version}-%{release}
74
75 %description -n python-geos
76 Python bindings for Geometry Engine - Open Source.
77
78 %description -n python-geos -l pl.UTF-8
79 Wiązania Pythona do biblioteki GEOS.
80
81 %package -n ruby-geos
82 Summary:        Ruby bindings for Geometry Engine - Open Source
83 Summary(pl.UTF-8):      Wiązania języka Ruby do biblioteki GEOS
84 Group:          Development/Languages/Python
85 Requires:       %{name} = %{version}-%{release}
86
87 %description -n ruby-geos
88 Ruby bindings for Geometry Engine - Open Source.
89
90 %description -n ruby-geos -l pl.UTF-8
91 Wiązania języka Ruby do biblioteki GEOS.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96
97 %build
98 cp -f /usr/share/automake/config.* .
99 %configure \
100         --enable-python \
101         %{?with_ruby:--enable-ruby}
102
103 %{__make} \
104         pkglibdir=%{_libdir}
105
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %{?with_ruby:rm -f $RPM_BUILD_ROOT%{ruby_sitearchdir}/*.{la,a}}
114 rm -f $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
115
116 %py_postclean
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog NEWS README TODO
127 %attr(755,root,root) %{_libdir}/libgeos-3.0.0.so
128 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_bindir}/geos-config
134 %attr(755,root,root) %{_libdir}/libgeos.so
135 %attr(755,root,root) %{_libdir}/libgeos_c.so
136 %{_libdir}/libgeos.la
137 %{_libdir}/libgeos_c.la
138 %{_includedir}/geos
139 %{_includedir}/geos.h
140 %{_includedir}/geos_c.h
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libgeos.a
145 %{_libdir}/libgeos_c.a
146
147 %files -n python-geos
148 %defattr(644,root,root,755)
149 %dir %{py_sitedir}/geos
150 %attr(755,root,root) %{py_sitedir}/geos/_geos.so
151 %{py_sitescriptdir}/geos
152 %{py_sitescriptdir}/geos.pth
153
154 %if %{with ruby}
155 %files -n ruby-geos
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{ruby_sitearchdir}/geos.so
158 %endif
This page took 0.073834 seconds and 3 git commands to generate.