]> git.pld-linux.org Git - packages/geos.git/blob - geos.spec
- added swig2 patch to allow build with swig 2.0.x
[packages/geos.git] / geos.spec
1 # TODO
2 # - unpackaged:    /usr/bin/XMLTester
3 #
4 # Conditional build:
5 %bcond_without  ruby    # ruby binding
6 #
7 Summary:        Geometry Engine - Open Source
8 Summary(pl.UTF-8):      GEOS - silnik geometryczny z otwartymi źródłami
9 Name:           geos
10 Version:        3.2.2
11 Release:        2
12 License:        LGPL v2.1
13 Group:          Libraries
14 Source0:        http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
15 # Source0-md5:  c5d264acac22fe7720f85dadc1fc17c6
16 Patch0:         %{name}-ruby1.9.patch
17 Patch1:         %{name}-swig2.patch
18 URL:            http://trac.osgeo.org/geos/
19 BuildRequires:  autoconf >= 2.52
20 BuildRequires:  automake
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  python
23 BuildRequires:  python-devel
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.219
26 %{?with_ruby:BuildRequires:     ruby-devel}
27 BuildRequires:  swig-python >= 1.3.29
28 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.40-3}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 GEOS (Geometry Engine - Open Source) is a C++ port of the Java
33 Topology Suite (JTS). As such, it aims to contain the complete
34 functionality of JTS in C++. This includes all the OpenGIS "Simple
35 Features for SQL" spatial predicate functions and spatial operators,
36 as well as specific JTS topology functions such as IsValid().
37
38 %description -l pl.UTF-8
39 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
40 otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
41 Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
42 JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
43 wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
44 także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
45
46 %package devel
47 Summary:        Header files for GEOS library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GEOS
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       libstdc++-devel
52
53 %description devel
54 Header files for GEOS library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki GEOS.
58
59 %package static
60 Summary:        Static GEOS library
61 Summary(pl.UTF-8):      Statyczna biblioteka GEOS
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static GEOS library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka GEOS.
70
71 %package -n python-geos
72 Summary:        Python bindings for Geometry Engine - Open Source
73 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GEOS
74 Group:          Development/Languages/Python
75 Requires:       %{name} = %{version}-%{release}
76
77 %description -n python-geos
78 Python bindings for Geometry Engine - Open Source.
79
80 %description -n python-geos -l pl.UTF-8
81 Wiązania Pythona do biblioteki GEOS.
82
83 %package -n ruby-geos
84 Summary:        Ruby bindings for Geometry Engine - Open Source
85 Summary(pl.UTF-8):      Wiązania języka Ruby do biblioteki GEOS
86 Group:          Development/Languages/Python
87 Requires:       %{name} = %{version}-%{release}
88
89 %description -n ruby-geos
90 Ruby bindings for Geometry Engine - Open Source.
91
92 %description -n ruby-geos -l pl.UTF-8
93 Wiązania języka Ruby do biblioteki GEOS.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98 %patch1 -p1
99
100 %build
101 %{__aclocal} -I macros
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         --enable-python \
107         %{?with_ruby:--enable-ruby}
108
109 %{__make} \
110         pkglibdir=%{_libdir}
111
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %{?with_ruby:rm -f $RPM_BUILD_ROOT%{ruby_sitearchdir}/*.{la,a}}
120 rm -f $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
121
122 %py_postclean
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog NEWS README TODO
133 %attr(755,root,root) %{_libdir}/libgeos-*.so
134 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_bindir}/geos-config
140 %attr(755,root,root) %{_libdir}/libgeos.so
141 %attr(755,root,root) %{_libdir}/libgeos_c.so
142 %{_libdir}/libgeos.la
143 %{_libdir}/libgeos_c.la
144 %{_includedir}/geos
145 %{_includedir}/geos.h
146 %{_includedir}/geos_c.h
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libgeos.a
151 %{_libdir}/libgeos_c.a
152
153 %files -n python-geos
154 %defattr(644,root,root,755)
155 %dir %{py_sitedir}/geos
156 %attr(755,root,root) %{py_sitedir}/geos/_geos.so
157 %{py_sitescriptdir}/geos
158 %{py_sitescriptdir}/geos.pth
159
160 %if %{with ruby}
161 %files -n ruby-geos
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{ruby_sitearchdir}/geos.so
164 %endif
This page took 0.034206 seconds and 3 git commands to generate.