]> git.pld-linux.org Git - packages/geos.git/blob - geos.spec
- python 2.5 for egg-info
[packages/geos.git] / geos.spec
1 Summary:        Geometry Engine - Open Source
2 Summary(pl):    GEOS - silnik geometryczny z otwartymi ¼ród³ami
3 Name:           geos
4 Version:        2.2.3
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://geos.refractions.net/%{name}-%{version}.tar.bz2
9 # Source0-md5:  440be2b11fd3d711e950a47ea6f1b424
10 Patch0:         %{name}-swig.patch
11 URL:            http://geos.refractions.net/
12 BuildRequires:  automake
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  python >= 1:2.5
15 BuildRequires:  python-devel >= 1:2.5
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  ruby-devel
18 BuildRequires:  swig-python >= 1.3.29
19 BuildRequires:  swig-ruby >= 1.3.29
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 GEOS (Geometry Engine - Open Source) is a C++ port of the Java
24 Topology Suite (JTS). As such, it aims to contain the complete
25 functionality of JTS in C++. This includes all the OpenGIS "Simple
26 Features for SQL" spatial predicate functions and spatial operators,
27 as well as specific JTS topology functions such as IsValid().
28
29 %description -l pl
30 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
31 otwartymi ¼ród³ami) to port C++ biblioteki Java Topology Suite (JTS).
32 Celem biblioteki jako takiej jest implementacja pe³nej funkcjonalno¶ci
33 JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
34 wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
35 tak¿e specyficzne dla JTS funkcje topologiczne takie jak IsValid().
36
37 %package devel
38 Summary:        Header files for GEOS library
39 Summary(pl):    Pliki nag³ówkowe biblioteki GEOS
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       libstdc++-devel
43
44 %description devel
45 Header files for GEOS library.
46
47 %description devel -l pl
48 Pliki nag³ówkowe biblioteki GEOS.
49
50 %package static
51 Summary:        Static GEOS library
52 Summary(pl):    Statyczna biblioteka GEOS
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static GEOS library.
58
59 %description static -l pl
60 Statyczna biblioteka GEOS.
61
62 %package -n python-geos
63 Summary:        Python bindings for Geometry Engine - Open Source
64 Summary(pl):    Wi±zania Pythona do biblioteki GEOS
65 Group:          Development/Languages/Python
66 Requires:       %{name} = %{version}-%{release}
67
68 %description -n python-geos
69 Python bindings for Geometry Engine - Open Source.
70
71 %description -n python-geos -l pl
72 Wi±zania Pythona do biblioteki GEOS.
73
74 %package -n ruby-geos
75 Summary:        Ruby bindings for Geometry Engine - Open Source
76 Summary(pl):    Wi±zania jêzyka Ruby do biblioteki GEOS
77 Group:          Development/Languages/Python
78 Requires:       %{name} = %{version}-%{release}
79
80 %description -n ruby-geos
81 Ruby bindings for Geometry Engine - Open Source.
82
83 %description -n ruby-geos -l pl
84 Wi±zania jêzyka Ruby do biblioteki GEOS.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 %build
91 cp -f /usr/share/automake/config.* .
92 %configure
93 %{__make} \
94         pkglibdir=%{_libdir}
95
96 cd swig/python
97 swig -c++ -python -modern -o geos_wrap.cxx ../geos.i
98 python setup.py build
99
100 cd ../ruby
101 swig -c++ -ruby -autorename -o geos_wrap.cxx ../geos.i
102 %{__cxx} %{rpmcxxflags} -I../../source/headers -I%{ruby_archdir} -c geos_wrap.cxx
103 %{__cxx} -shared -o geos.so geos_wrap.o -lruby -L../../source/geom/.libs -lgeos
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT \
110         pkglibdir=%{_libdir}
111
112 cd swig
113 install -D ruby/geos.so $RPM_BUILD_ROOT%{ruby_archdir}/geos.so
114
115 cd python
116 python setup.py install \
117         --optimize=2 \
118         --root=$RPM_BUILD_ROOT
119
120 %py_postclean
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS ChangeLog NEWS README TODO
131 %attr(755,root,root) %{_libdir}/libgeos.so.*.*.*
132 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/geos-config
137 %attr(755,root,root) %{_libdir}/libgeos.so
138 %attr(755,root,root) %{_libdir}/libgeos_c.so
139 %{_libdir}/libgeos.la
140 %{_libdir}/libgeos_c.la
141 %{_includedir}/geos
142 %{_includedir}/geos.h
143 %{_includedir}/geos_c.h
144
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libgeos.a
148 %{_libdir}/libgeos_c.a
149
150 %files -n python-geos
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{py_sitedir}/_geos.so
153 %{py_sitedir}/geos.py[co]
154 %{py_sitedir}/PyGEOS-*.egg-info
155
156 %files -n ruby-geos
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{ruby_archdir}/geos.so
This page took 0.04043 seconds and 3 git commands to generate.