]> git.pld-linux.org Git - packages/geos.git/blob - geos.spec
- unpackaged file
[packages/geos.git] / geos.spec
1 # TODO
2 # - unpackaged:    /usr/bin/XMLTester
3 #
4 # Conditional build:
5 %bcond_without  ruby    # ruby binding
6 #
7 Summary:        Geometry Engine - Open Source
8 Summary(pl.UTF-8):      GEOS - silnik geometryczny z otwartymi źródłami
9 Name:           geos
10 Version:        3.0.0
11 Release:        1
12 License:        LGPL v2.1
13 Group:          Libraries
14 Source0:        http://geos.refractions.net/downloads/%{name}-%{version}.tar.bz2
15 # Source0-md5:  3f7940abee9fec69a9787878cd3ae771
16 URL:            http://geos.refractions.net/
17 BuildRequires:  automake
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  python
20 BuildRequires:  python-devel
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.219
23 %{?with_ruby:BuildRequires:     ruby-devel}
24 BuildRequires:  swig-python >= 1.3.29
25 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.29}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 GEOS (Geometry Engine - Open Source) is a C++ port of the Java
30 Topology Suite (JTS). As such, it aims to contain the complete
31 functionality of JTS in C++. This includes all the OpenGIS "Simple
32 Features for SQL" spatial predicate functions and spatial operators,
33 as well as specific JTS topology functions such as IsValid().
34
35 %description -l pl.UTF-8
36 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
37 otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
38 Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
39 JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
40 wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
41 także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
42
43 %package devel
44 Summary:        Header files for GEOS library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GEOS
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       libstdc++-devel
49
50 %description devel
51 Header files for GEOS library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki GEOS.
55
56 %package static
57 Summary:        Static GEOS library
58 Summary(pl.UTF-8):      Statyczna biblioteka GEOS
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static GEOS library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka GEOS.
67
68 %package -n python-geos
69 Summary:        Python bindings for Geometry Engine - Open Source
70 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GEOS
71 Group:          Development/Languages/Python
72 Requires:       %{name} = %{version}-%{release}
73
74 %description -n python-geos
75 Python bindings for Geometry Engine - Open Source.
76
77 %description -n python-geos -l pl.UTF-8
78 Wiązania Pythona do biblioteki GEOS.
79
80 %package -n ruby-geos
81 Summary:        Ruby bindings for Geometry Engine - Open Source
82 Summary(pl.UTF-8):      Wiązania języka Ruby do biblioteki GEOS
83 Group:          Development/Languages/Python
84 Requires:       %{name} = %{version}-%{release}
85
86 %description -n ruby-geos
87 Ruby bindings for Geometry Engine - Open Source.
88
89 %description -n ruby-geos -l pl.UTF-8
90 Wiązania języka Ruby do biblioteki GEOS.
91
92 %prep
93 %setup -q
94
95 %build
96 cp -f /usr/share/automake/config.* .
97 %configure \
98         --enable-python \
99         %{?with_ruby:--enable-ruby}
100
101 %{__make} \
102         pkglibdir=%{_libdir}
103
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 %{?with_ruby:rm -f $RPM_BUILD_ROOT%{ruby_sitearchdir}/*.{la,a}}
112 rm -f $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
113
114 %py_postclean
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files
123 %defattr(644,root,root,755)
124 %doc AUTHORS ChangeLog NEWS README TODO
125 %attr(755,root,root) %{_libdir}/libgeos-3.0.0.so
126 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/geos-config
132 %attr(755,root,root) %{_libdir}/libgeos.so
133 %attr(755,root,root) %{_libdir}/libgeos_c.so
134 %{_libdir}/libgeos.la
135 %{_libdir}/libgeos_c.la
136 %{_includedir}/geos
137 %{_includedir}/geos.h
138 %{_includedir}/geos_c.h
139
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libgeos.a
143 %{_libdir}/libgeos_c.a
144
145 %files -n python-geos
146 %defattr(644,root,root,755)
147 %dir %{py_sitedir}/geos
148 %attr(755,root,root) %{py_sitedir}/geos/_geos.so
149 %{py_sitescriptdir}/geos
150 %{py_sitescriptdir}/geos.pth
151
152 %if %{with ruby}
153 %files -n ruby-geos
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{ruby_sitearchdir}/geos.so
156 %endif
This page took 0.034568 seconds and 3 git commands to generate.