]> git.pld-linux.org Git - packages/geos.git/blame - geos.spec
consistent php name
[packages/geos.git] / geos.spec
CommitLineData
33332b8a 1#
38386277 2# Conditional build:
424c3af6 3%bcond_without php # PHP binding
33332b8a 4%bcond_without ruby # ruby binding
6571feb9 5
c12a77e5 6%define php_name php55
7070463c 7Summary: Geometry Engine - Open Source
fd0ef9fd 8Summary(pl.UTF-8): GEOS - silnik geometryczny z otwartymi źródłami
7070463c 9Name: geos
ccc0fb6d 10Version: 3.5.0
fd718a20 11Release: 3
33332b8a 12License: LGPL v2.1
7070463c 13Group: Libraries
a58867fa 14Source0: http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
ccc0fb6d
JB
15# Source0-md5: 136842690be7f504fba46b3c539438dd
16Patch0: %{name}-php7.patch
b0a4937e 17Patch1: rubydir.patch
a58867fa 18URL: http://trac.osgeo.org/geos/
c12a77e5 19%{?with_php:BuildRequires: %{php_name}-devel}
de93cddd 20BuildRequires: autoconf >= 2.52
7070463c
JB
21BuildRequires: automake
22BuildRequires: libstdc++-devel
cfd118c2
ER
23BuildRequires: python
24BuildRequires: python-devel
68bc5314 25BuildRequires: rpm-pythonprov
424c3af6 26BuildRequires: rpmbuild(macros) >= 1.519
38386277 27%{?with_ruby:BuildRequires: ruby-devel}
68bc5314 28BuildRequires: swig-python >= 1.3.29
01dd35cb 29%{?with_ruby:BuildRequires: swig-ruby >= 1.3.40-3}
7070463c
JB
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33GEOS (Geometry Engine - Open Source) is a C++ port of the Java
34Topology Suite (JTS). As such, it aims to contain the complete
35functionality of JTS in C++. This includes all the OpenGIS "Simple
36Features for SQL" spatial predicate functions and spatial operators,
37as well as specific JTS topology functions such as IsValid().
38
e0dd9005 39%description -l pl.UTF-8
7070463c 40GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
e0dd9005
JR
41otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
42Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
c12a77e5
ER
43JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych wg
44"Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a także
45specyficzne dla JTS funkcje topologiczne takie jak IsValid().
7070463c
JB
46
47%package devel
48Summary: Header files for GEOS library
fd0ef9fd 49Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GEOS
7070463c
JB
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: libstdc++-devel
53
54%description devel
55Header files for GEOS library.
56
e0dd9005
JR
57%description devel -l pl.UTF-8
58Pliki nagłówkowe biblioteki GEOS.
7070463c
JB
59
60%package static
61Summary: Static GEOS library
fd0ef9fd 62Summary(pl.UTF-8): Statyczna biblioteka GEOS
7070463c
JB
63Group: Development/Libraries
64Requires: %{name}-devel = %{version}-%{release}
65
66%description static
67Static GEOS library.
68
e0dd9005 69%description static -l pl.UTF-8
7070463c
JB
70Statyczna biblioteka GEOS.
71
6571feb9 72%package -n %{php_name}-geos
424c3af6
JB
73Summary: PHP bindings for Geometry Engine - Open Source
74Summary(pl.UTF-8): Wiązania PHP do biblioteki GEOS
75Group: Development/Languages/PHP
76Requires: %{name} = %{version}-%{release}
77%{?requires_php_extension}
78
6571feb9 79%description -n %{php_name}-geos
424c3af6
JB
80PHP bindings for Geometry Engine - Open Source.
81
6571feb9 82%description -n %{php_name}-geos -l pl.UTF-8
424c3af6
JB
83Wiązania PHP do biblioteki GEOS.
84
2172c3d9 85%package -n python-geos
86Summary: Python bindings for Geometry Engine - Open Source
fd0ef9fd 87Summary(pl.UTF-8): Wiązania Pythona do biblioteki GEOS
adc066a8 88Group: Development/Languages/Python
2172c3d9 89Requires: %{name} = %{version}-%{release}
90
91%description -n python-geos
adc066a8 92Python bindings for Geometry Engine - Open Source.
2172c3d9 93
e0dd9005
JR
94%description -n python-geos -l pl.UTF-8
95Wiązania Pythona do biblioteki GEOS.
2172c3d9 96
68bc5314
JB
97%package -n ruby-geos
98Summary: Ruby bindings for Geometry Engine - Open Source
fd0ef9fd 99Summary(pl.UTF-8): Wiązania języka Ruby do biblioteki GEOS
68bc5314
JB
100Group: Development/Languages/Python
101Requires: %{name} = %{version}-%{release}
102
103%description -n ruby-geos
104Ruby bindings for Geometry Engine - Open Source.
105
e0dd9005
JR
106%description -n ruby-geos -l pl.UTF-8
107Wiązania języka Ruby do biblioteki GEOS.
68bc5314 108
7070463c 109%prep
33332b8a 110%setup -q
01dd35cb 111%patch0 -p1
4f288115 112%patch1 -p1
7070463c
JB
113
114%build
01dd35cb
JR
115%{__aclocal} -I macros
116%{__autoconf}
117%{__autoheader}
118%{__automake}
11971862 119%configure \
424c3af6 120 %{?with_php:--enable-php} \
11971862 121 --enable-python \
ce6851f1 122 %{?with_ruby:--enable-ruby}
11971862 123
7070463c
JB
124%{__make} \
125 pkglibdir=%{_libdir}
126
68bc5314 127
7070463c
JB
128%install
129rm -rf $RPM_BUILD_ROOT
130
131%{__make} install \
ccc0fb6d
JB
132 DESTDIR=$RPM_BUILD_ROOT \
133 pythondir=%{py_sitescriptdir}
33332b8a 134
424c3af6
JB
135%if %{with php}
136install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
137cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/geos.ini
138; Enable geos extension module
139extension=geos.so
140EOF
141%endif
142
ce6851f1 143%{?with_ruby:%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/*.{la,a}}
424c3af6 144%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
7070463c 145
02cf38a4 146%py_postclean
68bc5314 147
7070463c
JB
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151%post -p /sbin/ldconfig
152%postun -p /sbin/ldconfig
153
154%files
155%defattr(644,root,root,755)
02cf38a4 156%doc AUTHORS ChangeLog NEWS README TODO
ccc0fb6d 157%attr(755,root,root) %{_libdir}/libgeos-%{version}.so
6a9f7429 158%attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
33332b8a 159%attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
7070463c
JB
160
161%files devel
162%defattr(644,root,root,755)
163%attr(755,root,root) %{_bindir}/geos-config
6a9f7429
JB
164%attr(755,root,root) %{_libdir}/libgeos.so
165%attr(755,root,root) %{_libdir}/libgeos_c.so
166%{_libdir}/libgeos.la
167%{_libdir}/libgeos_c.la
7070463c 168%{_includedir}/geos
413fb971 169%{_includedir}/geos.h
6a9f7429 170%{_includedir}/geos_c.h
7070463c
JB
171
172%files static
173%defattr(644,root,root,755)
6a9f7429
JB
174%{_libdir}/libgeos.a
175%{_libdir}/libgeos_c.a
2172c3d9 176
424c3af6 177%if %{with php}
6571feb9 178%files -n %{php_name}-geos
424c3af6
JB
179%defattr(644,root,root,755)
180%doc php/{README,TODO}
181%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/geos.ini
182%attr(755,root,root) %{php_extensiondir}/geos.so
183%endif
184
2172c3d9 185%files -n python-geos
186%defattr(644,root,root,755)
11971862 187%dir %{py_sitedir}/geos
188%attr(755,root,root) %{py_sitedir}/geos/_geos.so
33332b8a
JB
189%{py_sitescriptdir}/geos
190%{py_sitescriptdir}/geos.pth
68bc5314 191
38386277 192%if %{with ruby}
68bc5314
JB
193%files -n ruby-geos
194%defattr(644,root,root,755)
71f7add8 195%attr(755,root,root) %{ruby_vendorarchdir}/geos.so
38386277 196%endif
This page took 0.138017 seconds and 4 git commands to generate.