]> git.pld-linux.org Git - packages/geos.git/blame - geos.spec
- added swig2 patch to allow build with swig 2.0.x
[packages/geos.git] / geos.spec
CommitLineData
b31b638f
ER
1# TODO
2# - unpackaged: /usr/bin/XMLTester
33332b8a 3#
38386277 4# Conditional build:
33332b8a 5%bcond_without ruby # ruby binding
38386277 6#
7070463c 7Summary: Geometry Engine - Open Source
fd0ef9fd 8Summary(pl.UTF-8): GEOS - silnik geometryczny z otwartymi źródłami
7070463c 9Name: geos
fdb1a3ad 10Version: 3.2.2
9132b2c3 11Release: 2
33332b8a 12License: LGPL v2.1
7070463c 13Group: Libraries
a58867fa 14Source0: http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
fdb1a3ad 15# Source0-md5: c5d264acac22fe7720f85dadc1fc17c6
01dd35cb 16Patch0: %{name}-ruby1.9.patch
6d476abe 17Patch1: %{name}-swig2.patch
a58867fa 18URL: http://trac.osgeo.org/geos/
de93cddd 19BuildRequires: autoconf >= 2.52
7070463c
JB
20BuildRequires: automake
21BuildRequires: libstdc++-devel
cfd118c2
ER
22BuildRequires: python
23BuildRequires: python-devel
68bc5314 24BuildRequires: rpm-pythonprov
33332b8a 25BuildRequires: rpmbuild(macros) >= 1.219
38386277 26%{?with_ruby:BuildRequires: ruby-devel}
68bc5314 27BuildRequires: swig-python >= 1.3.29
01dd35cb 28%{?with_ruby:BuildRequires: swig-ruby >= 1.3.40-3}
7070463c
JB
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32GEOS (Geometry Engine - Open Source) is a C++ port of the Java
33Topology Suite (JTS). As such, it aims to contain the complete
34functionality of JTS in C++. This includes all the OpenGIS "Simple
35Features for SQL" spatial predicate functions and spatial operators,
36as well as specific JTS topology functions such as IsValid().
37
e0dd9005 38%description -l pl.UTF-8
7070463c 39GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
e0dd9005
JR
40otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
41Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
42JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
7070463c 43wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
e0dd9005 44także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
7070463c
JB
45
46%package devel
47Summary: Header files for GEOS library
fd0ef9fd 48Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GEOS
7070463c
JB
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51Requires: libstdc++-devel
52
53%description devel
54Header files for GEOS library.
55
e0dd9005
JR
56%description devel -l pl.UTF-8
57Pliki nagłówkowe biblioteki GEOS.
7070463c
JB
58
59%package static
60Summary: Static GEOS library
fd0ef9fd 61Summary(pl.UTF-8): Statyczna biblioteka GEOS
7070463c
JB
62Group: Development/Libraries
63Requires: %{name}-devel = %{version}-%{release}
64
65%description static
66Static GEOS library.
67
e0dd9005 68%description static -l pl.UTF-8
7070463c
JB
69Statyczna biblioteka GEOS.
70
2172c3d9 71%package -n python-geos
72Summary: Python bindings for Geometry Engine - Open Source
fd0ef9fd 73Summary(pl.UTF-8): Wiązania Pythona do biblioteki GEOS
adc066a8 74Group: Development/Languages/Python
2172c3d9 75Requires: %{name} = %{version}-%{release}
76
77%description -n python-geos
adc066a8 78Python bindings for Geometry Engine - Open Source.
2172c3d9 79
e0dd9005
JR
80%description -n python-geos -l pl.UTF-8
81Wiązania Pythona do biblioteki GEOS.
2172c3d9 82
68bc5314
JB
83%package -n ruby-geos
84Summary: Ruby bindings for Geometry Engine - Open Source
fd0ef9fd 85Summary(pl.UTF-8): Wiązania języka Ruby do biblioteki GEOS
68bc5314
JB
86Group: Development/Languages/Python
87Requires: %{name} = %{version}-%{release}
88
89%description -n ruby-geos
90Ruby bindings for Geometry Engine - Open Source.
91
e0dd9005
JR
92%description -n ruby-geos -l pl.UTF-8
93Wiązania języka Ruby do biblioteki GEOS.
68bc5314 94
7070463c 95%prep
33332b8a 96%setup -q
01dd35cb 97%patch0 -p1
6d476abe 98%patch1 -p1
7070463c
JB
99
100%build
01dd35cb
JR
101%{__aclocal} -I macros
102%{__autoconf}
103%{__autoheader}
104%{__automake}
11971862 105%configure \
106 --enable-python \
107 %{?with_ruby:--enable-ruby}
108
7070463c
JB
109%{__make} \
110 pkglibdir=%{_libdir}
111
68bc5314 112
7070463c
JB
113%install
114rm -rf $RPM_BUILD_ROOT
115
116%{__make} install \
33332b8a
JB
117 DESTDIR=$RPM_BUILD_ROOT
118
119%{?with_ruby:rm -f $RPM_BUILD_ROOT%{ruby_sitearchdir}/*.{la,a}}
120rm -f $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
7070463c 121
02cf38a4 122%py_postclean
68bc5314 123
7070463c
JB
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post -p /sbin/ldconfig
128%postun -p /sbin/ldconfig
129
130%files
131%defattr(644,root,root,755)
02cf38a4 132%doc AUTHORS ChangeLog NEWS README TODO
a58867fa 133%attr(755,root,root) %{_libdir}/libgeos-*.so
6a9f7429 134%attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
33332b8a 135%attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
7070463c
JB
136
137%files devel
138%defattr(644,root,root,755)
139%attr(755,root,root) %{_bindir}/geos-config
6a9f7429
JB
140%attr(755,root,root) %{_libdir}/libgeos.so
141%attr(755,root,root) %{_libdir}/libgeos_c.so
142%{_libdir}/libgeos.la
143%{_libdir}/libgeos_c.la
7070463c 144%{_includedir}/geos
413fb971 145%{_includedir}/geos.h
6a9f7429 146%{_includedir}/geos_c.h
7070463c
JB
147
148%files static
149%defattr(644,root,root,755)
6a9f7429
JB
150%{_libdir}/libgeos.a
151%{_libdir}/libgeos_c.a
2172c3d9 152
153%files -n python-geos
154%defattr(644,root,root,755)
11971862 155%dir %{py_sitedir}/geos
156%attr(755,root,root) %{py_sitedir}/geos/_geos.so
33332b8a
JB
157%{py_sitescriptdir}/geos
158%{py_sitescriptdir}/geos.pth
68bc5314 159
38386277 160%if %{with ruby}
68bc5314
JB
161%files -n ruby-geos
162%defattr(644,root,root,755)
33332b8a 163%attr(755,root,root) %{ruby_sitearchdir}/geos.so
38386277 164%endif
This page took 0.0659459999999999 seconds and 4 git commands to generate.