]> git.pld-linux.org Git - packages/geocode-glib.git/blob - geocode-glib.spec
Initial release
[packages/geocode-glib.git] / geocode-glib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        GLib geocoding library that uses the Yahoo! Place Finder service
7 Name:           geocode-glib
8 Version:        0.99.0
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://download.gnome.org/sources/geocode-glib/0.99/%{name}-%{version}.tar.bz2
13 # Source0-md5:  73ac778225f35ad996ea0345c5abe4b9
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake >= 1:1.8
16 BuildRequires:  gettext-devel
17 BuildRequires:  glib2-devel >= 1:2.16.0
18 BuildRequires:  gnome-common
19 BuildRequires:  gobject-introspection-devel >= 0.6.3
20 BuildRequires:  gtk-doc >= 1.9
21 BuildRequires:  intltool >= 0.35.0
22 BuildRequires:  json-glib-devel >= 0.13.1
23 BuildRequires:  libsoup-devel
24 BuildRequires:  libtool
25 BuildRequires:  pkgconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 geocode-glib allows you to do geocoding (going from a place name, to a
30 longitude/latitude pair) and reverse geocoding (finding a place name
31 from coordinates).
32
33 %package devel
34 Summary:        Header files for geocode-glib library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki geocode-glib
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for geocode-glib library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki geocode-glib.
44
45 %package static
46 Summary:        Static geocode-glib library
47 Summary(pl.UTF-8):      Statyczna biblioteka geocode-glib
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static geocode-glib library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka geocode-glib.
56
57 %package apidocs
58 Summary:        geocode-glib API documentation
59 Summary(pl.UTF-8):      Dokumentacja API biblioteki geocode-glib
60 Group:          Documentation
61 Requires:       gtk-doc-common
62
63 %description apidocs
64 API documentation for geocode-glib library.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API biblioteki geocode-glib.
68
69 %prep
70 %setup -q
71
72 %build
73 %{__intltoolize}
74 %{__libtoolize}
75 %{__aclocal}
76 %{__autoconf}
77 %{__autoheader}
78 %{__automake}
79 %configure \
80         %{__enable_disable apidocs gtk-doc} \
81         %{__enable_disable static_libs static} \
82         --with-html-dir=%{_gtkdocdir}
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc AUTHORS ChangeLog NEWS README TODO
100 %attr(755,root,root) %{_libdir}/libgeocode-glib.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libgeocode-glib.so.0
102 %{_libdir}/girepository-1.0/GeocodeGlib-1.0.typelib
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libgeocode-glib.so
107 %{_libdir}/libgeocode-glib.la
108 %{_includedir}/geocode-glib
109 %{_datadir}/gir-1.0/GeocodeGlib-1.0.gir
110 %{_pkgconfigdir}/geocode-glib.pc
111
112 %if %{with static_libs}
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/libgeocode-glib.a
116 %endif
117
118 %if %{with apidocs}
119 %files apidocs
120 %defattr(644,root,root,755)
121 %{_gtkdocdir}/geocode-glib
122 %endif
This page took 0.066329 seconds and 3 git commands to generate.