]> git.pld-linux.org Git - packages/geoclue2.git/commitdiff
- added support for NM 0.9
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Thu, 7 Apr 2011 13:07:28 +0000 (13:07 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- release 5

Changed files:
    geoclue-nm09.patch -> 1.1
    geoclue.spec -> 1.17

geoclue-nm09.patch [new file with mode: 0644]
geoclue.spec

diff --git a/geoclue-nm09.patch b/geoclue-nm09.patch
new file mode 100644 (file)
index 0000000..fdec5ac
--- /dev/null
@@ -0,0 +1,43 @@
+From f2f988bfdda6a347a8190612af1501466b64d76b Mon Sep 17 00:00:00 2001
+From: Dan Williams <dcbw@redhat.com>
+Date: Mon, 07 Mar 2011 23:45:45 +0000
+Subject: master: Support NetworkManager 0.9
+
+---
+diff --git a/src/connectivity-networkmanager.c b/src/connectivity-networkmanager.c
+index a545073..09630a0 100644
+--- a/src/connectivity-networkmanager.c
++++ b/src/connectivity-networkmanager.c
+@@ -38,6 +38,10 @@
+ #include <nm-device-wifi.h>
+ #include <nm-setting-ip4-config.h>
++#if !defined(NM_CHECK_VERSION)
++#define NM_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #include "connectivity-networkmanager.h"
+ static void geoclue_networkmanager_connectivity_init (GeoclueConnectivityInterface *iface);
+@@ -285,10 +289,19 @@ nmstate_to_geocluenetworkstatus (NMState status)
+                       return GEOCLUE_CONNECTIVITY_UNKNOWN;
+               case NM_STATE_ASLEEP:
+               case NM_STATE_DISCONNECTED:
++#if NM_CHECK_VERSION(0,8,992)
++              case NM_STATE_DISCONNECTING:
++#endif
+                       return GEOCLUE_CONNECTIVITY_OFFLINE;
+               case NM_STATE_CONNECTING:
+                       return GEOCLUE_CONNECTIVITY_ACQUIRING;
++#if NM_CHECK_VERSION(0,8,992)
++              case NM_STATE_CONNECTED_LOCAL:
++              case NM_STATE_CONNECTED_SITE:
++              case NM_STATE_CONNECTED_GLOBAL:
++#else
+               case NM_STATE_CONNECTED:
++#endif
+                       return GEOCLUE_CONNECTIVITY_ONLINE;
+               default:
+                       g_warning ("Unknown NMStatus: %d", status);
+--
+cgit v0.8.3-6-g21f6
index 01d0a834eea996305347691bbac0a2af44e28a54..e81606523e9015f8fab5f6fefbc13c6ed7883d5f 100644 (file)
@@ -2,13 +2,14 @@ Summary:      A modular geoinformation service
 Summary(pl.UTF-8):     Modularna usÅ‚uga geoinformacyjna
 Name:          geoclue
 Version:       0.12.0
-Release:       4
+Release:       5
 License:       LGPL v2
 Group:         Applications
 Source0:       http://folks.o-hand.com/jku/geoclue-releases/%{name}-%{version}.tar.gz
 # Source0-md5: 33af8307f332e0065af056ecba65fec2
 Patch0:                %{name}-configure.patch
 Patch1:                %{name}-libsoup.patch
+Patch2:                %{name}-nm09.patch
 URL:           http://geoclue.freedesktop.org/
 BuildRequires: GConf2-devel >= 2.0
 BuildRequires: NetworkManager-devel
@@ -120,6 +121,7 @@ Interfejs geoclue do gypsy.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__gtkdocize}
This page took 0.130045 seconds and 4 git commands to generate.