]> git.pld-linux.org Git - packages/geoclue2.git/blob - geoclue2.spec
- updated to 2.7.0; service uses libsoup3 now
[packages/geoclue2.git] / geoclue2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        A modular geoinformation service
6 Summary(pl.UTF-8):      Modularna usługa geoinformacyjna
7 Name:           geoclue2
8 Version:        2.4.7
9 Release:        1
10 License:        GPL v2+ (programs), LGPL v2.1+ (library)
11 Group:          Applications
12 Source0:        https://www.freedesktop.org/software/geoclue/releases/2.4/geoclue-%{version}.tar.xz
13 # Source0-md5:  e50086e742740413669ab72d8572db05
14 URL:            https://geoclue.freedesktop.org/
15 BuildRequires:  ModemManager-devel >= 1.0.0
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  avahi-devel >= 0.6.10
19 BuildRequires:  avahi-glib-devel >= 0.6.10
20 BuildRequires:  glib2-devel >= 1:2.34.0
21 BuildRequires:  gnome-common
22 BuildRequires:  gobject-introspection-devel >= 0.10
23 BuildRequires:  gtk-doc >= 1.0
24 BuildRequires:  intltool >= 0.40.0
25 BuildRequires:  json-glib-devel >= 0.14
26 BuildRequires:  libnotify-devel
27 BuildRequires:  libsoup-devel >= 2.42
28 BuildRequires:  libtool >= 2:2.2
29 BuildRequires:  pkgconfig >= 1:0.22
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  yelp-tools
32 BuildRequires:  xz
33 Requires:       %{name}-libs = %{version}-%{release}
34 Requires:       avahi-libs >= 0.6.10
35 Requires:       avahi-glib >= 0.6.10
36 Requires:       dbus
37 Requires:       json-glib >= 0.14
38 Requires:       libsoup >= 2.42
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Geoclue is a modular geoinformation service built on top of the D-Bus
43 messaging system. The goal of the Geoclue project is to make creating
44 location-aware applications as simple as possible.
45
46 %description -l pl.UTF-8
47 Geoclue to modularna usługa geoinformacyjna zbudowana w oparciu o
48 system komunikacji D-Bus. Celem projektu jest jak największe
49 ułatwienie tworzenia aplikacji uwzględniających lokalizację.
50
51 %package libs
52 Summary:        Library to interact with Geoclue service
53 Summary(pl.UTF-8):      Biblioteka do współpracy z usługą Geoclue
54 License:        LGPL v2.1+
55 Group:          Libraries
56 Requires:       glib2 >= 1:2.34.0
57
58 %description libs
59 Library to interact with Geoclue service.
60
61 %description libs -l pl.UTF-8
62 Biblioteka do współpracy z usługą Geoclue.
63
64 %package devel
65 Summary:        Development package for geoclue2
66 Summary(pl.UTF-8):      Pakiet programistyczny geoclue2
67 License:        LGPL v2.1+
68 Group:          Development/Libraries
69 Requires:       %{name}-libs = %{version}-%{release}
70 Requires:       glib2-devel >= 1:2.34.0
71
72 %description devel
73 Header files for development with geoclue2.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe do programowania z użyciem geoclue2.
77
78 %package static
79 Summary:        Static geoclue2 library
80 Summary(pl.UTF-8):      Statyczna biblioteka geoclue2
81 License:        LGPL v2.1+
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static geoclue2 library.
87
88 %description static -l pl.UTF-8
89 Statyczna biblioteka geoclue2.
90
91 %prep
92 %setup -q -n geoclue-%{version}
93
94 %build
95 %{__intltoolize}
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         --enable-demo-agent \
103         --disable-silent-rules \
104         %{?with_static_libs:--enable-static} \
105         --with-systemdsystemunitdir=%{systemdunitdir}
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 # obsoleted by pkg-config
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgeoclue-2.la
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   libs -p /sbin/ldconfig
122 %postun libs -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc NEWS README
127 %attr(755,root,root) %{_libexecdir}/geoclue
128 %dir %{_sysconfdir}/geoclue
129 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/geoclue/geoclue.conf
130 %{systemdunitdir}/geoclue.service
131 /etc/dbus-1/system.d/org.freedesktop.GeoClue2.conf
132 /etc/dbus-1/system.d/org.freedesktop.GeoClue2.Agent.conf
133 %{_datadir}/dbus-1/system-services/org.freedesktop.GeoClue2.service
134 # demos
135 %dir %{_libexecdir}/geoclue-2.0
136 %dir %{_libexecdir}/geoclue-2.0/demos
137 %attr(755,root,root) %{_libexecdir}/geoclue-2.0/demos/agent
138 %attr(755,root,root) %{_libexecdir}/geoclue-2.0/demos/where-am-i
139 %{_desktopdir}/geoclue-demo-agent.desktop
140 %{_desktopdir}/geoclue-where-am-i.desktop
141
142 %files libs
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libgeoclue-2.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libgeoclue-2.so.0
146 %{_libdir}/girepository-1.0/Geoclue-2.0.typelib
147
148 %files devel
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_libdir}/libgeoclue-2.so
151 %{_includedir}/libgeoclue-2.0
152 %{_datadir}/gir-1.0/Geoclue-2.0.gir
153 %{_pkgconfigdir}/geoclue-2.0.pc
154 %{_pkgconfigdir}/libgeoclue-2.0.pc
155 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.xml
156 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Agent.xml
157 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Client.xml
158 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Location.xml
159 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Manager.xml
160
161 %if %{with static_libs}
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libgeoclue-2.a
165 %endif
This page took 0.087371 seconds and 3 git commands to generate.