]> git.pld-linux.org Git - packages/gentoo.git/blobdiff - gentoo.spec
- s/^Terminal=0/Terminal=false/ s/^Terminal=1/Terminal=true/ to conform
[packages/gentoo.git] / gentoo.spec
index 7172e83f96c91c38ad1902cc5150fe5dacd32b2e..7a090060428f2bbcf7e8688b94faa067387e7f2a 100644 (file)
@@ -1,83 +1,84 @@
-Summary:       gentoo is a Gtk+ file manager for Linux.
-Summary(pl):   gentoo jest opartym na Gtk+ zarz±dc± plików pod Linuxa.
+Summary:       gentoo is a Gtk+ file manager for Linux
+Summary(pl):   gentoo jest opartym na Gtk+ zarz±dc± plików pod Linuksa
 Name:          gentoo
-Version:       0.11.11
+Version:       0.11.43
 Release:       1
-Copyright:     GPL
-Group:         X11/Utilities
-Group(pl):     X11/Narzêdzia
-URL:           http://www.obsession.se/gentoo
-Source0:       ftp://ftp.obsession.se/gentoo/%{name}-%{version}.tar.gz
-Source1:       gentoo.desktop
-Patch0:                gentoo-makefile.patch
-Patch1:                gentoo-config.patch
+License:       GPL
+Group:         X11/Applications
+Source0:       http://dl.sourceforge.net/gentoo/%{name}-%{version}.tar.gz
+# Source0-md5: 54befd2974123209faf049401de9616d
+Source1:       %{name}.desktop
+Source2:       %{name}.png
+Patch0:                %{name}-etc_dir.patch
+URL:           http://www.obsession.se/gentoo/
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: gettext-devel
 BuildRequires: gtk+-devel >= 1.2.0
-BuildRequires: glib-devel >= 1.2.0
-BuildRequires: XFree86-devel
+BuildRequires: libtool
 Requires:      file
-BuildRoot:     /tmp/%{name}-%{version}-root
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define        _prefix         /usr/X11R6
-%define        _mandir         %{_prefix}/man
-%define                _applnkdir      %{_datadir}/applnk
+%define                _sysconfdir     /etc/X11
 
 %description
 gentoo is a file manager for Linux written from scratch in pure C. It
 uses the GTK+ toolkit for all of its interface needs. gentoo provides
-100%% GUI configurability; no need to edit config files by hand and re-
-start the program. gentoo supports identifying the type of various
-files (using extension, regular expressions, and/or the 'file' command),
-and can display files of different types with different colors and icons.
-gentoo borrows some of its look and feel from the classic Amiga
-file manager "Directory OPUS"(TM) (written by Jonathan Potter).
+100%% GUI configurability; no need to edit config files by hand and
+re- start the program. gentoo supports identifying the type of various
+files (using extension, regular expressions, and/or the 'file'
+command), and can display files of different types with different
+colors and icons. gentoo borrows some of its look and feel from the
+classic Amiga file manager "Directory OPUS"(TM) (written by Jonathan
+Potter).
 
 %description -l pl
-gentoo jest zarz±dc± plików dla Linuxa napisanym 'od zera' w czystym C.
-U¿ywa zestawu narzêdzi GTK+ do zaspokojenia wszystkich potrzeb zwi±zanych
-z interfejsem. gentoo zapewnia 100%-ow± konfigurowalno¶æ graficznego 
-interfejsu; nie ma potrzeby rêcznego edytowania plików konfiguracyjnch
-i ponownego uruchamiania programu. gentoo dostarcza identyfikacjê typów
-ró¿nych plików (u¿ywaj±c rozszerzenia, wyra¿eñ regularnych i/lub polecenia
-'file') oraz potrafi wy¶wietlaæ pliki ró¿nego typu w ró¿nych kolorach
-i z ró¿nymi ikonami. gentoo zapo¿ycza trochê ze swojego wygl±du od 
-klasycznego zarz±dcy plików Amigi -- "Directory OPUS"(TM) (napisanego
-przez Jonathana Pottera).
+gentoo jest zarz±dc± plików dla Linuksa napisanym 'od zera' w czystym
+C. U¿ywa zestawu narzêdzi GTK+ do zaspokojenia wszystkich potrzeb
+zwi±zanych z interfejsem. gentoo zapewnia 100%-ow± konfigurowalno¶æ
+graficznego interfejsu; nie ma potrzeby rêcznego edytowania plików
+konfiguracyjnch i ponownego uruchamiania programu. gentoo dostarcza
+identyfikacjê typów ró¿nych plików (u¿ywaj±c rozszerzenia, wyra¿eñ
+regularnych i/lub polecenia 'file') oraz potrafi wy¶wietlaæ pliki
+ró¿nego typu w ró¿nych kolorach i z ró¿nymi ikonami. gentoo zapo¿ycza
+trochê ze swojego wygl±du od klasycznego zarz±dcy plików Amigi --
+"Directory OPUS"(TM) (napisanego przez Jonathana Pottera).
 
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p0
 
 %build
-make DEBUG="$RPM_OPT_FLAGS" 
+rm -f missing
+%{__gettextize}
+%{__aclocal}
+%{__autoconf}
+%{__automake}
+%configure
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_applnkdir}/Utilities,%{_pixmapsdir}}
 
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1} \
-       $RPM_BUILD_ROOT{%{_datadir}/%{name}/icons,%{_applnkdir}/Utilities}
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-install -s %{name}      $RPM_BUILD_ROOT%{_bindir}
-install gentoorc-example $RPM_BUILD_ROOT%{_datadir}/%{name}/gentoorc
-install icons/*                 $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
-install docs/%{name}.1x  $RPM_BUILD_ROOT%{_mandir}/man1
-install %{SOURCE1}      $RPM_BUILD_ROOT%{_applnkdir}/Utilities
+install docs/gentoo.1x $RPM_BUILD_ROOT%{_mandir}/man1
+install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Utilities
+install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
 
-gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
-       BUGS FIXES-0.11 FIXES-0.9 README README.gtkrc CONFIG-CHANGES \
-       CREDITS docs/scratch/*
+%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files
+%files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc {BUGS,FIXES-0.11,FIXES-0.9,README,README.gtkrc,CONFIG-CHANGES,CREDITS}.gz
-%doc docs/{*.{html,css},images,config,scratch} 
-%doc gentoogtkrc-example gentoorc-example
-
+%doc AUTHORS BUGS CREDITS ChangeLog NEWS README* TODO docs
+%config %{_sysconfdir}/*
 %attr(755,root,root) %{_bindir}/%{name}
 %{_datadir}/%{name}
 %{_mandir}/man1/*
-
 %{_applnkdir}/Utilities/gentoo.desktop
+%{_pixmapsdir}/*
This page took 0.112556 seconds and 4 git commands to generate.