]> git.pld-linux.org Git - packages/geninitrd.git/commitdiff
- rel 2; compressors list changed to make best (size) ones as first; always add parti...
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 31 Jan 2016 16:04:15 +0000 (17:04 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 31 Jan 2016 16:04:15 +0000 (17:04 +0100)
geninitrd-git.patch
geninitrd.spec

index e69de29bb2d1d6434b8b29ae775ad8c2e48c5391..90d528abe80adda6c9aec88cbfb499d9b0643a18 100644 (file)
@@ -0,0 +1,36 @@
+diff --git a/geninitrd b/geninitrd
+index 7b962b5..a4de196 100755
+--- a/geninitrd
++++ b/geninitrd
+@@ -1103,8 +1103,7 @@ sym_exists() {
+ # find best compressor (or forced one) for initrd
+ find_compressor() {
+       local mode="$1"
+-      # fastest initrd decompression speed is first
+-      local compressors='lzo gzip xz lzma bzip2'
++      local compressors='xz lzma bzip2 gzip lzo'
+       # a specified one, take it
+       if ! is_yes "$mode"; then
+diff --git a/mod-md.sh b/mod-md.sh
+index a0cd7aa..d9093d4 100644
+--- a/mod-md.sh
++++ b/mod-md.sh
+@@ -139,13 +139,15 @@ initrd_gen_md() {
+       inst_exec $mdassemble /bin/mdassemble
++      echo "DEVICE partitions containers" >> "$DESTDIR/etc/mdadm.conf"
++
+       # LVM on RAID case
+       local dev_list_extra ex_dev
+       dev_list_extra=$(awk '/^DEVICE / { for (i=2; i<=NF; i++) { printf "%s ", $i; }; } ' /etc/mdadm.conf | xargs)
+       new_dev_list_extra=""
+       for ex_dev in $dev_list_extra; do
+-              if [ "$ex_dev" = "partitions" ]; then
+-                      echo "DEVICE partitions" >> "$DESTDIR/etc/mdadm.conf"
++              if [ "$ex_dev" = "partitions" -o "$ex_dev" = "containers" ]; then
++                      echo "DEVICE $ex_dev" >> "$DESTDIR/etc/mdadm.conf"
+                       # FIXME: find and copy partition devices from /proc/partitions
+                       #        - best if done at runtime, now initrd gen time
+                       continue
index 5af4ffd1da5f423275bd42ce3946487b36d59364..66eeee67e31ffeb46d5e7c4e173d61e07884f27e 100644 (file)
@@ -7,7 +7,7 @@ Summary:        Creates an initial ramdisk image for preloading modules
 Summary(pl.UTF-8):     Narzędzie do tworzenia inicjalnego ramdysku używanego przy starcie systemu
 Name:          geninitrd
 Version:       12757
-Release:       1
+Release:       2
 License:       GPL
 Group:         Applications/System
 Source0:       %{name}-%{version}.tar.gz
This page took 0.119436 seconds and 4 git commands to generate.