]> git.pld-linux.org Git - packages/geninitrd.git/commitdiff
- rel 4; fix mod-sata finding too much bug auto/th/geninitrd-10000_32-5
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 6 Mar 2011 16:15:17 +0000 (16:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    geninitrd-svn.patch -> 2.3
    geninitrd.spec -> 2.179

geninitrd-svn.patch
geninitrd.spec

index c51766514826719270937e253824299ea2ca9c1e..89b8106c6f9055af841fa39b828a1cecc52677d7 100644 (file)
@@ -27,3 +27,30 @@ Index: geninitrd
                        fi
                        if [ -n "$rootnr" ]; then
                                echo "$rootnr" > /proc/sys/kernel/real-root-dev
+Index: mod-sata.sh
+===================================================================
+--- mod-sata.sh        (wersja 12194)
++++ mod-sata.sh        (kopia robocza)
+@@ -17,7 +17,7 @@
+ # private until only mod-sata uses the function
+ find_modules_by_class() {
+-      local class=$1
++      local req_class=$1
+       # no pcimap, nothing to lookup from
+       if [ ! -f "$pcimap" ]; then
+@@ -28,10 +28,12 @@
+               return
+       fi
+-      set -- $($lspci -n | awk -vclass=$class '$2 == class":" {split($3, p, ":"); printf("0x0000%s 0x0000%s\n", p[1], p[2])}')
++      set -- $($lspci -n | awk -vclass=$req_class '$2 == class":" {split($3, p, ":"); printf("0x0000%s 0x0000%s\n", p[1], p[2])}')
+       local PCI_ANY_ID=0x0000ffff pci_module vendor device subvendor subdevice class class_mask driver_data
+       while read pci_module vendor device subvendor subdevice class class_mask driver_data; do
++              # match class
++              [ "$(($req_class & $class_mask))" = "$class" ] || continue
+               # match vendor
+               [ "$1" = "$vendor" ] || continue
+               # match device, allow PCI_ANY_ID
index 686bcb61b22c4598ed273e3a1d70b70170eb2593..d1012e69ad28c2568f0e061223115a02ef7a4f55 100644 (file)
@@ -8,7 +8,7 @@ Summary(pl.UTF-8):      Narzędzie do tworzenia inicjalnego ramdysku używanego przy
 Name:          geninitrd
 Version:       10000.32
 # leave rel 1 for ac
-Release:       4
+Release:       5
 License:       GPL
 Group:         Applications/System
 Source0:       %{name}-%{version}.tar.gz
This page took 0.255732 seconds and 4 git commands to generate.