]> git.pld-linux.org Git - packages/geninitrd.git/blame_incremental - geninitrd.spec
- rel 6; don't resolve symlink for luks device nodes
[packages/geninitrd.git] / geninitrd.spec
... / ...
CommitLineData
1### TODO:
2# - BUG: you can't set in /etc/mdadm.conf:
3# DEVICE partitions containers
4# (which is default BTW if none set). Generation of initrd will fail
5#
6Summary: Creates an initial ramdisk image for preloading modules
7Summary(pl.UTF-8): Narzędzie do tworzenia inicjalnego ramdysku używanego przy starcie systemu
8Name: geninitrd
9Version: 10000.32
10# leave rel 1 for ac
11Release: 6
12License: GPL
13Group: Applications/System
14Source0: %{name}-%{version}.tar.gz
15# Source0-md5: 9d75e347ff49312209e97ead93378f4a
16Patch0: %{name}-romfs.patch
17Patch1: %{name}-gzip-compressor.patch
18Patch2: %{name}-svn.patch
19BuildRequires: xmlto >= 0:0.0.18-1
20Requires: /usr/bin/ldd
21Requires: awk
22Requires: busybox-initrd > 1.00-4
23Requires: coreutils
24Requires: cpio
25Requires: fileutils
26Requires: genromfs
27Requires: gzip
28Requires: mktemp >= 1.5-8
29Requires: module-init-tools >= 3.2.2-6
30Requires: mount
31Requires: pci-database >= 0.4
32Requires: rc-scripts >= 0.2.7
33Requires: tar
34%if "%{pld_release}" == "ti"
35Requires: lvm2-initrd
36Requires: mdadm-initrd >= 1.12.0-1
37%else
38# otherwise LVM subsystem is not enabled in geninitrd
39Suggests: lvm2-initrd
40# without this softraid installations of PLD fail
41Suggests: mdadm-initrd >= 1.12.0-1
42%endif
43# suggest for blkid
44%if "%{pld_release}" != "ac"
45Suggests: util-linux-initrd
46%endif
47Obsoletes: mkinitrd
48%if "%{pld_release}" == "ac"
49Conflicts: grubby < 5.0.4-3.1
50%else
51Conflicts: grubby < 6.0.24-3
52%endif
53Conflicts: udev-initrd < 1:104
54Conflicts: xz < 4.999.9
55BuildArch: noarch
56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58%description
59Geninitrd creates filesystem images for use as initial ramdisk
60(initrd) images. These ramdisk images are often used to preload the
61block device modules (SCSI or RAID) needed to access the root
62filesystem.
63
64In other words, generic kernels can be built without drivers for any
65SCSI adapters which load the SCSI driver as a module. Since the kernel
66needs to read those modules, but in this case it isn't able to address
67the SCSI adapter, an initial ramdisk is used. The initial ramdisk is
68loaded by the operating system loader (normally LILO) and is available
69to the kernel as soon as the ramdisk is loaded. The ramdisk image
70loads the proper SCSI adapter and allows the kernel to mount the root
71filesystem. The geninitrd program creates such a ramdisk using
72information found in the /etc/modules.conf file.
73
74%description -l pl.UTF-8
75Geninitrd służy do tworzenia obrazu systemu plikowego używanego jako
76inicjalny ramdysk (initrd), z którego przy starcie systemu są ładowane
77moduły kernela z obsługą urządzeń których obsługa nie jest
78wkompilowana w kernel. Zazwyczaj modułami ładowanymi z inicjalnego
79systemu plikowego są sterowniki SCSI, IDE czy też RAID po to żeby w
80dalszej części inicjacji systemu był możliwy dostęp do głównego
81systemu plikowego (root fs).
82
83Dzięki initrd jest możliwe używanie dystrybucyjnego kernela w którym
84wkompilowana jest minimalna ilość obsługi różnych urządzeń, a reszta
85kodu obsługi sterowników SCSI, IDE czy RAID jest doczytywana w trakcie
86startu z initrd. Skrypt geninitrd generuje obraz ramdysku na podstawie
87bieżących informacji zawartych w /etc/modules.conf.
88
89%prep
90%setup -q
91%if "%{pld_release}" == "ti"
92%patch0 -p1
93%patch1 -p1
94%endif
95%patch2 -p0
96
97%build
98%{__make}
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%files
110%defattr(644,root,root,755)
111%doc ChangeLog
112%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/geninitrd
113%attr(755,root,root) /sbin/geninitrd
114%{_mandir}/man8/geninitrd.8*
115
116%dir /lib/geninitrd
117/lib/geninitrd/functions
118/lib/geninitrd/mod-*.sh
119%attr(755,root,root) /lib/geninitrd/extract-ikconfig
This page took 0.098824 seconds and 4 git commands to generate.