]> git.pld-linux.org Git - packages/geninitrd.git/blame - geninitrd.spec
- rel 8; silence ramdisk_size warning for initramfs
[packages/geninitrd.git] / geninitrd.spec
CommitLineData
5bba2f6c 1# TODO:
8d4b3be5
PG
2# - BUG: you can't set in /etc/mdadm.conf:
3# DEVICE partitions containers
4# (which is default BTW if none set). Generation of initrd will fail
5#
70a0ef68 6Summary: Creates an initial ramdisk image for preloading modules
4bd9777f 7Summary(pl.UTF-8): Narzędzie do tworzenia inicjalnego ramdysku używanego przy starcie systemu
70a0ef68 8Name: geninitrd
11d3d395 9Version: 12757
ce25c101 10Release: 9
70a0ef68 11License: GPL
6e7d5844 12Group: Applications/System
3adc6ee3 13Source0: %{name}-%{version}.tar.gz
11d3d395 14# Source0-md5: 3fb153489c3c245e5c1ee4bbc333acb4
eb76ccee 15Patch0: %{name}-git.patch
89be0200
JB
16Patch1: %{name}-static-dev.patch
17Patch2: %{name}-posix-sh.patch
d3226673 18URL: http://git.pld-linux.org/?p=projects/geninitrd.git
0dd71c4b 19BuildRequires: xmlto >= 0:0.0.18-1
fe2d4469 20Requires: /usr/bin/ldd
0e068c76 21Requires: awk
dfdfecb8 22Requires: busybox-implementation >= 1.22.1-2
417ef52a 23Requires: coreutils
7b29e9b5 24Requires: cpio
0e068c76 25Requires: fileutils
87c020ab 26Requires: glibc-misc
0e068c76 27Requires: gzip
16ac31fd 28Requires: mktemp >= 1.5-8
0e068c76 29Requires: mount
495990cb 30Requires: pci-database >= 0.4
e018b691 31Requires: rc-scripts >= 0.2.7
0e068c76 32Requires: tar
b7842622 33Requires: virtual(module-tools)
1e382335 34Requires: xz
c6fb1066 35Suggests: genromfs
c6af2556
JR
36Suggests: pciutils
37Obsoletes: mkinitrd
38# suggest for blkid
39%if "%{pld_release}" == "ac"
55c24912 40# otherwise LVM subsystem is not enabled in geninitrd
f3d68afb 41Suggests: lvm2-initrd
e018b691 42# without this softraid installations of PLD fail
ac7d5e9a 43Suggests: mdadm-initrd >= 1.12.0-1
fe2d4469
ER
44Conflicts: grubby < 5.0.4-3.1
45%else
429e8b1c 46Conflicts: grubby < 6.0.24-3
fe2d4469 47%endif
c7e102da 48Conflicts: kmod < 7-2
b7842622 49Conflicts: module-init-tools < 3.2.2-6
c5ec450e 50Conflicts: pciutils < 2.2.9
a843f5f7 51Conflicts: udev-initrd < 1:168
ba3bd13f 52Conflicts: xz < 4.999.9
cf111fa1 53BuildArch: noarch
70a0ef68
JK
54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56%description
570eccb2
ER
57Geninitrd creates filesystem images for use as initial ramdisk
58(initrd) images. These ramdisk images are often used to preload the
59block device modules (SCSI or RAID) needed to access the root
60filesystem.
70a0ef68
JK
61
62In other words, generic kernels can be built without drivers for any
63SCSI adapters which load the SCSI driver as a module. Since the kernel
64needs to read those modules, but in this case it isn't able to address
65the SCSI adapter, an initial ramdisk is used. The initial ramdisk is
66loaded by the operating system loader (normally LILO) and is available
67to the kernel as soon as the ramdisk is loaded. The ramdisk image
68loads the proper SCSI adapter and allows the kernel to mount the root
69filesystem. The geninitrd program creates such a ramdisk using
70information found in the /etc/modules.conf file.
71
54baa167
JR
72%description -l pl.UTF-8
73Geninitrd służy do tworzenia obrazu systemu plikowego używanego jako
74inicjalny ramdysk (initrd), z którego przy starcie systemu są ładowane
75moduły kernela z obsługą urządzeń których obsługa nie jest
76wkompilowana w kernel. Zazwyczaj modułami ładowanymi z inicjalnego
77systemu plikowego są sterowniki SCSI, IDE czy też RAID po to żeby w
78dalszej części inicjacji systemu był możliwy dostęp do głównego
70a0ef68
JK
79systemu plikowego (root fs).
80
54baa167
JR
81Dzięki initrd jest możliwe używanie dystrybucyjnego kernela w którym
82wkompilowana jest minimalna ilość obsługi różnych urządzeń, a reszta
83kodu obsługi sterowników SCSI, IDE czy RAID jest doczytywana w trakcie
70a0ef68 84startu z initrd. Skrypt geninitrd generuje obraz ramdysku na podstawie
54baa167 85bieżących informacji zawartych w /etc/modules.conf.
70a0ef68
JK
86
87%prep
89be0200 88%setup -q
eb76ccee 89%patch0 -p1
89be0200
JB
90%patch1 -p1
91%patch2 -p1
f2aef47d 92
0dd71c4b 93%build
e0c74de2 94%{__make}
0dd71c4b 95
70a0ef68
JK
96%install
97rm -rf $RPM_BUILD_ROOT
37688ad3 98%{__make} install \
e0c74de2 99 DESTDIR=$RPM_BUILD_ROOT
70a0ef68
JK
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%files
105%defattr(644,root,root,755)
61d0a20b 106%doc ChangeLog
417ef52a 107%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/geninitrd
70a0ef68 108%attr(755,root,root) /sbin/geninitrd
429e8b1c 109%{_mandir}/man8/geninitrd.8*
417ef52a 110
429e8b1c
ER
111%dir /lib/geninitrd
112/lib/geninitrd/functions
113/lib/geninitrd/mod-*.sh
824e8293 114%attr(755,root,root) /lib/geninitrd/extract-ikconfig
2bc9ddcf
ER
115
116%dir /lib/geninitrd/udev-rules
117/lib/geninitrd/udev-rules/*.rules
This page took 0.113175 seconds and 4 git commands to generate.