]> git.pld-linux.org Git - packages/geninitrd.git/blame - geninitrd.spec
- rel 4; fix strip to work also with compressed modules
[packages/geninitrd.git] / geninitrd.spec
CommitLineData
5bba2f6c 1# TODO:
8d4b3be5
PG
2# - BUG: you can't set in /etc/mdadm.conf:
3# DEVICE partitions containers
4# (which is default BTW if none set). Generation of initrd will fail
5#
70a0ef68 6Summary: Creates an initial ramdisk image for preloading modules
4bd9777f 7Summary(pl.UTF-8): Narzędzie do tworzenia inicjalnego ramdysku używanego przy starcie systemu
70a0ef68 8Name: geninitrd
f06cac70 9Version: 12385
d174cb31 10Release: 4
70a0ef68 11License: GPL
6e7d5844 12Group: Applications/System
3adc6ee3 13Source0: %{name}-%{version}.tar.gz
f06cac70 14# Source0-md5: 8dee910b40e5505c4ee3e71f4d2e042a
929a4239 15Patch0: %{name}-romfs.patch
b05ab846 16Patch1: %{name}-gzip-compressor.patch
f5aa6e2b 17Patch2: %{name}-svn.patch
aa605112 18URL: http://svn.pld-linux.org/trac/svn/wiki/packages/geninitrd
0dd71c4b 19BuildRequires: xmlto >= 0:0.0.18-1
fe2d4469 20Requires: /usr/bin/ldd
0e068c76 21Requires: awk
7c70c4dc 22Requires: busybox-initrd >= 1.1.0
417ef52a 23Requires: coreutils
7b29e9b5 24Requires: cpio
0e068c76 25Requires: fileutils
26Requires: genromfs
87c020ab 27Requires: glibc-misc
0e068c76 28Requires: gzip
16ac31fd 29Requires: mktemp >= 1.5-8
f9ef5006 30Requires: module-init-tools >= 3.2.2-6
0e068c76 31Requires: mount
495990cb 32Requires: pci-database >= 0.4
e018b691 33Requires: rc-scripts >= 0.2.7
0e068c76 34Requires: tar
6f0074bc 35%if "%{pld_release}" == "ti"
36Requires: lvm2-initrd
37Requires: mdadm-initrd >= 1.12.0-1
38%else
55c24912 39# otherwise LVM subsystem is not enabled in geninitrd
f3d68afb 40Suggests: lvm2-initrd
e018b691 41# without this softraid installations of PLD fail
ac7d5e9a 42Suggests: mdadm-initrd >= 1.12.0-1
6f0074bc 43%endif
55c24912
ER
44# suggest for blkid
45%if "%{pld_release}" != "ac"
244b296a 46Suggests: util-linux-initrd
55c24912 47%endif
70a0ef68 48Obsoletes: mkinitrd
fe2d4469
ER
49%if "%{pld_release}" == "ac"
50Conflicts: grubby < 5.0.4-3.1
51%else
429e8b1c 52Conflicts: grubby < 6.0.24-3
fe2d4469 53%endif
f9ef5006 54Conflicts: udev-initrd < 1:104
ba3bd13f 55Conflicts: xz < 4.999.9
cf111fa1 56BuildArch: noarch
70a0ef68
JK
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59%description
570eccb2
ER
60Geninitrd creates filesystem images for use as initial ramdisk
61(initrd) images. These ramdisk images are often used to preload the
62block device modules (SCSI or RAID) needed to access the root
63filesystem.
70a0ef68
JK
64
65In other words, generic kernels can be built without drivers for any
66SCSI adapters which load the SCSI driver as a module. Since the kernel
67needs to read those modules, but in this case it isn't able to address
68the SCSI adapter, an initial ramdisk is used. The initial ramdisk is
69loaded by the operating system loader (normally LILO) and is available
70to the kernel as soon as the ramdisk is loaded. The ramdisk image
71loads the proper SCSI adapter and allows the kernel to mount the root
72filesystem. The geninitrd program creates such a ramdisk using
73information found in the /etc/modules.conf file.
74
54baa167
JR
75%description -l pl.UTF-8
76Geninitrd służy do tworzenia obrazu systemu plikowego używanego jako
77inicjalny ramdysk (initrd), z którego przy starcie systemu są ładowane
78moduły kernela z obsługą urządzeń których obsługa nie jest
79wkompilowana w kernel. Zazwyczaj modułami ładowanymi z inicjalnego
80systemu plikowego są sterowniki SCSI, IDE czy też RAID po to żeby w
81dalszej części inicjacji systemu był możliwy dostęp do głównego
70a0ef68
JK
82systemu plikowego (root fs).
83
54baa167
JR
84Dzięki initrd jest możliwe używanie dystrybucyjnego kernela w którym
85wkompilowana jest minimalna ilość obsługi różnych urządzeń, a reszta
86kodu obsługi sterowników SCSI, IDE czy RAID jest doczytywana w trakcie
70a0ef68 87startu z initrd. Skrypt geninitrd generuje obraz ramdysku na podstawie
54baa167 88bieżących informacji zawartych w /etc/modules.conf.
70a0ef68
JK
89
90%prep
91%setup -q
929a4239 92%if "%{pld_release}" == "ti"
93%patch0 -p1
b05ab846 94%patch1 -p1
929a4239 95%endif
4290db97 96%patch2 -p0
f2aef47d 97
0dd71c4b 98%build
e0c74de2 99%{__make}
0dd71c4b 100
70a0ef68
JK
101%install
102rm -rf $RPM_BUILD_ROOT
37688ad3 103%{__make} install \
e0c74de2 104 DESTDIR=$RPM_BUILD_ROOT
70a0ef68
JK
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%files
110%defattr(644,root,root,755)
61d0a20b 111%doc ChangeLog
417ef52a 112%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/geninitrd
70a0ef68 113%attr(755,root,root) /sbin/geninitrd
429e8b1c 114%{_mandir}/man8/geninitrd.8*
417ef52a 115
429e8b1c
ER
116%dir /lib/geninitrd
117/lib/geninitrd/functions
118/lib/geninitrd/mod-*.sh
824e8293 119%attr(755,root,root) /lib/geninitrd/extract-ikconfig
This page took 0.086901 seconds and 4 git commands to generate.