]> git.pld-linux.org Git - packages/gemrb.git/blob - gemrb.spec
upstream fix for crash with GLES backend
[packages/gemrb.git] / gemrb.spec
1 # TODO:
2 # - make it build on x86_64
3 #
4 # Conditional build:
5 %bcond_without  png     # build without png
6
7 Summary:        Emulator of BioWare's Infinity game engine
8 Summary(pl.UTF-8):      Emulator silnika gier Infinity firmy BioWare
9 Name:           gemrb
10 Version:        0.7.0
11 Release:        0.1
12 License:        GPL v2+
13 Group:          Applications/Emulators
14 Source0:        http://downloads.sourceforge.net/gemrb/%{name}-%{version}.tar.gz
15 # Source0-md5:  0bb891db41d6f69e8414bdce808b32f8
16 Patch0:         %{name}-config_file.patch
17 Patch1:         %{name}-useless_files.patch
18 URL:            http://gemrb.sourceforge.net/
19 BuildRequires:  OpenAL-devel
20 BuildRequires:  SDL-devel >= 1.2
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 %{?with_png:BuildRequires:      libpng-devel}
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 BuildRequires:  python-devel >= 1:2.3.0
28 BuildRequires:  python-modules
29 BuildRequires:  zlib-devel
30 Suggests:       synce-unshield
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This Game Engine is a port of the original Infinity Engine (the one of
35 Baldur's Gate, Planescape: Torment, Icewind Dale) to Linux/Unix, MacOs
36 X and Windows with some Enhancements.
37
38 %description -l pl.UTF-8
39 Silnik ten jest portem oryginalnego silnika Infinity Engine (używanego
40 przez Baldur's Gate, Planescape: Torment, Icewind Dale) dla systemów
41 Linux/Unix, MacOS i Windows. Silnik posiada kilka ulepszeń.
42
43 %prep
44 %setup -q
45 %patch0 -p1
46 %patch1 -p1
47
48 %build
49 %{__libtoolize}
50 %{__aclocal}
51 %{__autoconf}
52 %{__autoheader}
53 %{__automake}
54 %configure
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_datadir}/gemrb/Cache}
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 install gemrb/GemRB.cfg.sample.in $RPM_BUILD_ROOT%{_sysconfdir}/gemrb.cfg
65 %{__rm} $RPM_BUILD_ROOT%{_libdir}{,/gemrb/plugins}/*.la
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post   -p /sbin/ldconfig
71 %postun -p /sbin/ldconfig
72
73 %files
74 %defattr(644,root,root,755)
75 %doc AUTHORS ChangeLog NEWS README TODO %{name}{/docs/en/*.txt,/GemRB.cfg*.sample}
76 %attr(755,root,root) %{_bindir}/gemrb
77 %dir %{_libdir}/gemrb
78 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
79 %dir %{_libdir}/gemrb/plugins
80 %attr(755,root,root) %{_libdir}/gemrb/plugins/*.so*
81 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gemrb.cfg
82 %{_datadir}/gemrb
83 %{_mandir}/man6/gemrb.6*
This page took 0.072301 seconds and 3 git commands to generate.