]> git.pld-linux.org Git - packages/gem2rpm.git/commitdiff
up to 0.11.1 auto/th/gem2rpm-0.11.1-1
authorElan Ruusamäe <glen@delfi.ee>
Mon, 10 Aug 2015 08:35:29 +0000 (11:35 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 10 Aug 2015 08:35:29 +0000 (11:35 +0300)
gem2rpm.spec
pld.patch [deleted file]
pld.spec.erb

index 35b1162f5dcc3d3094bb8b6ef47b56957896fea6..710b1b3a31323fb8c541e9705d3a9c5f5c220136 100644 (file)
@@ -4,15 +4,14 @@
 
 Summary:       Generate rpm specfiles from gems
 Name:          gem2rpm
-Version:       0.10.1
-Release:       2
+Version:       0.11.1
+Release:       1
 License:       GPL v2+
 Group:         Development/Languages
 Source0:       https://github.com/fedora-ruby/gem2rpm/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: a22be828b4aeff0387a735daae969c5c
+# Source0-md5: b1b60ade93fd61c22c17cfe4b95c3609
 Source2:       pld.spec.erb
 Patch0:                gems.patch
-Patch1:                pld.patch
 Patch2:                style.patch
 URL:           https://github.com/fedora-ruby/gem2rpm
 BuildRequires: rpm-rubyprov
@@ -43,7 +42,6 @@ Documentation for %{name}.
 %setup -q
 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
 %patch0 -p1
-%patch1 -p1
 %patch2 -p1
 cp -p %{SOURCE2} templates
 
@@ -72,7 +70,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README AUTHORS
+%doc README.md AUTHORS
 %attr(755,root,root) %{_bindir}/gem2rpm
 %{ruby_vendorlibdir}/gem2rpm.rb
 %{ruby_vendorlibdir}/gem2rpm
diff --git a/pld.patch b/pld.patch
deleted file mode 100644 (file)
index 69e5bd0..0000000
--- a/pld.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- gem2rpm-0.8.1/lib/gem2rpm/distro.rb~       2013-04-24 10:31:39.000000000 +0300
-+++ gem2rpm-0.8.1/lib/gem2rpm/distro.rb        2013-04-24 10:34:23.957321979 +0300
-@@ -1,6 +1,7 @@
- module Gem2Rpm
-   class Distro
-     FEDORA = :fedora
-+    PLD = :pld
-     OPENSUSE = :opensuse
-     DEFAULT = :default
-@@ -22,6 +23,8 @@
-         end
-       elsif !release_files.grep(/SuSe/).empty?
-         OPENSUSE
-+      elsif !release_files.grep(/pld/).empty?
-+        PLD
-       else
-         DEFAULT
-       end
index 96212853d5e06b7457197c1152a15f0926ba2735..34828c688b6fbc2a3936b3d3f84b555b3a824c90 100644 (file)
@@ -57,6 +57,15 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # write .gemspec
 %__gem_helper spec
 
+<% if !spec.extensions.empty? -%>
+cd ext/%{pkgname}
+%{__ruby} extconf.rb
+%{__make} \
+       CC="%{__cc}" \
+       LDFLAGS="%{rpmldflags}" \
+       CFLAGS="%{rpmcflags} -fPIC"
+<% end -%>
+
 %install
 rm -rf $RPM_BUILD_ROOT
 <% if spec.executables.empty? -%>
This page took 0.11719 seconds and 4 git commands to generate.