sort dependencies
authorElan Ruusamäe <glen@delfi.ee>
Mon, 29 Apr 2013 21:32:05 +0000 (00:32 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 29 Apr 2013 21:32:05 +0000 (00:32 +0300)
pld.spec.erb

index 425d534..39b519f 100644 (file)
@@ -25,14 +25,14 @@ BuildRequires:      sed >= 4.0
 <% if ! spec.required_rubygems_version.empty? and ! spec.required_rubygems_version.first.empty? -%>
 Requires:      ruby-rubygems <%= spec.required_rubygems_version.first %>
 <% end -%>
-<% for d in spec.runtime_dependencies -%>
+<% for d in spec.runtime_dependencies.sort -%>
 <% for req in d.requirement -%>
 Requires:      ruby-<%= d.name %> <%= req %>
 <% end -%>
 <% end -%>
 <% if ! spec.development_dependencies.empty? -%>
 %if %{with tests}
-<% for d in spec.development_dependencies -%>
+<% for d in spec.development_dependencies.sort -%>
 <% for req in d.requirement -%>
 Requires:      ruby-<%= d.name %> <%= req %>
 <% end -%>
This page took 0.236879 seconds and 4 git commands to generate.