]> git.pld-linux.org Git - packages/gem2rpm.git/blobdiff - gem2rpm.spec
tests (no longer?) need utf8 locale
[packages/gem2rpm.git] / gem2rpm.spec
index 1ce935d72eabcf938ba70b0a03966f631855f924..8e46718c212cb857b5b742c41ff8396313024c65 100644 (file)
@@ -1,27 +1,26 @@
 #
 # Conditional build:
-%bcond_without tests           # build without tests
+%bcond_with    tests           # tests require networking
 
 Summary:       Generate rpm specfiles from gems
 Name:          gem2rpm
-Version:       0.9.2
-Release:       3
+Version:       0.11.3
+Release:       1
 License:       GPL v2+
 Group:         Development/Languages
-Source0:       https://github.com/lutter/gem2rpm/archive/v%{version}.tar.gz
-# Source0-md5: 133c4cae2e26c24a5db0453e2cbe2a72
+Source0:       https://github.com/fedora-ruby/gem2rpm/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 5d81c9a3a9849f905819781fb61f86aa
 Source2:       pld.spec.erb
 Patch0:                gems.patch
-Patch1:                pld.patch
+Patch1:                os-release-quotes.patch
 Patch2:                style.patch
-URL:           https://github.com/lutter/gem2rpm/
+URL:           https://github.com/fedora-ruby/gem2rpm
 BuildRequires: rpm-rubyprov
 BuildRequires: rpmbuild(macros) >= 1.656
 %if %{with tests}
-%if %(locale -a | grep -q '^en_US$'; echo $?)
-BuildRequires: glibc-localedb-all
-%endif
+BuildRequires: ruby-rake
 %endif
+Requires:      pld-release
 Requires:      ruby-rubygems
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -41,26 +40,26 @@ Documentation for %{name}.
 
 %prep
 %setup -q
+%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 cp -p %{SOURCE2} templates
 
-%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
+# cleanup backups after patching
+find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
 %build
 %if %{with tests}
-# tests need UTF-8 locale
-LC_ALL=en_US.UTF-8 \
-testrb -Itest test/
+rake test
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{_bindir}}
+install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
 
 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
-cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
+cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
 
 install -d $RPM_BUILD_ROOT%{_datadir}/ruby/templates
 cp -a templates/* $RPM_BUILD_ROOT%{_datadir}/ruby/templates
@@ -70,8 +69,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README AUTHORS
+%doc README.md AUTHORS
 %attr(755,root,root) %{_bindir}/gem2rpm
-%{ruby_rubylibdir}/gem2rpm.rb
-%{ruby_rubylibdir}/gem2rpm
+%{ruby_vendorlibdir}/gem2rpm.rb
+%{ruby_vendorlibdir}/gem2rpm
 %{_datadir}/ruby/templates
This page took 0.080512 seconds and 4 git commands to generate.