]> git.pld-linux.org Git - packages/gem2rpm.git/blob - gem2rpm.spec
update pld template to be more pldish
[packages/gem2rpm.git] / gem2rpm.spec
1 Summary:        Generate rpm specfiles from gems
2 Name:           gem2rpm
3 Version:        0.8.1
4 Release:        0.5
5 License:        GPL v2+
6 Group:          Development/Languages
7 Source0:        http://rubygems.org/gems/%{name}-%{version}.gem
8 # Source0-md5:  d3c9416f225ae944fd195e69e122d46e
9 # git clone https://github.com/lutter/gem2rpm.git && cd gem2rpm && git checkout v0.8.1
10 # tar czvf gem2rpm-0.8.1-tests.tgz test/
11 Source1:        %{name}-%{version}-tests.tgz
12 # Source1-md5:  d7d8bc231dc405bbce00f570c89f530e
13 Source2:        pld.spec.erb
14 Patch0:         gems.patch
15 Patch1:         pld.patch
16 URL:            https://github.com/lutter/gem2rpm/
17 BuildRequires:  rpm-rubyprov
18 BuildRequires:  rpmbuild(macros) >= 1.656
19 Requires:       ruby
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Generate source rpms and rpm spec files from a Ruby Gem. The spec file
25 tries to follow the gem as closely as possible, and be compliant with
26 the Fedora rubygem packaging guidelines
27
28 %package doc
29 Summary:        Documentation for %{name}
30 Group:          Documentation
31 Requires:       %{name} = %{version}-%{release}
32
33 %description doc
34 Documentation for %{name}.
35
36 %prep
37 %setup -q
38 %patch0 -p1
39 %patch1 -p1
40 cp -p %{SOURCE2} templates
41
42 %build
43 %if %{with tests}
44 testrb -Itest test/
45 %endif
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{_bindir}}
50
51 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
52 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
53
54 install -d $RPM_BUILD_ROOT%{_datadir}/ruby/templates
55 cp -a templates/* $RPM_BUILD_ROOT%{_datadir}/ruby/templates
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README AUTHORS
63 %attr(755,root,root) %{_bindir}/gem2rpm
64 %{ruby_rubylibdir}/gem2rpm.rb
65 %{ruby_rubylibdir}/gem2rpm
66 %{_datadir}/ruby/templates
67
68 %if 0
69 %files doc
70 %defattr(644,root,root,755)
71 %doc %{gem_docdir}
72 %doc %{gem_instdir}/README
73 %doc %{gem_instdir}/AUTHORS
74 %endif
This page took 0.060474 seconds and 3 git commands to generate.