]> git.pld-linux.org Git - packages/gem2rpm.git/blob - gem2rpm.spec
Requires rubygems runtime
[packages/gem2rpm.git] / gem2rpm.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 Summary:        Generate rpm specfiles from gems
6 Name:           gem2rpm
7 Version:        0.9.2
8 Release:        3
9 License:        GPL v2+
10 Group:          Development/Languages
11 Source0:        https://github.com/lutter/gem2rpm/archive/v%{version}.tar.gz
12 # Source0-md5:  133c4cae2e26c24a5db0453e2cbe2a72
13 Source2:        pld.spec.erb
14 Patch0:         gems.patch
15 Patch1:         pld.patch
16 Patch2:         style.patch
17 URL:            https://github.com/lutter/gem2rpm/
18 BuildRequires:  rpm-rubyprov
19 BuildRequires:  rpmbuild(macros) >= 1.656
20 %if %{with tests}
21 %if %(locale -a | grep -q '^en_US$'; echo $?)
22 BuildRequires:  glibc-localedb-all
23 %endif
24 %endif
25 Requires:       ruby-rubygems
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Generate source rpms and rpm spec files from a Ruby Gem. The spec file
31 tries to follow the gem as closely as possible, and be compliant with
32 the Fedora rubygem packaging guidelines
33
34 %package doc
35 Summary:        Documentation for %{name}
36 Group:          Documentation
37 Requires:       %{name} = %{version}-%{release}
38
39 %description doc
40 Documentation for %{name}.
41
42 %prep
43 %setup -q
44 %patch0 -p1
45 %patch1 -p1
46 %patch2 -p1
47 cp -p %{SOURCE2} templates
48
49 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
50
51 %build
52 %if %{with tests}
53 # tests need UTF-8 locale
54 LC_ALL=en_US.UTF-8 \
55 testrb -Itest test/
56 %endif
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{_bindir}}
61
62 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
63 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
64
65 install -d $RPM_BUILD_ROOT%{_datadir}/ruby/templates
66 cp -a templates/* $RPM_BUILD_ROOT%{_datadir}/ruby/templates
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc README AUTHORS
74 %attr(755,root,root) %{_bindir}/gem2rpm
75 %{ruby_rubylibdir}/gem2rpm.rb
76 %{ruby_rubylibdir}/gem2rpm
77 %{_datadir}/ruby/templates
This page took 0.027254 seconds and 3 git commands to generate.