]> git.pld-linux.org Git - packages/gem2rpm.git/blame_incremental - gem2rpm.spec
up to 0.11.2
[packages/gem2rpm.git] / gem2rpm.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # tests require networking
4
5Summary: Generate rpm specfiles from gems
6Name: gem2rpm
7Version: 0.11.2
8Release: 1
9License: GPL v2+
10Group: Development/Languages
11Source0: https://github.com/fedora-ruby/gem2rpm/archive/v%{version}/%{name}-%{version}.tar.gz
12# Source0-md5: 80d6170dcfe7d0a840e8bf7149096d3a
13Source2: pld.spec.erb
14Patch0: gems.patch
15Patch1: os-release-quotes.patch
16Patch2: style.patch
17URL: https://github.com/fedora-ruby/gem2rpm
18BuildRequires: rpm-rubyprov
19BuildRequires: rpmbuild(macros) >= 1.656
20%if %{with tests}
21%if %(locale -a | grep -q '^en_US$'; echo $?)
22BuildRequires: glibc-localedb-all
23%endif
24%endif
25Requires: pld-release
26Requires: ruby-rubygems
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Generate source rpms and rpm spec files from a Ruby Gem. The spec file
32tries to follow the gem as closely as possible, and be compliant with
33the Fedora rubygem packaging guidelines
34
35%package doc
36Summary: Documentation for %{name}
37Group: Documentation
38Requires: %{name} = %{version}-%{release}
39
40%description doc
41Documentation for %{name}.
42
43%prep
44%setup -q
45%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
46%patch0 -p1
47%patch1 -p1
48%patch2 -p1
49cp -p %{SOURCE2} templates
50
51# cleanup backups after patching
52find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
53
54%build
55%if %{with tests}
56# tests need UTF-8 locale
57LC_ALL=en_US.UTF-8 \
58testrb -Itest test/
59%endif
60
61%install
62rm -rf $RPM_BUILD_ROOT
63install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
64
65cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
66cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
67
68install -d $RPM_BUILD_ROOT%{_datadir}/ruby/templates
69cp -a templates/* $RPM_BUILD_ROOT%{_datadir}/ruby/templates
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%files
75%defattr(644,root,root,755)
76%doc README.md AUTHORS
77%attr(755,root,root) %{_bindir}/gem2rpm
78%{ruby_vendorlibdir}/gem2rpm.rb
79%{ruby_vendorlibdir}/gem2rpm
80%{_datadir}/ruby/templates
This page took 0.049423 seconds and 4 git commands to generate.