]> git.pld-linux.org Git - packages/gem2rpm.git/blame - gem2rpm.spec
tests require newer minitest than we have with ruby 2.1
[packages/gem2rpm.git] / gem2rpm.spec
CommitLineData
749a1624
ER
1#
2# Conditional build:
d2046f61 3%bcond_with tests # tests require minitest >= 5.0
749a1624 4
f0d3c1e6 5Summary: Generate rpm specfiles from gems
e8e50a98 6Name: gem2rpm
fca7be54 7Version: 0.11.3
b4f912cc 8Release: 1
f0d3c1e6
ER
9License: GPL v2+
10Group: Development/Languages
26fbd092 11Source0: https://github.com/fedora-ruby/gem2rpm/archive/v%{version}/%{name}-%{version}.tar.gz
fca7be54 12# Source0-md5: 5d81c9a3a9849f905819781fb61f86aa
7d625e4e 13Source2: pld.spec.erb
f51775da 14Patch0: gems.patch
e2fce429 15Patch1: os-release-quotes.patch
bf1dd385 16Patch2: style.patch
26fbd092 17URL: https://github.com/fedora-ruby/gem2rpm
e8e50a98
ER
18BuildRequires: rpm-rubyprov
19BuildRequires: rpmbuild(macros) >= 1.656
749a1624 20%if %{with tests}
d2046f61 21BuildRequires: ruby-minitest >= 5.0
7cb22ffb 22BuildRequires: ruby-rake
749a1624 23%endif
e2fce429 24Requires: pld-release
624d0b83 25Requires: ruby-rubygems
f0d3c1e6
ER
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30Generate source rpms and rpm spec files from a Ruby Gem. The spec file
31tries to follow the gem as closely as possible, and be compliant with
32the Fedora rubygem packaging guidelines
33
34%package doc
35Summary: Documentation for %{name}
36Group: Documentation
37Requires: %{name} = %{version}-%{release}
38
39%description doc
40Documentation for %{name}.
41
42%prep
e8e50a98 43%setup -q
b59b10ce 44%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
f51775da 45%patch0 -p1
e2fce429 46%patch1 -p1
bf1dd385 47%patch2 -p1
7d625e4e 48cp -p %{SOURCE2} templates
f0d3c1e6 49
b59b10ce
ER
50# cleanup backups after patching
51find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
b978c369 52
f0d3c1e6
ER
53%build
54%if %{with tests}
7cb22ffb 55rake test
f0d3c1e6
ER
56%endif
57
58%install
59rm -rf $RPM_BUILD_ROOT
575f7dc5 60install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
f0d3c1e6
ER
61
62cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
575f7dc5 63cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
f0d3c1e6 64
c2e552c8
ER
65install -d $RPM_BUILD_ROOT%{_datadir}/ruby/templates
66cp -a templates/* $RPM_BUILD_ROOT%{_datadir}/ruby/templates
67
f0d3c1e6
ER
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%files
72%defattr(644,root,root,755)
b4f912cc 73%doc README.md AUTHORS
f0d3c1e6 74%attr(755,root,root) %{_bindir}/gem2rpm
575f7dc5
ER
75%{ruby_vendorlibdir}/gem2rpm.rb
76%{ruby_vendorlibdir}/gem2rpm
c2e552c8 77%{_datadir}/ruby/templates
This page took 0.071271 seconds and 4 git commands to generate.