]> git.pld-linux.org Git - packages/gem2rpm.git/blame - gem2rpm.spec
tests (no longer?) need utf8 locale
[packages/gem2rpm.git] / gem2rpm.spec
CommitLineData
749a1624
ER
1#
2# Conditional build:
48ec4e40 3%bcond_with tests # tests require networking
749a1624 4
f0d3c1e6 5Summary: Generate rpm specfiles from gems
e8e50a98 6Name: gem2rpm
fca7be54 7Version: 0.11.3
b4f912cc 8Release: 1
f0d3c1e6
ER
9License: GPL v2+
10Group: Development/Languages
26fbd092 11Source0: https://github.com/fedora-ruby/gem2rpm/archive/v%{version}/%{name}-%{version}.tar.gz
fca7be54 12# Source0-md5: 5d81c9a3a9849f905819781fb61f86aa
7d625e4e 13Source2: pld.spec.erb
f51775da 14Patch0: gems.patch
e2fce429 15Patch1: os-release-quotes.patch
bf1dd385 16Patch2: style.patch
26fbd092 17URL: https://github.com/fedora-ruby/gem2rpm
e8e50a98
ER
18BuildRequires: rpm-rubyprov
19BuildRequires: rpmbuild(macros) >= 1.656
749a1624 20%if %{with tests}
7cb22ffb 21BuildRequires: ruby-rake
749a1624 22%endif
e2fce429 23Requires: pld-release
624d0b83 24Requires: ruby-rubygems
f0d3c1e6
ER
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29Generate source rpms and rpm spec files from a Ruby Gem. The spec file
30tries to follow the gem as closely as possible, and be compliant with
31the Fedora rubygem packaging guidelines
32
33%package doc
34Summary: Documentation for %{name}
35Group: Documentation
36Requires: %{name} = %{version}-%{release}
37
38%description doc
39Documentation for %{name}.
40
41%prep
e8e50a98 42%setup -q
b59b10ce 43%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
f51775da 44%patch0 -p1
e2fce429 45%patch1 -p1
bf1dd385 46%patch2 -p1
7d625e4e 47cp -p %{SOURCE2} templates
f0d3c1e6 48
b59b10ce
ER
49# cleanup backups after patching
50find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
b978c369 51
f0d3c1e6
ER
52%build
53%if %{with tests}
7cb22ffb 54rake test
f0d3c1e6
ER
55%endif
56
57%install
58rm -rf $RPM_BUILD_ROOT
575f7dc5 59install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
f0d3c1e6
ER
60
61cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
575f7dc5 62cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
f0d3c1e6 63
c2e552c8
ER
64install -d $RPM_BUILD_ROOT%{_datadir}/ruby/templates
65cp -a templates/* $RPM_BUILD_ROOT%{_datadir}/ruby/templates
66
f0d3c1e6
ER
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(644,root,root,755)
b4f912cc 72%doc README.md AUTHORS
f0d3c1e6 73%attr(755,root,root) %{_bindir}/gem2rpm
575f7dc5
ER
74%{ruby_vendorlibdir}/gem2rpm.rb
75%{ruby_vendorlibdir}/gem2rpm
c2e552c8 76%{_datadir}/ruby/templates
This page took 0.079091 seconds and 4 git commands to generate.