]> git.pld-linux.org Git - packages/gem2rpm.git/blame - gem2rpm.spec
up to 0.11.3
[packages/gem2rpm.git] / gem2rpm.spec
CommitLineData
749a1624
ER
1#
2# Conditional build:
48ec4e40 3%bcond_with tests # tests require networking
749a1624 4
f0d3c1e6 5Summary: Generate rpm specfiles from gems
e8e50a98 6Name: gem2rpm
fca7be54 7Version: 0.11.3
b4f912cc 8Release: 1
f0d3c1e6
ER
9License: GPL v2+
10Group: Development/Languages
26fbd092 11Source0: https://github.com/fedora-ruby/gem2rpm/archive/v%{version}/%{name}-%{version}.tar.gz
fca7be54 12# Source0-md5: 5d81c9a3a9849f905819781fb61f86aa
7d625e4e 13Source2: pld.spec.erb
f51775da 14Patch0: gems.patch
e2fce429 15Patch1: os-release-quotes.patch
bf1dd385 16Patch2: style.patch
26fbd092 17URL: https://github.com/fedora-ruby/gem2rpm
e8e50a98
ER
18BuildRequires: rpm-rubyprov
19BuildRequires: rpmbuild(macros) >= 1.656
749a1624
ER
20%if %{with tests}
21%if %(locale -a | grep -q '^en_US$'; echo $?)
22BuildRequires: glibc-localedb-all
23%endif
24%endif
e2fce429 25Requires: pld-release
624d0b83 26Requires: ruby-rubygems
f0d3c1e6
ER
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Generate source rpms and rpm spec files from a Ruby Gem. The spec file
32tries to follow the gem as closely as possible, and be compliant with
33the Fedora rubygem packaging guidelines
34
35%package doc
36Summary: Documentation for %{name}
37Group: Documentation
38Requires: %{name} = %{version}-%{release}
39
40%description doc
41Documentation for %{name}.
42
43%prep
e8e50a98 44%setup -q
b59b10ce 45%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
f51775da 46%patch0 -p1
e2fce429 47%patch1 -p1
bf1dd385 48%patch2 -p1
7d625e4e 49cp -p %{SOURCE2} templates
f0d3c1e6 50
b59b10ce
ER
51# cleanup backups after patching
52find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
b978c369 53
f0d3c1e6
ER
54%build
55%if %{with tests}
749a1624
ER
56# tests need UTF-8 locale
57LC_ALL=en_US.UTF-8 \
f0d3c1e6
ER
58testrb -Itest test/
59%endif
60
61%install
62rm -rf $RPM_BUILD_ROOT
575f7dc5 63install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
f0d3c1e6
ER
64
65cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
575f7dc5 66cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
f0d3c1e6 67
c2e552c8
ER
68install -d $RPM_BUILD_ROOT%{_datadir}/ruby/templates
69cp -a templates/* $RPM_BUILD_ROOT%{_datadir}/ruby/templates
70
f0d3c1e6
ER
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%files
75%defattr(644,root,root,755)
b4f912cc 76%doc README.md AUTHORS
f0d3c1e6 77%attr(755,root,root) %{_bindir}/gem2rpm
575f7dc5
ER
78%{ruby_vendorlibdir}/gem2rpm.rb
79%{ruby_vendorlibdir}/gem2rpm
c2e552c8 80%{_datadir}/ruby/templates
This page took 0.059142 seconds and 4 git commands to generate.