]> git.pld-linux.org Git - packages/gem2rpm.git/blame - gem2rpm.spec
install to version independant ruby dir
[packages/gem2rpm.git] / gem2rpm.spec
CommitLineData
749a1624
ER
1#
2# Conditional build:
48ec4e40 3%bcond_with tests # tests require networking
749a1624 4
f0d3c1e6 5Summary: Generate rpm specfiles from gems
e8e50a98 6Name: gem2rpm
b59b10ce 7Version: 0.10.1
575f7dc5 8Release: 2
f0d3c1e6
ER
9License: GPL v2+
10Group: Development/Languages
26fbd092 11Source0: https://github.com/fedora-ruby/gem2rpm/archive/v%{version}/%{name}-%{version}.tar.gz
b59b10ce 12# Source0-md5: a22be828b4aeff0387a735daae969c5c
7d625e4e 13Source2: pld.spec.erb
f51775da 14Patch0: gems.patch
7d625e4e 15Patch1: pld.patch
bf1dd385 16Patch2: style.patch
26fbd092 17URL: https://github.com/fedora-ruby/gem2rpm
e8e50a98
ER
18BuildRequires: rpm-rubyprov
19BuildRequires: rpmbuild(macros) >= 1.656
749a1624
ER
20%if %{with tests}
21%if %(locale -a | grep -q '^en_US$'; echo $?)
22BuildRequires: glibc-localedb-all
23%endif
24%endif
624d0b83 25Requires: ruby-rubygems
f0d3c1e6
ER
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30Generate source rpms and rpm spec files from a Ruby Gem. The spec file
31tries to follow the gem as closely as possible, and be compliant with
32the Fedora rubygem packaging guidelines
33
34%package doc
35Summary: Documentation for %{name}
36Group: Documentation
37Requires: %{name} = %{version}-%{release}
38
39%description doc
40Documentation for %{name}.
41
42%prep
e8e50a98 43%setup -q
b59b10ce 44%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
f51775da 45%patch0 -p1
7d625e4e 46%patch1 -p1
bf1dd385 47%patch2 -p1
7d625e4e 48cp -p %{SOURCE2} templates
f0d3c1e6 49
b59b10ce
ER
50# cleanup backups after patching
51find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
b978c369 52
f0d3c1e6
ER
53%build
54%if %{with tests}
749a1624
ER
55# tests need UTF-8 locale
56LC_ALL=en_US.UTF-8 \
f0d3c1e6
ER
57testrb -Itest test/
58%endif
59
60%install
61rm -rf $RPM_BUILD_ROOT
575f7dc5 62install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
f0d3c1e6
ER
63
64cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
575f7dc5 65cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
f0d3c1e6 66
c2e552c8
ER
67install -d $RPM_BUILD_ROOT%{_datadir}/ruby/templates
68cp -a templates/* $RPM_BUILD_ROOT%{_datadir}/ruby/templates
69
f0d3c1e6
ER
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%files
74%defattr(644,root,root,755)
75%doc README AUTHORS
76%attr(755,root,root) %{_bindir}/gem2rpm
575f7dc5
ER
77%{ruby_vendorlibdir}/gem2rpm.rb
78%{ruby_vendorlibdir}/gem2rpm
c2e552c8 79%{_datadir}/ruby/templates
This page took 0.065646 seconds and 4 git commands to generate.