]> git.pld-linux.org Git - packages/geki3-KXL.git/commitdiff
- updated to 1.0.3, updated URLs
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 10 May 2003 20:16:23 +0000 (20:16 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- patched to place score file in proper place

Changed files:
    geki3-KXL-scorepath.patch -> 1.1
    geki3-KXL.spec -> 1.3

geki3-KXL-scorepath.patch [new file with mode: 0644]
geki3-KXL.spec

diff --git a/geki3-KXL-scorepath.patch b/geki3-KXL-scorepath.patch
new file mode 100644 (file)
index 0000000..480f00c
--- /dev/null
@@ -0,0 +1,54 @@
+diff -Nur geki3-KXL-1.0.3.orig/configure.in geki3-KXL-1.0.3/configure.in
+--- geki3-KXL-1.0.3.orig/configure.in  2002-11-12 04:02:07.000000000 +0100
++++ geki3-KXL-1.0.3/configure.in       2003-05-10 21:24:45.000000000 +0200
+@@ -29,10 +29,17 @@
+         BMP_PATH=$prefix/share/geki3/bmp
+         WAV_PATH=$prefix/share/geki3/wav
+ fi
++if test "x$localstatedir" = "xNONE"; then
++      SCORE_PATH=/var/games
++else
++      SCORE_PATH=$localstatedir/games
++fi
+ AC_DEFINE_UNQUOTED(DATA_PATH,"$DATA_PATH")
++AC_DEFINE_UNQUOTED(SCORE_PATH,"$SCORE_PATH")
+ AC_DEFINE_UNQUOTED(BMP_PATH,"$BMP_PATH")
+ AC_DEFINE_UNQUOTED(WAV_PATH,"$WAV_PATH")
+ AC_DEFINE_UNQUOTED(TITLE,"$PACKAGE $VERSION")
++AC_SUBST(SCORE_PATH)
+ AC_SUBST(DATA_PATH)
+ AC_SUBST(BMP_PATH)
+ AC_SUBST(WAV_PATH)
+diff -Nur geki3-KXL-1.0.3.orig/data/Makefile.am geki3-KXL-1.0.3/data/Makefile.am
+--- geki3-KXL-1.0.3.orig/data/Makefile.am      2002-08-05 12:35:58.000000000 +0200
++++ geki3-KXL-1.0.3/data/Makefile.am   2003-05-10 21:25:39.000000000 +0200
+@@ -2,5 +2,6 @@
+ data_DATA = stage1.dat stage2.dat stage3.dat stage4.dat
+ EXTRA_DIST = stage1.dat stage2.dat stage3.dat stage4.dat .score
+-install:
+-      $(INSTALL) -c -m 666 ./.score $(DESTDIR)$(DATA_PATH)
++install-data-local:
++      $(INSTALL) -d -m 755 $(DESTDIR)$(SCORE_PATH)
++      $(INSTALL) -c -m 666 ./.score $(DESTDIR)$(SCORE_PATH)/geki3.score
+diff -Nur geki3-KXL-1.0.3.orig/src/ranking.c geki3-KXL-1.0.3/src/ranking.c
+--- geki3-KXL-1.0.3.orig/src/ranking.c 2002-08-05 12:35:58.000000000 +0200
++++ geki3-KXL-1.0.3/src/ranking.c      2003-05-10 21:25:05.000000000 +0200
+@@ -37,7 +37,7 @@
+   FILE *fp;\r
+   Uint16 i;\r
\r
+-  if ((fp = fopen(DATA_PATH "/.score", "r"))) {\r
++  if ((fp = fopen(SCORE_PATH "/geki3.score", "r"))) {\r
+     fscanf(fp, "%d", &(Root->HiScore));\r
+     for (i = 0; i < 5; i ++)\r
+       fscanf(fp, "%d %d %d %s",\r
+@@ -69,7 +69,7 @@
+   FILE *fp;\r
+   Uint16 i;\r
\r
+-  if ((fp = fopen(DATA_PATH "/.score", "w"))) {\r
++  if ((fp = fopen(SCORE_PATH "/geki3.score", "w"))) {\r
+     fprintf(fp, "%d\n", Root->HiScore);\r
+     for (i = 0; i < 5; i ++)\r
+       fprintf(fp, "%d %d %d %s\n",\r
index 69ca9d4c7cc001c83fe06ab87a3cd3dc9e3d58bd..6f844296efc9610e556e26f1121329e90cf2694a 100644 (file)
@@ -1,47 +1,53 @@
-#
-# TODO: move score file(s) to /var/games
-#
 Summary:       Geki3, a video-oriented game
 Summary(pl):   Geki3 - gra wideo
 Name:          geki3-KXL
-Version:       1.0.2
-Release:       0.1
+Version:       1.0.3
+Release:       1
 License:       GPL
 Group:         X11/Applications/Games
-Source:                http://www2.mwnet.or.jp/~fc3srx7/download/%{name}-%{version}.tar.gz
-URL:           http://www2.mwnet.or.jp/~fc3srx7/
-BuildRequires: KXL-devel >= 1.1.1
+Source0:       http://kxl.hn.org/download/%{name}-%{version}.tar.gz
+Patch0:                %{name}-scorepath.patch
+URL:           http://kxl.hn.org/games.php
+BuildRequires: KXL-devel >= 1.1.5
+BuildRequires: autoconf
+BuildRequires: automake
+Requires:      KXL >= 1.1.5
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-
 %description
 2D horizon scroll shooting game.
 
 %description -l pl
-Przewijana strzelanka 2D.
+Poziomo przewijana strzelanka 2D.
 
 %prep
 %setup -q
+%patch -p1
 
 %build
-%configure2_13
+%{__aclocal}
+%{__autoconf}
+%{__automake}
+%configure
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} DESTDIR=$RPM_BUILD_ROOT install
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/geki3
-%doc COPYING ChangeLog README
+%doc ChangeLog README
+%attr(2755,root,games) %{_bindir}/geki3
 %dir %{_datadir}/geki3
 %{_datadir}/geki3/bmp
 %{_datadir}/geki3/wav
 %dir %{_datadir}/geki3/data
 %{_datadir}/geki3/data/*.dat
-# MOVE TO /var/games!!!
-%config(noreplace) %{_datadir}/geki3/data/.score
+%attr(644,root,games) %config(noreplace) %verify(not size mtime md5) /var/games/geki3.score
This page took 0.101315 seconds and 4 git commands to generate.