]> git.pld-linux.org Git - packages/geis.git/commitdiff
- rel 6; fixes from debian auto/th/geis-2.2.17-6
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 5 Jul 2018 07:20:46 +0000 (09:20 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 5 Jul 2018 07:20:46 +0000 (09:20 +0200)
build.patch [new file with mode: 0644]
geis.spec

diff --git a/build.patch b/build.patch
new file mode 100644 (file)
index 0000000..11b8567
--- /dev/null
@@ -0,0 +1,57 @@
+Description: Fix misleading indentation to fix build with gcc-6
+Author: Sean Whitton <spwhitton@spwhitton.name>
+Bug-Debian: https://bugs.debian.org/811933
+Forwarded: https://bugs.launchpad.net/geis/+bug/1608086
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/libgeis/geis_subscription.c
++++ b/libgeis/geis_subscription.c
+@@ -238,8 +238,10 @@ geis_subscription_bag_empty(GeisSubBag b
+   for (i = 0; i < bag->sub_store_size; ++i)
+   {
+     if (bag->sub_store[i])
++    {
+       _subscription_unref(bag->sub_store[i]);
+       bag->sub_store[i] = NULL;
++    }
+   }
+ }
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 24 Apr 2017 12:34:55 -0700
+X-Dgit-Generated: 2.2.17-1.2 32cf7d865222f63ba5da5f79d340acf895ff9379
+Subject: libgeis: Compare the first character of string to null
+
+gcc7 wants to be specific when it comes to comparing characters
+and strings
+
+fixes
+
+| ../../../../../../../workspace/sources/geis/libgeis/geis_v1.c: In function '_v1_subscribe_device':
+| ../../../../../../../workspace/sources/geis/libgeis/geis_v1.c:613:20: error: comparison between pointer and zero character constant [-Werror=pointer-compare]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Bug-Debian: https://bugs.debian.org/853415
+
+---
+
+--- geis-2.2.17.orig/libgeis/geis_v1.c
++++ geis-2.2.17/libgeis/geis_v1.c
+@@ -610,7 +610,7 @@ _v1_subscribe_device(GeisInstance instan
+                      const char **gesture_list)
+ {
+   GeisStatus result = GEIS_UNKNOWN_ERROR;
+-  if (gesture_list == GEIS_ALL_GESTURES)
++  if (gesture_list[0][0] == GEIS_ALL_GESTURES)
+   {
+     geis_debug("subscribing device %d for all gestures", device_id);
+   }
+@@ -757,7 +757,7 @@ geis_unsubscribe(GeisInstance     instan
+                  GeisGestureType *gesture_list)
+ {
+   GeisStatus status = GEIS_STATUS_NOT_SUPPORTED;
+-  if (gesture_list == GEIS_ALL_GESTURES)
++  if (gesture_list[0] == GEIS_ALL_GESTURES)
+   {
+     status = geis_subscription_deactivate(instance->subscription);
+   }
index 376b4c8ffe81923d7c86554e2d23eead9424ca5c..32cbecf28dee0f0287af1004fbb18c919e7d56bd 100644 (file)
--- a/geis.spec
+++ b/geis.spec
@@ -5,11 +5,12 @@
 Summary:       An implementation of the GEIS (Gesture Engine Interface and Support) interface
 Name:          geis
 Version:       2.2.17
-Release:       5
+Release:       6
 License:       GPL v3/LGPL v3
 Group:         Libraries
 Source0:       https://launchpad.net/geis/trunk/%{version}/+download/%{name}-%{version}.tar.xz
 # Source0-md5: 2ff9d76a3ea5794516bb02c9d1924faf
+Patch0:                build.patch
 URL:           https://launchpad.net/geis
 BuildRequires: autoconf
 BuildRequires: automake
@@ -97,6 +98,7 @@ Narzędzie do przeglądania działania GEIS API.
 
 %prep
 %setup -q
+%patch0 -p1
 
 sed -i -e 's#-pedantic##g' configure.ac
 
This page took 0.12664 seconds and 4 git commands to generate.