]> git.pld-linux.org Git - packages/geis.git/blob - geis.spec
36a0c768cfe431c4120e5d582cdec7cc6387df73
[packages/geis.git] / geis.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        An implementation of the GEIS (Gesture Engine Interface and Support) interface
6 Name:           geis
7 Version:        2.2.16
8 Release:        2
9 License:        GPL v3/LGPL v3
10 Group:          Libraries
11 Source0:        https://launchpad.net/geis/trunk/%{version}/+download/%{name}-%{version}.tar.xz
12 # Source0-md5:  f70af0887a5585539406d8737b231b5e
13 URL:            https://launchpad.net/geis
14 BuildRequires:  dbus-devel >= 1.2.16
15 BuildRequires:  frame-devel >= 2.2
16 BuildRequires:  grail-devel >= 3.0.8
17 BuildRequires:  libxcb-devel >= 1.6
18 BuildRequires:  python3-devel
19 BuildRequires:  python3-modules
20 BuildRequires:  python3-setuptools > 7.0
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  xorg-lib-libX11-devel
23 BuildRequires:  xorg-lib-libXext-devel
24 BuildRequires:  xorg-lib-libXi-devel >= 1.3
25 Requires(post,postun):  /sbin/ldconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 GEIS is a library for applications and toolkit programmers which
30 provides a consistent platform independent interface for any
31 system-wide input gesture recognition mechanism.
32
33 %package tools
34 Summary:        Test tools for geis library
35 Summary(pl.UTF-8):      Testowe narzędzia biblioteki geis
36 Summary(pl.UTF-8):      Wspólne pliki biblioteki geis
37 Group:          Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description tools
41 Test tools for geis library.
42
43 %description tools -l pl.UTF-8
44 Testowe narzędzia biblioteki geis.
45
46 %package devel
47 Summary:        Header files for geis library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki geis
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for geis library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki geis.
57
58 %package static
59 Summary:        Static geis library
60 Summary(pl.UTF-8):      Statyczna biblioteka geis
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static geis library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka geis.
69
70 %package -n python3-geis
71 Summary:        Python3 bindings for geis library
72 Summary(pl.UTF-8):      Wiązania python3 dla biblioteki geis
73 Group:          Libraries/Python
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       python3-modules
76
77 %description -n python3-geis
78 Python3 bindings for geis library.
79
80 %description -n python3-geis -l pl.UTF-8
81 Wiązania python3 dla biblioteki geis.
82
83 %package -n geisview
84 Summary:        A tool to view operation of the GEIS API
85 Summary(pl.UTF-8):      Narzędzie do przeglądania działania GEIS API.
86 Group:          Applications
87 Requires:       python3-geis = %{version}-%{release}
88
89 %description -n geisview
90 A tool to view operation of the GEIS API.
91
92 %description -n geisview -l pl.UTF-8
93 Narzędzie do przeglądania działania GEIS API.
94
95 %prep
96 %setup -q
97
98 %build
99 %configure \
100         %{!?with_static_libs:--disable-static}
101 %{__make} V=1
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS README
120 %attr(755,root,root) %{_libdir}/libgeis.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libgeis.so.1
122
123 %files tools
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_bindir}/geistest
126 %attr(755,root,root) %{_bindir}/geis-server
127 %attr(755,root,root) %{_bindir}/pygeis
128 %{_mandir}/man1/pygeis.1*
129 %{_mandir}/man1/geistest.1*
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libgeis.so
134 %{_includedir}/geis
135 %{_pkgconfigdir}/libgeis.pc
136
137 %if %{with static_libs}
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libgeis.a
141 %endif
142
143 %files -n python3-geis
144 %defattr(644,root,root,755)
145 %{py3_sitedir}/_geis_bindings.so
146 %dir %{py3_sitescriptdir}/geis
147 %{py3_sitescriptdir}/geis/__init__.py*
148 %{py3_sitescriptdir}/geis/geis_v2.py*
149
150 %files -n geisview
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/geisview
153 %dir %{py3_sitescriptdir}/geisview
154 %{py3_sitescriptdir}/geisview/*.py*
155 %{_desktopdir}/geisview.desktop
156 %dir %{_datadir}/geisview
157 %{_datadir}/geisview/filter_definition.ui
158 %{_datadir}/geisview/filter_list.ui
159 %{_datadir}/geisview/geisview.ui
160 %{_pixmapsdir}/geisview32x32.xpm
161 %{_mandir}/man1/geisview.1*
This page took 0.068484 seconds and 2 git commands to generate.