]> git.pld-linux.org Git - packages/gegl.git/commitdiff
- added introspection bcond (requires babl built with introspection first)
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 18 Apr 2012 18:49:22 +0000 (18:49 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added introspection patch to fix Gegl API version in automake suite
- package locales

Changed files:
    gegl-introspection.patch -> 1.1
    gegl.spec -> 1.35

gegl-introspection.patch [new file with mode: 0644]
gegl.spec

diff --git a/gegl-introspection.patch b/gegl-introspection.patch
new file mode 100644 (file)
index 0000000..b01f3c0
--- /dev/null
@@ -0,0 +1,17 @@
+--- gegl-0.2.0/gegl/Makefile.am.orig   2012-03-25 23:30:17.000000000 +0200
++++ gegl-0.2.0/gegl/Makefile.am        2012-04-18 20:03:57.989734708 +0200
+@@ -118,10 +118,10 @@
+ INCLUDES = $(AM_CFLAGS) $(AM_CPPFLAGS)
+ Gegl-@GEGL_API_VERSION@.gir: libgegl-@GEGL_API_VERSION@.la Makefile
+-Gegl_0_1_gir_INCLUDES = GObject-2.0 GLib-2.0 Babl-0.1
+-Gegl_0_1_gir_CFLAGS = $(INCLUDES)
+-Gegl_0_1_gir_LIBS = libgegl-@GEGL_API_VERSION@.la
+-Gegl_0_1_gir_FILES = $(introspection_sources)
++Gegl_0_2_gir_INCLUDES = GObject-2.0 GLib-2.0 Babl-0.1
++Gegl_0_2_gir_CFLAGS = $(INCLUDES)
++Gegl_0_2_gir_LIBS = libgegl-@GEGL_API_VERSION@.la
++Gegl_0_2_gir_FILES = $(introspection_sources)
+ INTROSPECTION_GIRS += Gegl-@GEGL_API_VERSION@.gir
+ girdir = $(datadir)/gir-1.0
index a15ec21e18777354cc0079a4129b792d28a9a0f7..c024f70b7527a3c48a225e096006a188b531f0a9 100644 (file)
--- a/gegl.spec
+++ b/gegl.spec
@@ -1,10 +1,11 @@
 #
 # Conditional build:
-%bcond_with    mmx     # use MMX instructions
-%bcond_with    sse     # use SSE instructions
-%bcond_without doc     # apidocs
+%bcond_with    mmx             # use MMX instructions
+%bcond_with    sse             # use SSE instructions
+%bcond_without doc             # apidocs
+%bcond_without introspection   # API introspection
 # reenable when new babl will arrive that actually is able to build
-%bcond_with    vala    # Vala API
+%bcond_with    vala            # Vala API
 #
 %ifarch %{x8664} athlon pentium3 pentium4
 %define        with_mmx        1
@@ -12,6 +13,9 @@
 %ifarch %{x8664} pentium3 pentium4
 %define        with_sse        1
 %endif
+%if %{without introspection}
+%undefine      with_vala
+%endif
 Summary:       Generic image processing library
 Summary(pl.UTF-8):     Ogólna biblioteka przetwarzania obrazu
 Name:          gegl
@@ -25,6 +29,7 @@ Patch0:               %{name}-lua.patch
 Patch1:                %{name}-ffmpeg.patch
 Patch2:                %{name}-ruby1.9.patch
 Patch3:                %{name}-build.patch
+Patch4:                %{name}-introspection.patch
 URL:           http://www.gegl.org/
 BuildRequires: OpenEXR-devel
 BuildRequires: SDL-devel
@@ -33,15 +38,17 @@ BuildRequires:      asciidoc
 BuildRequires: autoconf >= 2.54
 BuildRequires: automake >= 1:1.11
 BuildRequires: babl-devel >= 0.1.10
+%{?with_introspection:BuildRequires:   /usr/share/gir-1.0/Babl-0.1.gir}
 BuildRequires: cairo-devel
 BuildRequires: enscript
 BuildRequires: exiv2-devel
 BuildRequires: ffmpeg-devel >= 0.8
 BuildRequires: gdk-pixbuf2-devel >= 2.18.0
 BuildRequires: glib2-devel >= 1:2.28.0
-BuildRequires: gobject-introspection-devel >= 0.10.0
+%{?with_introspection:BuildRequires:   gobject-introspection-devel >= 0.10.0}
 BuildRequires: graphviz
 BuildRequires: gtk-doc >= 1.0
+BuildRequires: intltool >= 0.40.1
 BuildRequires: jasper-devel >= 1.900.1
 BuildRequires: lensfun-devel >= 0.2.5
 BuildRequires: libjpeg-devel
@@ -139,6 +146,7 @@ API języka Vala dla biblioteki gegl.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__libtoolize}
@@ -149,11 +157,12 @@ API języka Vala dla biblioteki gegl.
 %configure \
        CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack" \
        --enable-docs%{!?with_doc:=no} \
+       %{?with_introspection:--enable-introspection} \
        %{!?with_mmx:--disable-mmx} \
        %{!?with_sse:--disable-sse} \
-       --with%{!?with_vala:out}-vala \
        --disable-silent-rules \
-       --enable-static
+       --enable-static \
+       --with%{!?with_vala:out}-vala
 %{__make}
 
 %install
@@ -165,19 +174,21 @@ rm -rf $RPM_BUILD_ROOT
 
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.2/*.{a,la}
 
+%find_lang %{name}-0.2
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%files
+%files -f %{name}-0.2.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/gegl
 %attr(755,root,root) %{_libdir}/libgegl-0.2.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.2.so.0
-#%{_libdir}/girepository-1.0/Gegl-0.2.typelib
+%{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.2.typelib}
 %dir %{_libdir}/gegl-0.2
 %attr(755,root,root) %{_libdir}/gegl-0.2/*.so
 
@@ -186,7 +197,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libgegl-0.2.so
 %{_libdir}/libgegl-0.2.la
 %{_includedir}/gegl-0.2
-#%{_datadir}/gir-1.0/Gegl-0.2.gir
+%{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.2.gir}
 %{_pkgconfigdir}/gegl-0.2.pc
 
 %files static
This page took 0.122882 seconds and 4 git commands to generate.