]> git.pld-linux.org Git - packages/gegl.git/commitdiff
borrow patch from FreeBSD to unbreak build with ffmpeg4
authorJan Palus <atler@pld-linux.org>
Thu, 26 Apr 2018 22:56:51 +0000 (00:56 +0200)
committerJan Palus <atler@pld-linux.org>
Thu, 26 Apr 2018 22:59:24 +0000 (00:59 +0200)
AVFMT_RAWPICTURE support was dropped (deprecated since 2015) see
http://ffmpeg.org/pipermail/ffmpeg-cvslog/2017-October/110261.html

gegl-ffmpeg4.patch [new file with mode: 0644]
gegl.spec

diff --git a/gegl-ffmpeg4.patch b/gegl-ffmpeg4.patch
new file mode 100644 (file)
index 0000000..79a512e
--- /dev/null
@@ -0,0 +1,46 @@
+--- operations/external/ff-save.c.orig 2017-07-01 17:19:54 UTC
++++ operations/external/ff-save.c
+@@ -290,7 +290,7 @@ add_audio_stream (GeglProperties *o, AVFormatContext *
+   c->codec_type = AVMEDIA_TYPE_AUDIO;
+   if (oc->oformat->flags & AVFMT_GLOBALHEADER)
+-    c->flags |= CODEC_FLAG_GLOBAL_HEADER;
++    c->flags |= AV_CODEC_FLAG_GLOBAL_HEADER;
+   return st;
+ }
+@@ -631,7 +631,7 @@ add_video_stream (GeglProperties *o, AVFormatContext *
+ #endif
+    if (oc->oformat->flags & AVFMT_GLOBALHEADER)
+-     c->flags |= CODEC_FLAG_GLOBAL_HEADER;
++     c->flags |= AV_CODEC_FLAG_GLOBAL_HEADER;
+   return st;
+ }
+@@ -699,7 +699,9 @@ open_video (GeglProperties *o, AVFormatContext * oc, A
+     }
+   p->video_outbuf = NULL;
++#ifdef AVFMT_RAWPICTURE
+   if (!(oc->oformat->flags & AVFMT_RAWPICTURE))
++#endif
+     {
+       /* allocate output buffer, 1 mb / frame, might fail for some codecs on UHD - but works for now */
+       p->video_outbuf_size = 1024 * 1024;
+@@ -803,6 +805,7 @@ write_video_frame (GeglProperties *o,
+   picture_ptr      = p->picture;
+   picture_ptr->pts = p->frame_count;
++#ifdef AVFMT_RAWPICTURE
+   if (oc->oformat->flags & AVFMT_RAWPICTURE)
+     {
+       /* raw video case. The API will change slightly in the near
+@@ -821,6 +824,7 @@ write_video_frame (GeglProperties *o,
+       ret = av_write_frame (oc, &pkt);
+     }
+   else
++#endif
+     {
+       /* encode the image */
+       AVPacket pkt2;
index f94235b7f500d82263aa701f7d72b9effcfee568..aeb067ca15f0ca94f9f1c643e2e495cd49bf5dd5 100644 (file)
--- a/gegl.spec
+++ b/gegl.spec
@@ -29,9 +29,10 @@ License:     LGPL v3+
 Group:         Libraries
 Source0:       https://download.gimp.org/pub/gegl/0.3/%{name}-%{version}.tar.bz2
 # Source0-md5: e6758d2526c27dd3a34d3470aa844112
-Patch2:                %{name}-ruby1.9.patch
-Patch3:                %{name}-build.patch
-Patch5:                umfpack.patch
+Patch1:                %{name}-ruby1.9.patch
+Patch2:                %{name}-build.patch
+Patch3:                umfpack.patch
+Patch4:                %{name}-ffmpeg4.patch
 URL:           http://www.gegl.org/
 BuildRequires: OpenEXR-devel >= 1.6.1
 BuildRequires: SDL-devel >= 1.2.0
@@ -165,9 +166,10 @@ API jÄ™zyka Vala dla biblioteki gegl.
 
 %prep
 %setup -q
+%patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch5 -p1
+%patch4 -p0
 
 %build
 %{__libtoolize}
This page took 0.16231 seconds and 4 git commands to generate.