]> git.pld-linux.org Git - packages/gegl-qt.git/commitdiff
- updated URLs master
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 24 Apr 2021 11:00:06 +0000 (13:00 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 24 Apr 2021 11:00:06 +0000 (13:00 +0200)
- added gegl-0.3 patch from git (gegl-0.3 support)
- added gegl-0.4 patch (gegl-0.4 support, disable operations module - not ported to new chanting)
- added python-dirs patch (update py_sitedir detection)
- adjusted shiboken patch to use -py2.pc files from shiboken and PySide

gegl-qt-gegl-0.3.patch [new file with mode: 0644]
gegl-qt-gegl-0.4.patch [new file with mode: 0644]
gegl-qt-python-dirs.patch [new file with mode: 0644]
gegl-qt-shiboken.patch
gegl-qt.spec

diff --git a/gegl-qt-gegl-0.3.patch b/gegl-qt-gegl-0.3.patch
new file mode 100644 (file)
index 0000000..45e8073
--- /dev/null
@@ -0,0 +1,30 @@
+From 0e48db1e2baac9dde31b1a0b9add2ccd28df012b Mon Sep 17 00:00:00 2001
+From: Jon Nordby <jononor@gmail.com>
+Date: Fri, 28 Jun 2013 03:04:24 +0200
+Subject: [PATCH] Build: allow to build against gegl-0.3 (git master) also
+
+---
+ config.pri | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/config.pri b/config.pri
+index b279869..7fd4ecd 100644
+--- a/config.pri
++++ b/config.pri
+@@ -23,6 +23,13 @@ MOC_DIR = .moc
+ HAVE_GEGL = no
+ GEGL_PKG = ""
++contains(HAVE_GEGL, no) {
++    system(pkg-config --exists gegl-0.3) {
++        HAVE_GEGL = 0.3
++        GEGL_PKG = gegl-0.3
++    }
++}
++
+ contains(HAVE_GEGL, no) {
+     system(pkg-config --exists gegl-0.2) {
+         HAVE_GEGL = 0.2
+-- 
+GitLab
+
diff --git a/gegl-qt-gegl-0.4.patch b/gegl-qt-gegl-0.4.patch
new file mode 100644 (file)
index 0000000..45808fc
--- /dev/null
@@ -0,0 +1,39 @@
+--- gegl-qt-0.0.7/config.pri.orig      2021-04-24 09:39:50.524992585 +0200
++++ gegl-qt-0.0.7/config.pri   2021-04-24 09:40:32.558098205 +0200
+@@ -24,6 +24,13 @@
+ GEGL_PKG = ""
+ contains(HAVE_GEGL, no) {
++    system(pkg-config --exists gegl-0.4) {
++        HAVE_GEGL = 0.4
++        GEGL_PKG = gegl-0.4
++    }
++}
++
++contains(HAVE_GEGL, no) {
+     system(pkg-config --exists gegl-0.3) {
+         HAVE_GEGL = 0.3
+         GEGL_PKG = gegl-0.3
+#--- gegl-qt-0.0.7/pygegl-qt/pygegl-qt.pro.orig        2021-04-24 09:41:03.621263255 +0200
+#+++ gegl-qt-0.0.7/pygegl-qt/pygegl-qt.pro     2021-04-24 09:58:37.222222075 +0200
+#@@ -33,7 +33,7 @@
+#         -I$$[QT_INSTALL_HEADERS]/QtNetwork
+# }
+# 
+#-INCLUDES += $$system(pkg-config --cflags gegl-0.2 pygobject-2.0 gobject-2.0 pyside shiboken QtCore)
+#+INCLUDES += $$system(pkg-config --cflags gegl-0.4 pygobject-2.0 gobject-2.0 pyside shiboken QtCore)
+# 
+# # pkg-config --libs pyside is buggy for pyside<1.0.5 due
+# # http://bugs.pyside.org/show_bug.cgi?id=929
+--- gegl-qt-0.0.7/gegl-qt.pro.orig     2021-04-24 10:04:48.540210473 +0200
++++ gegl-qt-0.0.7/gegl-qt.pro  2021-04-24 11:03:32.847784327 +0200
+@@ -10,9 +10,6 @@
+     contains(HAVE_PYSIDE, yes) {
+         SUBDIRS += pygegl-qt
+     }
+-    contains(HAVE_QT_WIDGETS, yes) {
+-        SUBDIRS += operations
+-    }
+     SUBDIRS +=  plugins doc
+ } else {
diff --git a/gegl-qt-python-dirs.patch b/gegl-qt-python-dirs.patch
new file mode 100644 (file)
index 0000000..c08a76a
--- /dev/null
@@ -0,0 +1,14 @@
+--- gegl-qt-0.0.7/pygegl-qt/pygegl-qt.pro.orig 2021-04-24 11:41:21.642159879 +0200
++++ gegl-qt-0.0.7/pygegl-qt/pygegl-qt.pro      2021-04-24 12:44:03.721778946 +0200
+@@ -79,9 +79,9 @@
+ link.commands += $$QMAKE_CXX $$QMAKE_LFLAGS_RELEASE ../geglqt*wrapper.o $$LIBRARIES -fPIC -shared -Wl,-soname,geglqt.so -o geglqt.so
+ # Install
+-PYTHON_SITE_PACKAGES = $$system(`echo $PYTHON` -c \"from distutils.sysconfig import get_python_lib; print get_python_lib(True)\")
++PYTHON_SITE_PACKAGES = $$system(`echo $PYTHON` -c \"from distutils.sysconfig import get_python_lib; print get_python_lib(True, False, prefix=\'/usr\')\")
+ isEmpty(PYTHON_SITE_PACKAGES) {
+-    PYTHON_SITE_PACKAGES = $$system(python -c \"from distutils.sysconfig import get_python_lib; print get_python_lib(True)\")
++    PYTHON_SITE_PACKAGES = $$system(python -c \"from distutils.sysconfig import get_python_lib; print get_python_lib(True, False, prefix=\'/usr\')\")
+ }
index 1ce3c644a54ea6ac2b163c231a7fbcac2c22bf7b..b9624cb2c05f89b6e238d4f470f1df75fadcbb0e 100644 (file)
@@ -5,7 +5,7 @@
  }
  
 -INCLUDES += $$system(pkg-config --cflags gegl pygobject-2.0 gobject-2.0 pyside)
-+INCLUDES += $$system(pkg-config --cflags gegl-0.2 pygobject-2.0 gobject-2.0 pyside shiboken QtCore)
++INCLUDES += $$system(pkg-config --cflags $$GEGL_PKG pygobject-2.0 gobject-2.0 pyside-py2 shiboken-py2 QtCore)
  
  # pkg-config --libs pyside is buggy for pyside<1.0.5 due
  # http://bugs.pyside.org/show_bug.cgi?id=929
index 5b1796a3a0618edac4ec673a09f6970ee3fc697e..eee49ba5406d779e40a1d0b67efb2bc1a68539f8 100644 (file)
@@ -12,7 +12,7 @@ Version:      0.0.7
 Release:       1
 License:       LGPL v3+
 Group:         Libraries
-Source0:       ftp://ftp.gimp.org/pub/gegl-qt/0.0/%{name}-%{version}.tar.bz2
+Source0:       https://download.gimp.org/pub/gegl-qt/0.0/%{name}-%{version}.tar.bz2
 # Source0-md5: fbb0692af354d404615980a68c8a88f4
 # git diff 0.0.7 4f46898e7dfaade23553f167bb03caf95171c0e7 (before switch to gegl 0.3)
 # (then adjusted to apply on dist tarball)
@@ -20,7 +20,11 @@ Patch0:              %{name}-git.patch
 Patch1:                %{name}-shiboken.patch
 Patch2:                %{name}-qmake.patch
 Patch3:                %{name}-qt5.patch
-URL:           http://www.gegl.org/
+# https://gitlab.gnome.org/Archive/gegl-qt/-/commit/0e48db1e2baac9dde31b1a0b9add2ccd28df012b.patch (last commit)
+Patch4:                %{name}-gegl-0.3.patch
+Patch5:                %{name}-gegl-0.4.patch
+Patch6:                %{name}-python-dirs.patch
+URL:           https://www.gegl.org/
 %if %{with qt4}
 BuildRequires: QtCore-devel >= 4
 BuildRequires: QtDeclarative-devel >= 4
@@ -41,8 +45,8 @@ BuildRequires:        rpmbuild(macros) >= 1.219
 BuildRequires: texlive-format-pdflatex
 BuildRequires: texlive-latex-extend
 %if %{with python}
-BuildRequires: python-PySide-devel
-BuildRequires: shiboken
+BuildRequires: python-PySide-devel >= 4.8_1.2.4-1
+BuildRequires: shiboken >= 1.2.4-3
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -139,6 +143,9 @@ Dokumentacja API biblioteki gegl.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 %build
 %if %{with qt4}
@@ -205,7 +212,8 @@ rm -rf $RPM_BUILD_ROOT
 %doc README.txt
 %attr(755,root,root) %{_libdir}/libgegl-qt4-0.1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libgegl-qt4-0.1.so.0
-%attr(755,root,root) %{_libdir}/gegl-0.2/libgegl-qt4-display.so
+# not ready for gegl-0.4
+#%attr(755,root,root) %{_libdir}/gegl-0.3/libgegl-qt4-display.so
 %dir %{_libdir}/qt4/imports/GeglQt4
 %attr(755,root,root) %{_libdir}/qt4/imports/GeglQt4/libgegl-qt4-0.1.so
 %{_libdir}/qt4/imports/GeglQt4/qmldir
@@ -230,7 +238,8 @@ rm -rf $RPM_BUILD_ROOT
 %doc README.txt
 %attr(755,root,root) %{_libdir}/libgegl-qt5-0.1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libgegl-qt5-0.1.so.0
-%attr(755,root,root) %{_libdir}/gegl-0.2/libgegl-qt5-display.so
+# not ready for gegl-0.4
+#%attr(755,root,root) %{_libdir}/gegl-0.3/libgegl-qt5-display.so
 # not ready for qt5 plugin format (_disabled in qt5 patch)
 #%dir %{_libdir}/qt4/imports/GeglQt4
 #%attr(755,root,root) %{_libdir}/qt4/imports/GeglQt4/libgegl-qt4-0.1.so
This page took 0.10837 seconds and 4 git commands to generate.