]> git.pld-linux.org Git - packages/gdome2.git/blob - gdome2.spec
- added no-common patch to fix build with -fno-common, gcc 10+ default; release 16
[packages/gdome2.git] / gdome2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 Summary:        DOM level2 library for accessing XML files
6 Summary(pl.UTF-8):      Biblioteka dostępu do plików XML, DOM poziom 2
7 Name:           gdome2
8 Version:        0.8.1
9 Release:        13
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://gdome2.cs.unibo.it/tarball/%{name}-%{version}.tar.gz
13 # Source0-md5:  bfc114e59eec50cbda8e4ece751ff022
14 Patch0:         %{name}-glib2.patch
15 Patch1:         %{name}-build_fix.patch
16 Patch2:         format-security.patch
17 Patch3:         %{name}-destdir.patch
18 URL:            http://gdome2.cs.unibo.it/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  glib2-devel >= 2.2.0
22 BuildRequires:  libtool
23 BuildRequires:  libxml2-devel >= 1:2.4.26
24 BuildRequires:  pkgconfig
25 Requires:       glib2 >= 2.2.0
26 Requires:       libxml2 >= 1:2.4.26
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 gdome2 is a fast, light and complete DOM level2 implementation based
31 on libxml2. Although it has been written for the GNOME project, it can
32 be used stand-alone.
33
34 A DOM implementation (also called a host implementation) is what makes
35 a parsed XML or HTML document available for processing via the DOM
36 interface.
37
38 gdome2 currently supports the "Core", "XML", "Events" and
39 "MutationEvents" modules from the DOM2 Recommendation (see
40 http://www.w3.org/TR/DOM-Level-2-Core/ and
41 http://www.w3.org/TR/DOM-Level-2-Events/), and is supposed to become a
42 full implementation of all the DOM Level2 standard.
43
44 Now gdome2 also partially supports the XPath module from the DOM level
45 3 drafts.
46
47 %description -l pl.UTF-8
48 gdome2 jest szybką, lekką i kompletną implementacją poziomu 2 DOM
49 opartą o libxml2. Pomimo, że gdome2 zostało napisane z myślą o
50 projekcie GNOME, może być używane samodzielnie.
51
52 Implementacja DOM (zwana również implementacją hosta) udostępnia
53 przeanalizowany składniowo dokument XML lub HTML w celu dalszego jego
54 przetwarzania poprzez interfejs DOM.
55
56 gdome2 w chwili obecnej wspiera następujące moduły rekomendacji DOM2:
57 "Core", "XML", "Events" oraz "MutationEvents" (więcej informacji można
58 uzyskać pod adresem http://www.w3.org/TR/DOM-Level-2-Core/ oraz
59 http://www.w3.org/TR/DOM-Level-2-Events/), a w przyszłości ma zostać
60 pełną implementacją standardu poziomu 2 DOM.
61
62 gdome2 wspiera również częściowo poziom 3 DOM, konkretnie XPath.
63
64 %package devel
65 Summary:        Development files for gdome2
66 Summary(pl.UTF-8):      Pliki nagłówkowe gdome2
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       glib2-devel >= 2.2.0
70 Requires:       libxml2-devel >= 1:2.4.26
71
72 %description devel
73 This package contains the header files and configuration scripts for
74 developing with gdome2.
75
76 gdome2 is a fast, light and complete DOM level2 implementation based
77 on libxml2. Although it has been written for the GNOME project, it can
78 be used stand-alone.
79
80 A DOM implementation (also called a host implementation) is what makes
81 a parsed XML or HTML document available for processing via the DOM
82 interface.
83
84 gdome2 currently supports the "Core", "XML", "Events" and
85 "MutationEvents" modules from the DOM2 Recommendation (see
86 http://www.w3.org/TR/DOM-Level-2-Core/ and
87 http://www.w3.org/TR/DOM-Level-2-Events/), and is supposed to become a
88 full implementation of all the DOM Level2 standard.
89
90 Now gdome2 also partially supports the XPath module from the DOM level
91 3 drafts.
92
93 %description devel -l pl.UTF-8
94 Pakiet ten zawiera pliki nagłówkowe oraz skrypty konfiguracyjne
95 potrzebne do rozwijania oprogramowania opartego o gdome2.
96
97 gdome2 jest szybką, lekką i kompletną implementacją poziomu 2 DOM
98 opartą o libxml2. Pomimo, że gdome2 zostało napisane z myślą o
99 projekcie GNOME, może być używane samodzielnie.
100
101 Implementacja DOM (zwana również implementacją hosta) udostępnia
102 przeanalizowany składniowo dokument XML lub HTML w celu dalszego jego
103 przetwarzania poprzez interfejs DOM.
104
105 gdome2 w chwili obecnej wspiera następujące moduły rekomendacji DOM2:
106 "Core", "XML", "Events" oraz "MutationEvents" (więcej informacji można
107 uzyskać pod adresem http://www.w3.org/TR/DOM-Level-2-Core/ oraz
108 http://www.w3.org/TR/DOM-Level-2-Events/), a w przyszłości ma zostać
109 pełną implementacją standardu poziomu 2 DOM.
110
111 gdome2 wspiera również częściowo poziom 3 DOM, konkretnie XPath.
112
113 %package static
114 Summary:        Static libraries for gdome2
115 Summary(pl.UTF-8):      Biblioteki statyczne dla gdome2
116 Group:          Development/Libraries
117 Requires:       %{name}-devel = %{version}-%{release}
118
119 %description static
120 This package contains static libraries for developing with gdome2.
121
122 %description static -l pl.UTF-8
123 Pakiet ten zawiera statyczne biblioteki potrzebne do rozwijania
124 oprogramowania opartego o gdome2.
125
126 %package apidocs
127 Summary:        API documentation for gdome2 library
128 Summary(pl.UTF-8):      Dokumentacja API biblioteki gdome2
129 Group:          Documentation
130 %if "%{_rpmversion}" >= "5"
131 BuildArch:      noarch
132 %endif
133
134 %description apidocs
135 API documentation for gdome2 library.
136
137 %description apidocs -l pl.UTF-8
138 Dokumentacja API biblioteki gdome2.
139
140 %prep
141 %setup -q
142 %patch0 -p1
143 %patch1 -p1
144 %patch2 -p1
145 %patch3 -p1
146
147 # disable glib 1.x in order to force 2.x
148 echo 'AM_DEFUN([AM_PATH_GLIB], [$3])' >> acinclude.m4
149
150 %build
151 %{__libtoolize}
152 %{__aclocal}
153 %{__autoconf}
154 %{__autoheader}
155 %{__automake}
156 %configure \
157         %{!?with_static_libs:--disable-static} \
158         --with-html-dir=%{_gtkdocdir}
159
160 %{__make}
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164
165 %{__make} install \
166         DESTDIR=$RPM_BUILD_ROOT
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   -p /sbin/ldconfig
172 %postun -p /sbin/ldconfig
173
174 %files
175 %defattr(644,root,root,755)
176 %doc AUTHORS MAINTAINERS ChangeLog README
177 %attr(755,root,root) %{_libdir}/libgdome.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libgdome.so.0
179
180 %files devel
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_bindir}/gdome-config
183 %attr(755,root,root) %{_libdir}/libgdome.so
184 %{_libdir}/libgdome.la
185 %attr(755,root,root) %{_libdir}/gdomeConf.sh
186 %{_includedir}/libgdome
187 %{_mandir}/man1/gdome-config.1*
188 %{_aclocaldir}/gdome2.m4
189 %{_pkgconfigdir}/gdome2.pc
190
191 %if %{with static_libs}
192 %files static
193 %defattr(644,root,root,755)
194 %{_libdir}/libgdome.a
195 %endif
196
197 %files apidocs
198 %defattr(644,root,root,755)
199 %{_gtkdocdir}/gdome2-%{version}
This page took 0.053756 seconds and 3 git commands to generate.