]> git.pld-linux.org Git - packages/gdbm.git/blob - gdbm.spec
- changed all BuildRoot definitons
[packages/gdbm.git] / gdbm.spec
1 Summary:        GNU database library for C
2 Summary(de):    GNU-Datenbank-Library für C
3 Summary(fr):    La librairie GNU de bases de données pout le langage C.
4 Summary(pl):    GNU biblioteka bazy danych la jêzyka C
5 Name:           gdbm
6 Version:        1.8.0
7 Release:        3
8 Copyright:      GPL
9 Group:          Libraries
10 Group(pl):      Biblioteki
11 Source:         ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
12 Patch0:         gdbm-info.patch
13 Patch1:         gdbm-DESTDIR.patch
14 Patch2:         gdbm-jbj.patch
15 BuildRequires:  libtool
16 BuildRequires:  autoconf
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Gdbm is a GNU database indexing library, including routines which use
21 extensible hashing. Gdbm works in a similar way to standard UNIX dbm
22 routines. Gdbm is useful for developers who write C applications and need
23 access to a simple and efficient database or who are building C applications
24 which will use such a database.
25
26 %description -l de
27 Dies ist eine Datenbank-Index-Library für Programmierer, die 
28 C-Anwendungen schreiben und eine einfache und leistungsfähige
29 Datenbank benötigen oder diese in C-Anwendungen einsetzen möchten.
30
31 %description -l fr
32 Une librairie d'indexation de bases de données. Elle est utile pour ceux
33 qui désirent écrivent des applications en C et ont besion d'accéder à
34 une base de données simple et efficace ou de construire une application
35 en C qui l'utilise.
36
37 %description -l pl
38 W pakiecie znajduje siê biblioteka indeksowania bazy danych. Biblioteka
39 ta jest szczególnie uzyteczna dla ludzi, którzy pisz± oprogramowanie w C
40 i potrzebuj± prostej i szybkiej bazy danych, lub dla tych którzy pisz±
41 programy w C z wykorzystaniem tej biblioteki. 
42
43 %description -l tr
44 gdbm bir veri tabaný dizinleme kitaplýðýdýr. C uygulamalarý yazýp basit ve
45 etkin bir þekilde veri tabanýna ulaþmak isteyenler için yararlý olacaktýr.
46
47 %package devel
48 Summary:        development libraries and header files for gdbm
49 Summary(de):    Entwicklungs-Libraries und Header-Dateien für gdbm 
50 Summary(fr):    Bibliothèques de développement et en-têtes pour gdbm
51 Summary(pl):    Biblioteki i pliki nag³ówkowe dla gdbm
52 Summary(tr):    gdbm için baþlýk dosyalarý ve geliþtirme kitaplýklarý
53 Group:          Development/Libraries
54 Group(pl):      Programowanie/Biblioteki
55 Requires:       %{name} = %{version}
56 Prereq:         /usr/sbin/fix-info-dir
57
58 %description devel
59 These are the development libraries and header files for gdbm, the
60 GNU database system.  These are required if you plan to do 
61 development using the gdbm database.
62
63 %description -l de devel
64 Dies sind die Entwicklungs-Libraries und Header-Dateien für gdbm, das
65 GNU-Datenbanksystem. Sie sind darauf angewiesen, wenn Sie vorhaben,
66 die gdbm-Datenbank für Entwicklungsarbeiten zu benutzen.
67
68 %description -l fr devel
69 Ce sont les librairies de développement et les fichiers d'en-tête pour gdbm,
70 le système de base de données GNU. Ceci est nécessaire si vous désirez 
71 développer en utilisant la base de données gdbm.
72
73 %description -l pl devel
74 W pakiecie tym znajduj± siê pliki nag³ówkowe i biblioteki dla GNU
75 systemu bazy danych.
76
77 %description -l tr devel
78 GNU veri tabaný sistemi gdbm ile program geliþtirmek için gereken baþlýk
79 dosyalarý ve kitaplýklar.
80
81 %package static
82 Summary:        Static gdbm library
83 Summary(pl):    Biblioteki statyczne gdbm
84 Group:          Development/Libraries
85 Group(pl):      Programowanie/Biblioteki
86 Requires:       %{name}-devel = %{version}
87
88 %description static
89 Static gdbm library.
90
91 %prep
92 %setup  -q
93 %patch0 -p1
94 %patch1 -p1
95 %patch2 -p1
96
97 %build
98 libtoolize --copy --force
99 aclocal
100 autoheader
101 autoconf
102 %configure
103
104 make CFLAGS="$RPM_OPT_FLAGS"
105
106 makeinfo gdbm.texinfo
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}} \
111            $RPM_BUILD_ROOT{%{_mandir}/man3,%{_infodir}}
112
113 make install \
114         prefix=%{_prefix} \
115         exec_prefix=%{_exec_prefix} \
116         binprefix=%{_exec_prefix} \
117         manprefix=%{_prefix} \
118         libdir=%{_libdir} \
119         includedir=%{_includedir} \
120         infodir=%{_infodir} \
121         man3dir=%{_mandir}/man3 \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
125
126 gzip -fn9 $RPM_BUILD_ROOT{%{_infodir}/gdbm*info*,%{_mandir}/man3/*}
127
128 %post -p /sbin/ldconfig
129
130 %post devel
131 /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
132
133 %postun -p /sbin/ldconfig
134
135 %postun devel
136 /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/lib*.so.*.*
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/lib*.so
148 %attr(755,root,root) %{_libdir}/lib*.la
149 %{_mandir}/man3/*
150 %{_includedir}/*
151 %{_infodir}/gdbm*
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/lib*.a
This page took 0.040792 seconds and 4 git commands to generate.