]> git.pld-linux.org Git - packages/gdbm.git/blob - gdbm.spec
- release 2.
[packages/gdbm.git] / gdbm.spec
1 Summary:        GNU database library for C
2 Summary(de):    GNU-Datenbank-Library für C
3 Summary(fr):    La librairie GNU de bases de données pout le langage C.
4 Summary(pl):    GNU biblioteka bazy danych la jêzyka C
5 Name:           gdbm
6 Version:        1.8.0
7 Release:        2
8 Copyright:      GPL
9 Group:          Libraries
10 Group(pl):      Biblioteki
11 Source:         ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
12 Patch0:         gdbm-info.patch
13 Patch1:         gdbm-DESTDIR.patch
14 BuildRequires:  libtool
15 BuildRequires:  autoconf
16 Buildroot:      /tmp/%{name}-%{version}-root
17
18 %description
19 This is a database indexing library. It is useful for those who need 
20 to write C applications and need access to a simple and efficient
21 database or build C applications which use it.
22
23 %description -l de
24 Dies ist eine Datenbank-Index-Library für Programmierer, die 
25 C-Anwendungen schreiben und eine einfache und leistungsfähige
26 Datenbank benötigen oder diese in C-Anwendungen einsetzen möchten.
27
28 %description -l fr
29 Une librairie d'indexation de bases de données. Elle est utile pour ceux
30 qui désirent écrivent des applications en C et ont besion d'accéder à
31 une base de données simple et efficace ou de construire une application
32 en C qui l'utilise.
33
34 %description -l pl
35 W pakiecie znajduje siê biblioteka indeksowania bazy danych. Biblioteka
36 ta jest szczególnie uzyteczna dla ludzi, którzy pisz± oprogramowanie w C
37 i potrzebuj± prostej i szybkiej bazy danych, lub dla tych którzy pisz±
38 programy w C z wykorzystaniem tej biblioteki. 
39
40 %description -l tr
41 gdbm bir veri tabaný dizinleme kitaplýðýdýr. C uygulamalarý yazýp basit ve
42 etkin bir þekilde veri tabanýna ulaþmak isteyenler için yararlý olacaktýr.
43
44 %package devel
45 Summary:        development libraries and header files for gdbm
46 Summary(de):    Entwicklungs-Libraries und Header-Dateien für gdbm 
47 Summary(fr):    Bibliothèques de développement et en-têtes pour gdbm
48 Summary(pl):    Biblioteki i pliki nag³ówkowe dla gdbm
49 Summary(tr):    gdbm için baþlýk dosyalarý ve geliþtirme kitaplýklarý
50 Group:          Development/Libraries
51 Group(pl):      Programowanie/Biblioteki
52 Requires:       %{name} = %{version}
53 Prereq:         /sbin/install-info
54
55 %description devel
56 These are the development libraries and header files for gdbm, the
57 GNU database system.  These are required if you plan to do 
58 development using the gdbm database.
59
60 %description -l de devel
61 Dies sind die Entwicklungs-Libraries und Header-Dateien für gdbm, das
62 GNU-Datenbanksystem. Sie sind darauf angewiesen, wenn Sie vorhaben,
63 die gdbm-Datenbank für Entwicklungsarbeiten zu benutzen.
64
65 %description -l fr devel
66 Ce sont les librairies de développement et les fichiers d'en-tête pour gdbm,
67 le système de base de données GNU. Ceci est nécessaire si vous désirez 
68 développer en utilisant la base de données gdbm.
69
70 %description -l pl devel
71 W pakiecie tym znajduj± siê pliki nag³ówkowe i biblioteki dla GNU
72 systemu bazy danych.
73
74 %description -l tr devel
75 GNU veri tabaný sistemi gdbm ile program geliþtirmek için gereken baþlýk
76 dosyalarý ve kitaplýklar.
77
78 %package static
79 Summary:        Static gdbm library
80 Summary(pl):    Biblioteki statyczne gdbm
81 Group:          Development/Libraries
82 Group(pl):      Programowanie/Biblioteki
83 Requires:       %{name}-devel = %{version}
84
85 %description static
86 Static gdbm library.
87
88 %prep
89 %setup  -q
90 %patch0 -p1
91 %patch1 -p1
92
93 %build
94 libtoolize --copy --force
95 aclocal
96 autoheader
97 autoconf
98 %configure
99
100 make CFLAGS="$RPM_OPT_FLAGS"
101
102 makeinfo gdbm.texinfo
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}} \
107            $RPM_BUILD_ROOT{%{_mandir}/man3,%{_infodir}}
108
109 make install \
110         prefix=%{_prefix} \
111         exec_prefix=%{_exec_prefix} \
112         binprefix=%{_exec_prefix} \
113         manprefix=%{_prefix} \
114         libdir=%{_libdir} \
115         includedir=%{_includedir} \
116         infodir=%{_infodir} \
117         man3dir=%{_mandir}/man3 \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
121
122 gzip -fn9 $RPM_BUILD_ROOT{%{_infodir}/gdbm*info*,%{_mandir}/man3/*}
123
124 %post -p /sbin/ldconfig
125
126 %post devel
127 /sbin/install-info %{_infodir}/gdbm.info.gz /etc/info-dir
128
129 %postun -p /sbin/ldconfig
130
131 %preun devel
132 if [ "$1" = "0" ]; then
133         /sbin/install-info --delete %{_infodir}/gdbm.info.gz /etc/info-dir
134 fi
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %files
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/lib*.so.*.*
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/lib*.so
146 %attr(755,root,root) %{_libdir}/lib*.la
147 %{_mandir}/man3/*
148 %{_includedir}/*
149 %{_infodir}/gdbm*
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/lib*.a
This page took 0.036664 seconds and 4 git commands to generate.