]> git.pld-linux.org Git - packages/gdbm.git/blob - gdbm.spec
- spec adapterized.
[packages/gdbm.git] / gdbm.spec
1 Summary:        GNU database library for C
2 Summary(de):    GNU-Datenbank-Library für C
3 Summary(fr):    La librairie GNU de bases de données pout le langage C.
4 Summary(pl):    GNU biblioteka bazy danych la jêzyka C
5 Name:           gdbm
6 Version:        1.8.0
7 Release:        4
8 License:        GPL
9 Group:          Libraries
10 Group(fr):      Librairies
11 Group(pl):      Biblioteki
12 Source0:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
13 Patch0:         gdbm-info.patch
14 Patch1:         gdbm-DESTDIR.patch
15 Patch2:         gdbm-jbj.patch
16 BuildRequires:  libtool
17 BuildRequires:  autoconf
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Gdbm is a GNU database indexing library, including routines which use
22 extensible hashing. Gdbm works in a similar way to standard UNIX dbm
23 routines. Gdbm is useful for developers who write C applications and
24 need access to a simple and efficient database or who are building C
25 applications which will use such a database.
26
27 %description -l de
28 Dies ist eine Datenbank-Index-Library für Programmierer, die
29 C-Anwendungen schreiben und eine einfache und leistungsfähige
30 Datenbank benötigen oder diese in C-Anwendungen einsetzen möchten.
31
32 %description -l fr
33 Une librairie d'indexation de bases de données. Elle est utile pour
34 ceux qui désirent écrivent des applications en C et ont besion
35 d'accéder à une base de données simple et efficace ou de construire
36 une application en C qui l'utilise.
37
38 %description -l pl
39 W pakiecie znajduje siê biblioteka indeksowania bazy danych.
40 Biblioteka ta jest szczególnie uzyteczna dla ludzi, którzy pisz±
41 oprogramowanie w C i potrzebuj± prostej i szybkiej bazy danych, lub
42 dla tych którzy pisz± programy w C z wykorzystaniem tej biblioteki.
43
44 %description -l tr
45 gdbm bir veri tabaný dizinleme kitaplýðýdýr. C uygulamalarý yazýp
46 basit ve etkin bir þekilde veri tabanýna ulaþmak isteyenler için
47 yararlý olacaktýr.
48
49 %package devel
50 Summary:        development libraries and header files for gdbm
51 Summary(de):    Entwicklungs-Libraries und Header-Dateien für gdbm 
52 Summary(fr):    Bibliothèques de développement et en-têtes pour gdbm
53 Summary(pl):    Biblioteki i pliki nag³ówkowe dla gdbm
54 Summary(tr):    gdbm için baþlýk dosyalarý ve geliþtirme kitaplýklarý
55 Group:          Development/Libraries
56 Group(fr):      Development/Librairies
57 Group(pl):      Programowanie/Biblioteki
58 Requires:       %{name} = %{version}
59
60 %description devel
61 These are the development libraries and header files for gdbm, the GNU
62 database system. These are required if you plan to do development
63 using the gdbm database.
64
65 %description -l de devel
66 Dies sind die Entwicklungs-Libraries und Header-Dateien für gdbm, das
67 GNU-Datenbanksystem. Sie sind darauf angewiesen, wenn Sie vorhaben,
68 die gdbm-Datenbank für Entwicklungsarbeiten zu benutzen.
69
70 %description -l fr devel
71 Ce sont les librairies de développement et les fichiers d'en-tête pour
72 gdbm, le système de base de données GNU. Ceci est nécessaire si vous
73 désirez développer en utilisant la base de données gdbm.
74
75 %description -l pl devel
76 W pakiecie tym znajduj± siê pliki nag³ówkowe i biblioteki dla GNU
77 systemu bazy danych.
78
79 %description -l tr devel
80 GNU veri tabaný sistemi gdbm ile program geliþtirmek için gereken
81 baþlýk dosyalarý ve kitaplýklar.
82
83 %package static
84 Summary:        Static gdbm library
85 Summary(pl):    Biblioteki statyczne gdbm
86 Group:          Development/Libraries
87 Group(fr):      Development/Librairies
88 Group(pl):      Programowanie/Biblioteki
89 Requires:       %{name}-devel = %{version}
90
91 %description static
92 Static gdbm library.
93
94 %prep
95 %setup  -q
96 %patch0 -p1
97 %patch1 -p1
98 %patch2 -p1
99
100 %build
101 libtoolize --copy --force
102 aclocal
103 autoheader
104 autoconf
105 %configure
106
107 make CFLAGS="$RPM_OPT_FLAGS"
108
109 makeinfo gdbm.texinfo
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}} \
114            $RPM_BUILD_ROOT{%{_mandir}/man3,%{_infodir}}
115
116 make install \
117         prefix=%{_prefix} \
118         exec_prefix=%{_exec_prefix} \
119         binprefix=%{_exec_prefix} \
120         manprefix=%{_prefix} \
121         libdir=%{_libdir} \
122         includedir=%{_includedir} \
123         infodir=%{_infodir} \
124         man3dir=%{_mandir}/man3 \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
128
129 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/gdbm*info*,%{_mandir}/man3/*}
130
131 %post -p /sbin/ldconfig
132
133 %post devel
134 [ -x /usr/sbin/fix-info-dir ] && /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
135
136 %postun -p /sbin/ldconfig
137
138 %postun devel
139 [ -x /usr/sbin/fix-info-dir ] && /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %files
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/lib*.so.*.*
147
148 %files devel
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_libdir}/lib*.so
151 %attr(755,root,root) %{_libdir}/lib*.la
152 %{_mandir}/man3/*
153 %{_includedir}/*
154 %{_infodir}/gdbm*
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/lib*.a
This page took 0.064562 seconds and 4 git commands to generate.