]> git.pld-linux.org Git - packages/gdbm.git/blob - gdbm.spec
- added compatybility headers
[packages/gdbm.git] / gdbm.spec
1 Summary:        GNU database library for C
2 Summary(de):    GNU-Datenbank-Library für C
3 Summary(fr):    La librairie GNU de bases de données pout le langage C
4 Summary(pl):    GNU biblioteka bazy danych la jêzyka C
5 Name:           gdbm
6 Version:        1.8.0
7 Release:        7
8 License:        GPL
9 Group:          Libraries
10 Group(de):      Libraries
11 Group(fr):      Librairies
12 Group(pl):      Biblioteki
13 Source0:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-DESTDIR.patch
16 Patch2:         %{name}-jbj.patch
17 BuildRequires:  libtool
18 BuildRequires:  autoconf
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Gdbm is a GNU database indexing library, including routines which use
23 extensible hashing. Gdbm works in a similar way to standard UNIX dbm
24 routines. Gdbm is useful for developers who write C applications and
25 need access to a simple and efficient database or who are building C
26 applications which will use such a database.
27
28 %description -l de
29 Dies ist eine Datenbank-Index-Library für Programmierer, die
30 C-Anwendungen schreiben und eine einfache und leistungsfähige
31 Datenbank benötigen oder diese in C-Anwendungen einsetzen möchten.
32
33 %description -l fr
34 Une librairie d'indexation de bases de données. Elle est utile pour
35 ceux qui désirent écrivent des applications en C et ont besion
36 d'accéder à une base de données simple et efficace ou de construire
37 une application en C qui l'utilise.
38
39 %description -l pl
40 W pakiecie znajduje siê biblioteka indeksowania bazy danych.
41 Biblioteka ta jest szczególnie uzyteczna dla ludzi, którzy pisz±
42 oprogramowanie w C i potrzebuj± prostej i szybkiej bazy danych, lub
43 dla tych którzy pisz± programy w C z wykorzystaniem tej biblioteki.
44
45 %description -l tr
46 gdbm bir veri tabaný dizinleme kitaplýðýdýr. C uygulamalarý yazýp
47 basit ve etkin bir þekilde veri tabanýna ulaþmak isteyenler için
48 yararlý olacaktýr.
49
50 %package devel
51 Summary:        development libraries and header files for gdbm
52 Summary(de):    Entwicklungs-Libraries und Header-Dateien für gdbm 
53 Summary(fr):    Bibliothèques de développement et en-têtes pour gdbm
54 Summary(pl):    Biblioteki i pliki nag³ówkowe dla gdbm
55 Summary(tr):    gdbm için baþlýk dosyalarý ve geliþtirme kitaplýklarý
56 Group:          Development/Libraries
57 Group(de):      Entwicklung/Libraries
58 Group(fr):      Development/Librairies
59 Group(pl):      Programowanie/Biblioteki
60 Requires:       %{name} = %{version}
61
62 %description devel
63 These are the development libraries and header files for gdbm, the GNU
64 database system. These are required if you plan to do development
65 using the gdbm database.
66
67 %description -l de devel
68 Dies sind die Entwicklungs-Libraries und Header-Dateien für gdbm, das
69 GNU-Datenbanksystem. Sie sind darauf angewiesen, wenn Sie vorhaben,
70 die gdbm-Datenbank für Entwicklungsarbeiten zu benutzen.
71
72 %description -l fr devel
73 Ce sont les librairies de développement et les fichiers d'en-tête pour
74 gdbm, le système de base de données GNU. Ceci est nécessaire si vous
75 désirez développer en utilisant la base de données gdbm.
76
77 %description -l pl devel
78 W pakiecie tym znajduj± siê pliki nag³ówkowe i biblioteki dla GNU
79 systemu bazy danych.
80
81 %description -l tr devel
82 GNU veri tabaný sistemi gdbm ile program geliþtirmek için gereken
83 baþlýk dosyalarý ve kitaplýklar.
84
85 %package static
86 Summary:        Static gdbm library
87 Summary(pl):    Biblioteki statyczne gdbm
88 Group:          Development/Libraries
89 Group(de):      Entwicklung/Libraries
90 Group(fr):      Development/Librairies
91 Group(pl):      Programowanie/Biblioteki
92 Requires:       %{name}-devel = %{version}
93
94 %description static
95 Static gdbm library.
96
97 %prep
98 %setup  -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102
103 %build
104 libtoolize --copy --force
105 aclocal
106 autoheader
107 autoconf
108 %configure
109
110 %{__make} CFLAGS="%{!?debug:$RPM_OPT_FLAGS}%{?debug:-O -g}"
111
112 makeinfo gdbm.texinfo
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}} \
117            $RPM_BUILD_ROOT{%{_mandir}/man3,%{_infodir}}
118
119 %{__make} install install-compat \
120         prefix=%{_prefix} \
121         exec_prefix=%{_exec_prefix} \
122         binprefix=%{_exec_prefix} \
123         manprefix=%{_prefix} \
124         libdir=%{_libdir} \
125         includedir=%{_includedir} \
126         infodir=%{_infodir} \
127         man3dir=%{_mandir}/man3 \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %post devel
134 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
135
136 %postun devel
137 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %files
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/lib*.so.*.*
145
146 %files devel
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/lib*.so
149 %attr(755,root,root) %{_libdir}/lib*.la
150 %{_mandir}/man3/*
151 %{_includedir}/*
152 %{_infodir}/gdbm*
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/lib*.a
This page took 0.066314 seconds and 4 git commands to generate.