]> git.pld-linux.org Git - packages/gdbm.git/blob - gdbm.spec
- adapterized.
[packages/gdbm.git] / gdbm.spec
1 Summary:        GNU database library for C
2 Summary(de):    GNU-Datenbank-Library für C
3 Summary(fr):    La librairie GNU de bases de données pout le langage C
4 Summary(pl):    Biblioteka GNU bazy danych dla jêzyka C
5 Name:           gdbm
6 Version:        1.8.0
7 Release:        12
8 License:        GPL
9 Group:          Libraries
10 Source0:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
11 Patch0:         %{name}-info.patch
12 Patch1:         %{name}-DESTDIR.patch
13 Patch2:         %{name}-jbj.patch
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRequires:  texinfo
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Gdbm is a GNU database indexing library, including routines which use
22 extensible hashing. Gdbm works in a similar way to standard UNIX dbm
23 routines. Gdbm is useful for developers who write C applications and
24 need access to a simple and efficient database or who are building C
25 applications which will use such a database.
26
27 %description -l de
28 Dies ist eine Datenbank-Index-Library für Programmierer, die
29 C-Anwendungen schreiben und eine einfache und leistungsfähige
30 Datenbank benötigen oder diese in C-Anwendungen einsetzen möchten.
31
32 %description -l fr
33 Une librairie d'indexation de bases de données. Elle est utile pour
34 ceux qui désirent écrivent des applications en C et ont besion
35 d'accéder à une base de données simple et efficace ou de construire
36 une application en C qui l'utilise.
37
38 %description -l pl
39 W pakiecie znajduje siê biblioteka indeksowania bazy danych.
40 Biblioteka ta jest szczególnie u¿yteczna dla ludzi, którzy pisz±
41 oprogramowanie w C i potrzebuj± prostej i szybkiej bazy danych, lub
42 dla tych którzy pisz± programy w C z wykorzystaniem tej biblioteki.
43
44 %description -l tr
45 gdbm bir veri tabaný dizinleme kitaplýðýdýr. C uygulamalarý yazýp
46 basit ve etkin bir þekilde veri tabanýna ulaþmak isteyenler için
47 yararlý olacaktýr.
48
49 %package devel
50 Summary:        development libraries and header files for gdbm
51 Summary(de):    Entwicklungs-Libraries und Header-Dateien für gdbm
52 Summary(fr):    Bibliothèques de développement et en-têtes pour gdbm
53 Summary(pl):    Biblioteki i pliki nag³ówkowe dla gdbm
54 Summary(tr):    gdbm için baþlýk dosyalarý ve geliþtirme kitaplýklarý
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}
57
58 %description devel
59 These are the development libraries and header files for gdbm, the GNU
60 database system. These are required if you plan to do development
61 using the gdbm database.
62
63 %description devel -l de
64 Dies sind die Entwicklungs-Libraries und Header-Dateien für gdbm, das
65 GNU-Datenbanksystem. Sie sind darauf angewiesen, wenn Sie vorhaben,
66 die gdbm-Datenbank für Entwicklungsarbeiten zu benutzen.
67
68 %description devel -l fr
69 Ce sont les librairies de développement et les fichiers d'en-tête pour
70 gdbm, le système de base de données GNU. Ceci est nécessaire si vous
71 désirez développer en utilisant la base de données gdbm.
72
73 %description devel -l pl
74 W pakiecie tym znajduj± siê pliki nag³ówkowe i biblioteki dla systemu
75 bazy danych GNU.
76
77 %description devel -l tr
78 GNU veri tabaný sistemi gdbm ile program geliþtirmek için gereken
79 baþlýk dosyalarý ve kitaplýklar.
80
81 %package static
82 Summary:        Static gdbm library
83 Summary(pl):    Biblioteki statyczne gdbm
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}
86
87 %description static
88 Static gdbm library.
89
90 %description static -l pl
91 Biblioteka statyczna gdbm.
92
93 %prep
94 %setup  -q
95 %patch0 -p1
96 %patch1 -p1
97 %patch2 -p1
98
99 %build
100 libtoolize --copy --force
101 aclocal
102 autoheader
103 autoconf
104 %configure
105
106 %{__make} CFLAGS="%{rpmcflags}"
107
108 makeinfo gdbm.texinfo
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}} \
113            $RPM_BUILD_ROOT{%{_mandir}/man3,%{_infodir}}
114
115 %{__make} install install-compat \
116         prefix=%{_prefix} \
117         exec_prefix=%{_exec_prefix} \
118         binprefix=%{_exec_prefix} \
119         manprefix=%{_prefix} \
120         libdir=%{_libdir} \
121         includedir=%{_includedir} \
122         infodir=%{_infodir} \
123         man3dir=%{_mandir}/man3 \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %post devel
133 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
134
135 %postun devel
136 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
137
138 %files
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/lib*.so.*.*
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/lib*.so
145 %attr(755,root,root) %{_libdir}/lib*.la
146 %{_mandir}/man3/*
147 %{_includedir}/*
148 %{_infodir}/gdbm*
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/lib*.a
This page took 0.059787 seconds and 4 git commands to generate.