]> git.pld-linux.org Git - packages/gdbm.git/blob - gdbm.spec
[1.7.3-22]
[packages/gdbm.git] / gdbm.spec
1 Summary:        GNU database library for C
2 Summary(de):    GNU-Datenbank-Library für C
3 Summary(fr):    La librairie GNU de bases de données pout le langage C.
4 Summary(pl):    GNU biblioteka bazy danych la jêzyka C
5 Name:           gdbm
6 Version:        1.7.3
7 Release:        21
8 Copyright:      GPL
9 Group:          Libraries
10 Group(pl):      Biblioteki
11 Source:         ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
12 Patch0:         gdbm-shlib.patch
13 Patch1:         gdbm-info.patch
14 Patch2:         gdbm-configure.patch
15 Buildroot:      /tmp/%{name}-%{version}-root
16
17 %description
18 This is a database indexing library. It is useful for those who need 
19 to write C applications and need access to a simple and efficient
20 database or build C applications which use it.
21
22 %description -l de
23 Dies ist eine Datenbank-Index-Library für Programmierer, die 
24 C-Anwendungen schreiben und eine einfache und leistungsfähige
25 Datenbank benötigen oder diese in C-Anwendungen einsetzen möchten.
26
27 %description -l fr
28 Une librairie d'indexation de bases de données. Elle est utile pour ceux
29 qui désirent écrivent des applications en C et ont besion d'accéder à
30 une base de données simple et efficace ou de construire une application
31 en C qui l'utilise.
32
33 %description -l pl
34 W pakiecie znajduje siê biblioteka indeksowania bazy danych. Biblioteka
35 ta jest szczególnie uzyteczna dla ludzi, którzy pisz± oprogramowanie w C
36 i potrzebuj± prostej i szybkiej bazy danych, lub dla tych którzy pisz±
37 programy w C z wykorzystaniem tej biblioteki. 
38
39 %description -l tr
40 gdbm bir veri tabaný dizinleme kitaplýðýdýr. C uygulamalarý yazýp basit ve
41 etkin bir þekilde veri tabanýna ulaþmak isteyenler için yararlý olacaktýr.
42
43 %package devel
44 Summary:        development libraries and header files for gdbm
45 Summary(de):    Entwicklungs-Libraries und Header-Dateien für gdbm 
46 Summary(fr):    Bibliothèques de développement et en-têtes pour gdbm
47 Summary(pl):    Biblioteki i pliki nag³ówkowe dla gdbm
48 Summary(tr):    gdbm için baþlýk dosyalarý ve geliþtirme kitaplýklarý
49 Group:          Development/Libraries
50 Group(pl):      Programowanie/Biblioteki
51 Requires:       %{name} = %{version}
52 Prereq:         /sbin/install-info
53
54 %description devel
55 These are the development libraries and header files for gdbm, the
56 GNU database system.  These are required if you plan to do 
57 development using the gdbm database.
58
59 %description -l de devel
60 Dies sind die Entwicklungs-Libraries und Header-Dateien für gdbm, das
61 GNU-Datenbanksystem. Sie sind darauf angewiesen, wenn Sie vorhaben,
62 die gdbm-Datenbank für Entwicklungsarbeiten zu benutzen.
63
64 %description -l fr devel
65 Ce sont les librairies de développement et les fichiers d'en-tête pour gdbm,
66 le système de base de données GNU. Ceci est nécessaire si vous désirez 
67 développer en utilisant la base de données gdbm.
68
69 %description -l pl devel
70 W pakiecie tym znajduj± siê pliki nag³ówkowe i biblioteki dla GNU
71 systemu bazy danych.
72
73 %description -l tr devel
74 GNU veri tabaný sistemi gdbm ile program geliþtirmek için gereken baþlýk
75 dosyalarý ve kitaplýklar.
76
77 %package static
78 Summary:        Static gdbm library
79 Summary(pl):    Biblioteki statyczne gdbm
80 Group:          Development/Libraries
81 Group(pl):      Programowanie/Biblioteki
82 Requires:       %{name}-devel = %{version}
83
84 %description static
85 Static gdbm library.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92
93 %build
94 mkdir shared
95 aclocal
96 autoheader
97 %configure
98
99 make CFLAGS="$RPM_OPT_FLAGS"
100 make CFLAGS="$RPM_OPT_FLAGS" shared
101
102 makeinfo gdbm.texinfo
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT/usr/{lib,include,info,man/man3}
107
108 make install prefix=$RPM_BUILD_ROOT/usr
109
110 ln -sf libgdbm.so.2.0.0 $RPM_BUILD_ROOT/usr/lib/libgdbm.so
111
112 strip --strip-unneeded $RPM_BUILD_ROOT/usr/lib/lib*.so.*.*
113
114 gzip -fn9 $RPM_BUILD_ROOT/usr/{info/gdbm*info*,man/man3/*}
115
116 %post -p /sbin/ldconfig
117
118 %post devel
119 /sbin/install-info /usr/info/gdbm.info.gz /etc/info-dir
120
121 %postun -p /sbin/ldconfig
122
123 %preun devel
124 if [ "$1" = "0" ]; then
125         /sbin/install-info --delete /usr/info/gdbm.info.gz /etc/info-dir
126 fi
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files
132 %defattr(644,root,root,755)
133 %attr(755,root,root) /usr/lib/lib*.so.*.*
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) /usr/lib/lib*.so
138 /usr/man/man3/*
139 /usr/include/*
140 /usr/info/gdbm*
141
142 %files static
143 %defattr(644,root,root,755)
144 /usr/lib/lib*.a
145
146 %changelog
147 * Thu Apr 29 1999 Artur Frysiak <wiget@pld.org.pl>
148   [1.7.3-22]
149 - used %%configure macro
150 - added gdbm-configure.patch
151
152 * Sun Mar 14 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
153   [1.7.3-21]
154 - added --strip-unneeded parameter on striping shared libraries,
155 - removed man group from man pages.
156
157 * Mon Jan 04 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
158   [1.7.3-20]
159 - standarized {un}registering info pages (added gdbm-info.patch),
160 - added gzipping man pages.
161
162 * Sun Nov 22 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
163   [1.7.3-19]
164 - removed "Prereq: /sbin/install-info" from static,
165 - fixed --entry text on {un}registering info page for ed in %post
166   %preun in devel.
167
168 * Wed Sep 30 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
169 - build against glibc-2.1,
170 - translation modified for pl.
171
172 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
173   [1.7.3-18]
174 - added -q %setup parameter,
175 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
176 - added using %%{name} and %%{version} in Source,
177 - added static subpackage,
178 - changed dependencies to "Requires: %%{name} = %%{version}" in devel
179   subpackage,
180 - added stripping shared libraries,
181 - added %attr and %defattr macros in %files (allows build package from
182   non-root account).
183
184 * Thu May 07 1998 Prospector System <bugs@redhat.com>
185 - translations modified for de, fr, tr
186
187 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
188 - gdbm-devel moved to Development/Libraries
189
190 * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
191 - buildroot and built for Manhattan
192
193 * Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
194 - spec file cleanups
195
196 * Thu Jun 12 1997 Erik Troan <ewt@redhat.com>
197 - built against glibc
This page took 0.074865 seconds and 4 git commands to generate.